Youtube stuttering and frame dropping or skipping issues



  • Ok, so I have read a few random post around the forum about people having performance issues watching videos on YouTube, and maybe more.

    I have been experiencing these too for a few versions now, but unfortunatey no word from the developers on that front. From what I'm told they can't really reproduce the error so they cannot fix what can't be tested.

    I am creating this thread in the hopes that anyone with YouTube video stuttering issues, dropped or skipped frames, low performance or bad frame rates would post as thorough details as possible to try and get this solved if possible.

    So my system specs are Windows 7 64bits, Intel Core i7 2600k 16Gb RAM, NVidia GT580 + GT980ti, dual monitor setup 2560x1600 x2 each monitor connected to each card. Here's what else I could find out.

    • I have never experienced any stuttering before with any dedicated video player software or other browsers
    • Videos randomly stutter or not, can't reproduce reliably, some times only HD or high-res misbehave, some other times low quality too.
    • Pausing and playing the video seems to fix the issue.
    • Moving the browser window from monitor 2 to monitor one and back seems to alleviate the issue.
    • Full-screening also seems to fix the issue, reverting brings stuttering back
    • Whole page rendering seems to stutter, but not Vivaldi UI itself, or other tabs.
    • Scrolling the video out of view also eliminates the stuttering while video is offscreen.

    Here are some random video where the problem happened from me, i'll test again later see if the frame dropping persists on the same video. https://www.youtube.com/watch?v=60ItHLz5WEA and https://www.youtube.com/watch?v=6SUj7nRmX0E



  • @duarte.framos 1.9 Worked for a while with U.tube on Mac, then went out to lunch and never came back. https://youtu.be/RbUMKenn5l8



  • Forgot to mention this seems to happens exclusively in "Cinema Mode", Fullscreen mode and default view are mostly not affected



  • @duarte.framos

    Same here, just registered here because of that annoying problem what is now for at least two versions :grey_exclamation:

    My Setup: HP Notebook, Windows 10 Home 64bit with AMD A10-9600P, Radeon R5 and R8 M445DX and 16GB RAM and SSD Hard Drive.

    Never ever had any problems with Video playback on any other browser. Only with Vivaldi. Why we can reproduce the problem but the developers can't? Yeah sure....

    This problem makes me almost change from vivaldi to another browser, so fix it!



  • @Ameisenwuerger Ohh now they will be surely motivated to fix it despite the multiple reports done in the past, well done :rolling_eyes:


  • Moderator

    Strange for me inspecting nerd statistics on YT videos.
    On my NVidia GT700 a Fullscreen HD has less drops than a smaller windowed view.


  • Moderator

    @Ameisenwuerger said in Youtube stuttering and frame dropping or skipping issues:

    Never ever had any problems with Video playback on any other browser. Only with Vivaldi. Why we can reproduce the problem but the developers can't? Yeah sure....

    Testers and developers can not reproduce all problems of Vivaldi + video driver and hardware issues.

    If you found a bug, please report the issue to the developers to fix it.

    How to do a bugreport for Vivaldi
    Report every bug seperately at https://vivaldi.com/bugreport/
    Describe the issue as precise as you can.
    If you use any extensions please give information which ones you use.
    If you have a URL or a own testpage which can checked, add it to the bugreport.
    If you have own testcase files (HTML, CSS, JS etc.) add them to the confirmation mail you get after report.
    If you have a screenrecording video, you can attach it to give the developers a hint how this might happen or look like.
    You will get a bug confirmation mail and in a reply to this mail you can add more information and files as attachments for the testers and bug tracking team.

    Thanks in advance for helping us to make Vivaldi better!




  • Where is the Cinema mode?



  • @liyin It's actually "Theater mode", the button on the left of full screen mode button in YT videos



  • That's the viewing mode I prefer. Tried those 2 videos without issues.



  • My only "problem" with dropped frames are 60fps videos, no single drop from normal 720@30fps. The workaround is to watch them in full screen or even just by hiding the tab bar (alt-shift-t for me)
    https://forum.vivaldi.net/topic/11638/vivaldi-and-youtube-stutter-and-dropped-frames



  • <speculation> Could it be related to the animated sound icon drawn in the tab?
    I seem to see a noticeable difference in playback fluidity when I mute the sound of the tab, and hence the animated icon stops moving and is replaced by the mute icon.
    This would be in line with @iAN-CooG remark that hiding the tab bar seems to alleviate the stuttering. </speculation>



  • OK, it definitely seems related, muting a stuttering video seems to speed it up, and even non stuttering videos seem more fluid when the sound icon is not animating. It doesn't seem to be sound related directly, more cause by the animated sound icon drawn in the tab bar.

    Hope this helps the developers narrow down the issue.



  • @duarte.framos I doubt that the tab's sound animation maybe one of the root cause. From your description, It can be recovered by some action (ex: pause -> replay). I have tried to reproduce this issue on my three computers, but can't reproduce. It seems base on some condition.
    Could you do me a favor ? I can give you some steps to record trace, which maybe more clear to find out the root cause.



  • @duarte.framos said in Youtube stuttering and frame dropping or skipping issues:

    NVidia GT580 + GT980ti, dual monitor setup 2560x1600 x2 each monitor connected to each card

    Most people have one GPU.



  • @liyin said in Youtube stuttering and frame dropping or skipping issues:

    Most people have one GPU.

    I do a lot of 3D model rendering using Blender, so I upgraded some time ago and kept both GPUs in because they provide a significant speed boost under Cycles render engine.

    If it is relevant they are in a non-SLI config, that is each one is installed independently, and each monitor connected to each graphics card.



  • @WillyYu

    @WillyYu said in Youtube stuttering and frame dropping or skipping issues:

    Could you do me a favor ? I can give you some steps to record trace, which maybe more clear to find out the root cause.

    Certainly, I'm up for it if it helps fix problem. Just let me know what to do.



  • @Gwen-Dragon said in Youtube stuttering and frame dropping or skipping issues:

    Strange for me inspecting nerd statistics on YT videos.
    On my NVidia GT700 a Fullscreen HD has less drops than a smaller windowed view.

    Same here. Lotsa dropped frames windowed, hundreds, almost none in fullscreen. Also seems to increase with rapid mouse movement. Tested the same video posted earlier (https://youtu.be/RbUMKenn5l8) in Firefox and not a single (not one!) dropped frame no matter what i tried. Bouncing the scrollbar up and down, moving the window all over the place; Nothing. There's definitely something going on.

    Maybe it matters that one is PPAPI and the other NPAPI?

    I'm on 1.9.818.44 (Stable channel) (64-bit) by the way.


  • Moderator

    @mdnjou No, Youtube des not use Flash Player and so PPAPI or NPAPI does not matter, and HTML5 video and audio technology do not need Flash content.



  • composer.user_said_in

    OK, it definitely seems related, muting a stuttering video seems to speed it up, and even non stuttering videos seem more fluid when the sound icon is not animating. It doesn't seem to be sound related directly, more cause by the animated sound icon drawn in the tab bar.

    Hope this helps the developers narrow down the issue.

    Good find, that's it: I've disabled "use animation" in settings/appereance, and now I got ONLY 4 dropped frames after 2000 frames played on ANY 720@60 fps video, watched in normal Youtube window with tab bar visible, full screen, HW decode enabled or disabled.
    Now watching
    https://www.youtube.com/watch?v=-Yi9f4idKpU (vp9/webm)
    https://www.youtube.com/watch?v=wL1mreUL4LU (mp4/avc1)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.