Video stuttering/dropped frames on Youtube only



  • For the past month since the last upgrade I've been experiencing stuttering videos sometimes on Youtube. It's not all videos, but certain ones. And usually happen if I go beyond 720p on those videos. I currently have an i7 5820k, 32 gb of RAM and a 970 gtx video card, with an 80 Mbps connection.


  • Vivaldi Team

    Hi, I've sadly not been able to reproduce this myself, could I ask, what kind of extensions are you using? Have you tried it with a clean profile? Are you seeing the same issue in any other browser? Finding what causes this would be great, as we don't have any solid steps to reproduce at the moment.



  • @AT2016:

    For the past month since the last upgrade I've been experiencing stuttering videos sometimes on Youtube. It's not all videos, but certain ones. And usually happen if I go beyond 720p on those videos.

    I currently have an i7 5820k, 32 gb of RAM and a 970 gtx video card, with an 80 Mbps connection.

    Go to Settings of your YouTube profile and enable HTML5. It will only work for videos uploaded after 2005 (if I remember correctly). That stuttering is caused by Adobe Flash Player. I had the same problem long ago and it disappeared when I enabled HTML5. And in order to avoid stuttering, I choose to watch videos uploaded after 2005.



  • @Aronand:

    Hi, I've sadly not been able to reproduce this myself, could I ask, what kind of extensions are you using? Have you tried it with a clean profile? Are you seeing the same issue in any other browser? Finding what causes this would be great, as we don't have any solid steps to reproduce at the moment.

    Just uBlock Origin. Disabling it delivers the same issue on specific videos. I've watched other 4K videos without any trouble, but sometimes the browser will have issues with certain uploads. The problem persists on a new profile as well. The video stutter is not present in Firefox stable and developer, Chrome x64, Chromodo, or Opera. Initially I thought it was a loading issue, but the video will buffer considerably but stop playing back when half the video has loaded or it'll stutter severely. Dropping it down to 720p causes the video to play back normally. Disabling v-sync doesn't help either. I'm able to repeat the problem on my other computers as well.

    @rado84:

    @AT2016:

    For the past month since the last upgrade I've been experiencing stuttering videos sometimes on Youtube. It's not all videos, but certain ones. And usually happen if I go beyond 720p on those videos.

    I currently have an i7 5820k, 32 gb of RAM and a 970 gtx video card, with an 80 Mbps connection.

    Go to Settings of your YouTube profile and enable HTML5. It will only work for videos uploaded after 2005 (if I remember correctly). That stuttering is caused by Adobe Flash Player. I had the same problem long ago and it disappeared when I enabled HTML5. And in order to avoid stuttering, I choose to watch videos uploaded after 2005.

    These are 1080p60, 1440p60 and 2160p60 (4K) videos uploaded recently. HTML5 is on by default. H.264, HTMLVideoElement, WebM VP8, MSE and H.264 and MSE and WebM VP9 are all enabled. Enabling "Stats for Nerds" I can see huge frame drops corresponding to the video stutter. Youtube turned HTML5 on globally last year.



  • @AT2016:

    For the past month since the last upgrade I've been experiencing stuttering videos sometimes on Youtube. It's not all videos, but certain ones. And usually happen if I go beyond 720p on those videos.

    I currently have an i7 5820k, 32 gb of RAM and a 970 gtx video card, with an 80 Mbps connection.

    A few questions :
    What is your Vivaldi version (and is it 32 or 64 bit)?
    Also, links to a couple of these "problem" videos would be useful too.
    Are you logging in to Youtube or viewing as a guest?



  • @TbGbe:

    @AT2016:

    For the past month since the last upgrade I've been experiencing stuttering videos sometimes on Youtube. It's not all videos, but certain ones. And usually happen if I go beyond 720p on those videos.

    I currently have an i7 5820k, 32 gb of RAM and a 970 gtx video card, with an 80 Mbps connection.

    A few questions :
    What is your Vivaldi version (and is it 32 or 64 bit)?
    Also, links to a couple of these "problem" videos would be useful too.
    Are you logging in to Youtube or viewing as a guest?

    Sure

    1. Vivaldi 1.2.490.43 () (32-bit)
    2. Here's one video. It works fine under 720p60, but stutters like mad at anything above. It works fine in all browsers.

    https://www.youtube.com/watch?v=Zf1_-8kxxiA

    I'm having the same issue on other computers using this version of Vivaldi. I first noticed the problem a month ago while watching some Indy Car race clips and driver segments shot at 1080p and 4K. I didn't have the issue in other browsers as well.

    Logged in or as a guest, the playback quality is the same. I've even wiped my cookies and user profile on other computers and still managed to have this problem. I went ahead and updated my video card's drivers this morning and did a clean install, but still have the same issue.

    I can try and make some time tomorrow to figure out a way to do a screen capture if that would help you guys. Just let me know if you want the stats for nerds popup on youtube open too! :)



  • Sorry, but I can't reproduce the problem @1080p with that video using Vivaldi 1.2.490.43 () (32-bit) on Win64 pro (with Ublock and Ghostery enabled - youtube is NOT whitelisted).
    I also tried viewing it full screen - no problem.
    Also tried the DOOM video ( https://www.youtube.com/watch?v=FzgTCoCOACA ) again @1080p, no problems.



  • I've been having the same issue on both Vivaldi and Chrome, but not on Edge. It only stutters at 1440p and 2160p for me, but it's bad enough that I can't stand to use Vivaldi for YouTube.

    I have 60Mbps down, and my computer has an i7-4700MQ, 8GB of memory, and HD4600 graphics. Each browser is up to date.



  • I can see videos well on youtube, I've seen 720p, 1080p, 4k, 360 videos… all times fine.its not something to do with your extensions or youtube configuration? -> I forgot I used Firefox yesterday to see those LOL. so I went on checking on youtube that issue, and actually on the stable release of Vivaldi, the only options given to me are 480 and 720p, nothing less, nothing more.



  • Hi, just for info, as I have no problems with snapshot 1.3.551.13 and stable 1.3 is just around the corner it is may easier to wait for Vivaldi 1.3.

    Cheers, mib



  • I think I had the same issue. My solution was disabling hardware acceleration in Vivaldi.

    https://vivaldi.net/en-US/forum/vivaldi-browser/10458-hardware-acceleration

    @Gwen-Dragon:

    Open vivaldi://chrome/settings/search#hardw
    Deselect it
    Close Settings

    Long story is I noticed that youtube videos that were 1080p60fps AND using codec webm (right click the video, "stats for nerds") were fine and not very taxing to my GPU (monitoring my GPU Engines with Process Explorer). Then I noticed that 1080p60fps videos that used some different codecs were choking my GPU to death. So I disabled hardware acceleration and saw in Windows Task Manager that my CPU could handle both codecs much better than my GPU.

    I don't have a 4K monitor so I never dabbled with 4K videos. Hopes this helps someone.


  • Banned

    This post is deleted!

Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.