Auto hide bookmark bar



  • I think if there vivaldi auto hide the bookmarks bar would be great. I tried custom css vivaldi and this is my result [attachment=2498]test.gif[/attachment] This is my css was using [code]/Auto hide bookmark bar/ .toolbar{ z-index: 2; } .bookmark-bar{ position: fixed !important; width: 100%; transform: translateY(-100%); transition: transform 0.2s !important; z-index: 1; } .bookmark-bar:hover{ transform: translateY(0); } .toolbar:hover ~ .bookmark-bar{ transform: translateY(0); } #header:hover ~ #main .bookmark-bar{ transform: translateY(0); } .webpanel-header{ z-index: 0; }[/code] Attachments: [img]https://forum.vivaldi.net/uploads/attachments/71083/test.gif[/img]



  • Nice.

    I suggested a similar function for the whole address bar, but makes sense also for the bookmark bar alone.



  • sorry, my english is not very well. You can tell more detail. I really do not quite understand



  • @tam710562:

    sorry, my english is not very well. You can tell more detail. I really do not quite understand

    It was just an appreciation comment.

    I added that I suggested (months ago) a similar feature for the address bar alone, that's all ;)



  • Hi tam710562

    Thank you for creating this css. I also would like this to become a Vivaldi option [eg, Slimjet does it]. I copied your css text into my Linux Mint text editor [Kate], saved it as "Auto hide bookmark bar.css", moved it into /opt/vivaldi-snapshot/resources/vivaldi/user_files/, then restarted Vivaldi-Snapshot. The bookmark bar did not auto-hide. I closed V again, & moved it into /opt/vivaldi-snapshot/resources/vivaldi/style/ & restarted Vivaldi-Snapshot. The bookmark bar still did not auto-hide.

    Can you please tell me where i need to move this file, & is there anything else i also need to do for it to work? I'm not a programmer, have never worked with css files before, & so probably i've made some silly error or misunderstanding here.



  • @Steffie:

    Hi tam710562

    Thank you for creating this css. I also would like this to become a Vivaldi option [eg, Slimjet does it]. I copied your css text into my Linux Mint text editor [Kate], saved it as "Auto hide bookmark bar.css", moved it into /opt/vivaldi-snapshot/resources/vivaldi/user_files/, then restarted Vivaldi-Snapshot. The bookmark bar did not auto-hide. I closed V again, & moved it into /opt/vivaldi-snapshot/resources/vivaldi/style/ & restarted Vivaldi-Snapshot. The bookmark bar still did not auto-hide.

    Can you please tell me where i need to move this file, & is there anything else i also need to do for it to work? I'm not a programmer, have never worked with css files before, & so probably i've made some silly error or misunderstanding here.

    you can see how to add css in vivaldi at https://vivaldi.net/es/forum/all/3073-vivaldi-ui-customisations



  • Thanks for your fast reply. Ahhhhh, i see, so i would have to remember to do these, EVERY time another V SS is released:

    1. Open common.css and add this at the beginning of the file:
    @import "custom.css";
    2. Open browser.html and add this line after the first tag:

    Nah, too much like hard work. I'll just have to wait til this becomes another standard option built into V.

    Many thanks all the same.



  • I need that option too, Vivaldi please give us an option to auto hide bookmarks bar.



  • Yes, this is a common-sense addition.



  • How can I use with this?

    /* Auto hide bookmark bar
    .toolbar{
    	z-index: 1;
    }
    
    .bookmark-bar{
    	position: fixed !important;
    	width: 100%;
    	transform: translateY(-100%);
    	transition: transform 0.2s !important;
    	z-index: 1;
    }
    
    .bookmark-bar:hover{
    	transform: translateY(0);
    }
    
    .toolbar:hover ~ .bookmark-bar{
    	transform: translateY(0);
    }
    
    #header:hover ~ #main .bookmark-bar{
    	transform: translateY(0);
    }
    
    .webpanel-header{
    	z-index: 0;
    }
    */
    
    


  • I think I would find autohide of the Bookmarks Bar annoying, but perhaps in fullscreen mode autohide of the address bar would be useful. Currently, shortcuts don't work in fullscreen mode to show the Bookmarks Bar or Address Bar. Opera 12.17 is also problematic in this respect.

    In Opera 12.17 I have both a shortcut (b,b) and a mouse gesture (Up/Down) to show the Bookmarks Bar for 5 seconds. I browse with it off, and show it when I need it. The problem I see with the Autohide solution is that it's going to show up very frequently when you don't need it, every time you move the mouse cursor up to the tabs or the URL field.

    I had already assigned GestureUp, GestureDown to show/hide the bookmarks bar, but I usually browse with the Bookmarks Bar enabled, so I don't use it much.

    I found that the shortcut "B" could be assigned to toggle it off/on. That's even easier to use than the mouse gesture and does not stop me from typing any word with a "B" in it, without triggering the bookmark bar toggle.



  • I didn't consider the gesture.
    Also a unique combo to hide vivaldi bar+bookmark+tabs+urlbar to maximize area is an idea.
    The fact is I almost never use the browser in fullscreen: most of time I use it in half screen (32'' monitor tv) or even in quarter. =D



  • To see the feature in action, check out Slimjet. It can be on autohide on top or the side, which would solve the above-mentioned problem of it showing up whenever you access tabs (with tabs on top). It's always nice to have options.

    Edit: I forgot about Cent. It has the "Show bookmarks when mouse hovered within X" feature, which solves the problem of bookmarks showing up when accessing tabs.



  • I too would love to have auto-hiding bookmarks bar as a built in feature, as I am currently doing this with custom CSS as well. Fading in the bar is much more preferable to sliding it in however, as the icons are recognizable faster and you can clearly see their entire target area.



  • Hi.

    Thanks for creating this css. :)

    It's not working for me. It's always showing and collapses if I touch the Adress bar. Its also hovering over the Tab bar and not like on the screenshot. Is there a way to fix it?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.