Thunderbird eMail links



  • Mozilla Thunderbird eMail links default to FireFox.
    ( thus ignoring the 'my default browser is vivaldi' )
    Here's a fix....

    Go to Thunderbird Menu: Edit-->Preferences Click Config Editor Hit Ok
    Search for the following 3 entries:
    network.protocol-handler.warn-external.http
    network.protocol-handler.warn-external.https
    network.protocol-handler.warn-external.ftp
    and double click to true.
    end.

    Now- Thunderbird goto /edit /preferences
    Edit Preferences
    Change HTML Action & https to 'use other' value vivaldi

    ( html links will now link to vivaldi )



  • @IronTom said in Thunderbird eMail links:

    network.protocol-handler.warn-external.http

    Yeah, nahhh. Mine already works fine when i run V naked, but given i eschew that as a matter of principle & run all my browsers [& heaps of other pgms too] in Firejail, this does not work for me. I struggled with this issue for a couple of years, on & off, always supposing the problem was Vivaldi or Thunderbird, or both. One day it occurred to me [hand, meet forehead] that it was probably neither but instead simply FJ just doing its job... which i then proved by closing V & relaunching it naked then retrying some TB email links. Pity.



  • @IronTom said in Thunderbird eMail links:

    Now- Thunderbird goto /edit /preferences
    Edit Preferences
    Change HTML Action & https to 'use other' value vivaldi

    I can't seem to find this? I don't see Edit Preferences in Preferences.

    But it still works, after I changed them to true I just clicked on a link and a window popped up asking which app to use but I still can't find the HTML Action.

    I'm using Thunderbird 60.3.1 (64-bit)



  • @troypulk said in Thunderbird eMail links:

    I can't seem to find this?

    There was a slight inaccuracy; try this:

    0_1544157401862_20181207_002.png

    IMO it's not a very intuitive tab for those settings.


  • Moderator

    As i know since years, i always had to change the handlers in Thunderbird to open the correct browser.
    Thunderbird used its own settings and ignored OS settings. Bad attitude.



  • Thank you,

    I totally over looked that Tab


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.