Swipe sensitivity with Magic Mouse

  • I think that the sensitivity when swiping on the surface of Apple MagicMouse is bad(short? small?). If I swipe like any other application, Vivaldi will not react. I swipe my finger about 3/4 and finally the page transition icon is displayed. Can I adjust this sensitivity?

    macOS 10.13.5, Vivaldi 1.15.1147.55

  • Moderator

    @izacks I'm not sure what can be done to adjust the sensitivity on the Magic Mouse specifically. However, I know how you feel because I've filed bugs in the past when swipe gestures don't trigger correctly.

    Right now, with Vivaldi 1.16, the swipe gestures react for me like they do in Chrome/Chromium: it only takes a slight flick to trigger. Another bug also just got fixed internally where swipe gestures don't trigger on some web pages.

    Vivaldi 1.16 is getting close to being released and hopefully it will work better for you in this regard. Please let us know either way.

  • I became completely unaware of Magic Mouse 's gesture and swipe since Vivaldi 2.0.

  • @izacks

    What do you mean? Do they not work? If that is the case take a look at my Thread here:


    Just wait until 2.2 is released and it should work again.

  • @gixxa As I often see it scrolls in x and y directions only a little. I can not swipe and move pages. MagicTrackpad is in a similar state, but it can swip back and forth in history by swiping.

  • @izacks

    Sadly I still don't understand what you mean. With the current snapshot however I do not have any problem mit my Trackpad on a MacBook Pro 2017 13".

  • I updated to Ver.2.2, but there was still no change.

    There is something I think is strange. Within Vivaldi's preferences, the left and right swipe of MagicMouse / MagicTrackpad is recognized normally. I just swiped a little bit and the "back (arrow)" icon is displayed on the left.
    Of course I tried ON/OFF of the gesture function, but there is no change at all.

    Is it a new feature of Ver.2.2?
    It seems that it has become possible to adjust the reaction size area of the gesture. But it does not affect MagicMouse at all.

  • Moderator

    @izacks Vivaldi's "Mouse Gesture" settings don't affect swipe gestures on the Magic Mouse or TrackPad; they only affect how Vivaldi's "right-click" Gestures trigger.

  • Are there few users using Vivaldi with MagicMouse/TrackPad? Or is this a limited issue due to my own environment?

  • Moderator

    @izacks I personally use both the TrackPad and Magic Mouse and as an internal tester, I'm typically the first to report bugs whenever swiping or scrolling doesn't "feel right". My benchmarks are to compare Vivaldi's performance with Safari and Chrome. I haven't run into any problems with scrolling or swipe gestures in months.

  • @xyzzy So should I recognize this as a problem only for me?
    Although I do not change the state even if I start Mac in safe mode, I do not know which setting of Mac is interfering with. Of course I am also trying to delete all Vivaldi related files.

    The swipe operation seems to be problematic in Vivaldi's environment settings, and there is a problem with the main contents display. Is this caused by the OS, or is it a problem of setting Vivaldi?

  • Moderator

    @izacks Do swipe gestures work for you in Safari? I'm not sure what could be going on with your Mac but all I can say is that swipe gestures work perfectly fine for me in Safari, Vivaldi, Chrome, and Firefox.

  • @xyzzy I work perfectly with Safari, Sleipnir, Firefox, Brave.

  • Moderator

    @izacks The culprit could be a problematic extension. I'd first try disabling all extensions to see if the problem goes away.

    It's also possible that your Vivaldi installation could have gotten messed up in some way. Rather than doing a full reset, you can try to clean/refresh your Vivaldi profile.

  • @izacks I seem to have very similar problem since updating to 2.2.1388.34.

    MagicMouse gestures (back, forward swipes) are not being recognised at all.
    Those gestures still work in all other browsers.

    UPDATE: Cleaning my Vivaldi profile like @xyzzy suggested did not help, the gestures on the MagicMouse still have no effect.

  • I understood the cause. The cause was "smooth scroll add-on". I was not trying to use this, so I did not notice it. Vivaldi Mac version forcibly installs the smooth scroll add-on after installation or update. Even if I do not want to use it, it is forced to be in the "Enable" state. I completely forgot about this. I deleted this add-on, and the swipe problem was solved.

    Certainly the scrolling of Vivaldi Mac around Ver.1.3 was bad. But now it has improved a lot. I would like to change to an optional installation rather than a forced installation.

  • @izacks happy that solved it for you.
    Do mean to say that you have disabled the "Smooth Scrolling" setting on the Webpages tab (see below)?

    That setting was already disabled on my side but the problem still persists.

    0_1545042001211_Screenshot 2018-12-17 at 10.17.08.png

  • Moderator

    @nito FYI, I don't think that "Smooth Scrolling" is actually functional on macOS. Apparently, all the option does is control whether Vivaldi gets started with the --disable-smooth-scrolling paremeter. However, since the vivaldi://flags/#smooth-scrolling flag is not available on Mac, the corresponding command line switch will not have any effect.

  • @nito What I am talking about is not smooth scrolling of the preferences. I have noticed the existence now. When I install Vivaldi, I recommend installing the application to macOS by Vivaldi. I think that it is an add-on attached to it.


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.