YouTube Side Panel doesn't work properly (redirect to desktop version)



  • after last updates I've detect that YouTube on side panel doesn't work right
    I try many options, and unfortunately it did not succeed
    YouTube on side panel automatically switches to desktop version, and if I switch it back manually it also switch on main panel.

    0_1521885524372_Screenshot_1.png

    0_1521885192920_Screenshot_6.png

    0_1521885247036_Screenshot_3.png

    0_1521885269311_Screenshot_4.png

    that text show me on top (on side panel)
    "We've redirected you to the desktop website. Return to mobile YouTube"
    https://m.youtube.com/?app=m&persist_app=1
    0_1521884847621_Screenshot_1.png

    I also suspect that this problem evoke by Google (YouTube) - and if that is the case I beg you fix this problem (because I lOVE VIVALDI SIDE PANEL)

    0_1521885295661_Screenshot_2.png



  • @if-sergiy You are doing this far too complicated. Load the youtube video you want in a tab, right click to add the page to the panel. Once it's in the panel it should automatically show you the mobile version. This way you have the desktop version in the tab and the mobile version in the panel.


  • Moderator

    Click on + in panel bar
    Enter https://m.youtube.com/ as address
    You get the mobile view
    And it stays in mobile view for me on 1.14 Stable.



  • @gwen-dragon

    reading your answers I'm feel like a nooby, seriously guys I'm glad that you're answered, but it seems like you don't really read my question.

    just quick about me - I'm not the guy who text on forum at the first need. I've try review everything in details; make some screenshots; describe problems in the details... etc

    ok I make some .gif file

    YouTube on side panel automatically switches to desktop version
    that text show me on top (on side panel)
    "We've redirected you to the desktop website. Return to mobile YouTube"

    alt text

    if I click on "Return to mobile YouTube" than main panel change to mobile version too

    alt text

    change manually to desktop version on main panel, than after restart browser everything is repeated

    alt text



  • @if-sergiy Looks like YouTube is using a cookie to determine whether you should get the desktop or mobile sites rather than by a domain (like a sane website like wikipedia would do).

    Microsoft Outlook does this as well, and it can get confusing. Unfortunately, I'm not sure if there is a way to fix this.



  • @if-sergiy the problem only exists if the mode is set explicitly in the youtube cookie (PREF → app=desktop).

    By default no mode is preselected and YouTube shows different modes for side panel (mobile version) and main page. So if the mode is never set explicitly the problem does not exist and can not be reproduced.

    Clearing the YouTube-cookie (Settings → privacy → cookies → .youtube.com → PREF), you will lose some YT-related settings and current login state) and never explicitly set the mode might be the only viable way to avoid the problem. All (future) technical fixes (from the browser side) will break other functionality.

    If you switch the side panel to desktop and back to mobile mode it may take some requests (maybe referrer related) to settle all views on the new mode.



  • @becm That's why I couldn't reproduce the problem, I always use a clean youtube.



  • @becm said in YouTube Side Panel doesn't work properly (redirect to desktop version):

    @if-sergiy the problem only exists if the mode is set explicitly in the youtube cookie (PREF → app=desktop).

    By default no mode is preselected and YouTube shows different modes for side panel (mobile version) and main page. So if the mode is never set explicitly the problem does not exist and can not be reproduced.

    Clearing the YouTube-cookie (Settings → privacy → cookies → .youtube.com → PREF), you will lose some YT-related settings and current login state) and never explicitly set the mode might be the only viable way to avoid the problem. All (future) technical fixes (from the browser side) will break other functionality.

    If you switch the side panel to desktop and back to mobile mode it may take some requests (maybe referrer related) to settle all views on the new mode.

    thanks dude! that really help me. thanks a lot



Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.