Tearing on fullscreen video - youtube, twitch, etc.



  • Hi, recently I've started experiencing video tearing when watching videos in fullscreen. The problem occurs only in Vivaldi, on two different systems I'm using, one of which had a fresh windows install a week ago.



  • @silly_regex What is video tearing? If you mean flickering, that can be fixed by disabling hardware acceleration.



  • Something like this - looks like different video frames are being spliced together.

    0_1494959331469_upload-9661c808-a7ec-4f5b-afe8-da9cbd18736c



  • I'm sorry to revive an old(ish) topic, but i'd rather ask OP the question, than open a new one.

    @silly_regex Do you have G-Sync enabled by any chance? I do and i noticed a tearing on my screen today. The tearing itself isn't strong on normal paced videos, but i stumbled upon "The Prodigy Russian Tour" and in concert scenes there is quite a lot of strobing going on. That's where you just can't miss tearing, it's there all the time.

    Well, not all the time, technically. It's there only in fullscreen and while YT playback interface is showing, i.e. when you move your mouse. As far as i can tell (judging by my monitor's hardware fps-counter) when you open video in fullscreen and interface goes away FPS drops to 25, no tearing. Bringing the interface up is causing fps to jump to 60 (my default desktop mode) and tearing to appear.

    My setup:
    i5-4570
    GTX1070
    3 monitors (all different)
    Nvidia 382.53 driver. G-Sync enabled in windowed and fullscreen modes.

    Tearing only occurs on primary monitor. It's also the only one that has G-Sync capability. Disabling G-Sync solves the problem
    I also tested fullscreen playback in Opera and Yandex.Browser, no tearing there.



  • @silly_regex said in Tearing on fullscreen video - youtube, twitch, etc.:

    Something like this - looks like different video frames are being spliced together.

    0_1494959331469_upload-9661c808-a7ec-4f5b-afe8-da9cbd18736c

    Had this exact same problem. But it seems to have been cleared up since I disabled Hardware Acceleration for Vivaldi.

    The only way I know to do that though, is by adding the --disable-gpu argument to the shortcut I use to open Vivaldi.

    For anyone who wants to try the same, and isn't sure how to do that, just right-click the Vivaldi shortcut icon and choose properties, choose the Shortcuts tab and in the Target section add the " --disable-gpu" argument without quotes to the end of the target path. Note that there is a space befoer the --disable-gpu

    So for me, on my system, it looks like this > C:\Users\sp4zz\AppData\Local\Vivaldi\Application\vivaldi.exe --disable-gpu

    Anyways, hope that helps someone.

    Edit: Also, someone else evidently had some success with simply disabling the vivaldi://flags/#disable-accelerated-2d-canvas flag.



  • The switch --disable-gpu-vsync did not help?



  • @Gwen-Dragon nope, same thing. Which kinda makes sense, because except if not for some strange VSYNC/G-Sync double stacking bug, both of those technologies are supposed to fight against tearing.

    The problem is that Vivaldi somehow manages to negotiate this custom 25fps mode, then while showing YT interface renegotiate it back to 60 (still probably in G-Sync, just maxed out) while drawing 25fps video. Actually i don't really know how all this stuff works, it's just my crazy theses. As i said, both Opera and Y.Browser managed to stay out of it and played back at 60 without problems.

    But i've made some videos demonstrating the effects: without and with --disable-gpu-vsync.
    Also Vivaldi using G-Sync is not a given thing. After exiting the game it didn't trigger it until PC restart, nor when i tried to record playback with Nvidia's Shadowplay.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.