remove ALT shortcut

  • I often switch to russian keyboard layut. I use tandart ALT+SHIFT for that. When I press ALT Vivaldi menu opens. It annoys me. In shortcuts menu set to ALP+P.

    I want to ask to remove ALT shortcut connected to Menu by default. It may confuse new users, who use different keyboard layouts.

  • Moderator

    You seem to be suffering from the same issue as described here. But I don't know what are you guys doing wrong with the keyboard that the Vivaldi menu appears. Here's how it works on my PC: as long as I press the [ALT] key, the menu won't appear. It appears only on key release. But if I use the shortcut (such as [ALT]+[SHIFT]), the menu won't appear either, after releasing those keys (no matter which one is released first)...

    You must be releasing the [ALT] key before actually pressing the [SHIFT] key - otherwise, I don't know why does it behave like that on your PC. The only workaround I found is to switch to the Horizontal Menu in vivaldi://settings/appearance/ but this takes up some vertical space and thus it might not be a perfect solution...

    EDIT: I've just changed the settings of the Windows language bar hot keys to switch between several keyboard layouts using the [ALT]+[SHIFT] keys and I'm still unable to reproduce the issue. I'm using Vivaldi 1.7.735.46 (32-bit) on Windows 10 x64.

  • Moderator

    @alxgvr said in remove ALT shortcut:

    When I press ALT Vivaldi menu opens.

    Actually, it does not. When you release the Alt key the menu opens. If you press Alt + Shift, the menu does not open.

    In all programs, Alt is reserved for menus, but Vivaldi allows you to assign Alt + Key shortcuts to any commands. If you do that, you won't then be able to open the menus with the same shortcuts.

    For example, in English, Alt + F opens the file menu, but if I assign Alt + F to Find in Page, the menu will no longer open with Alt + F. However, it will always open with Alt, then release Alt. I think there is nothing you can do about that, and nor should it be possible.


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.