[Bug] Switching to/from Japanese input defocuses from text box, as does any other hotkey using Alt



  • The keyboard shortcut to switch to/from Japanese and English is Alt+`, which brings up the window's context menu, making it necessary to re-focus the input box.

    The problem occurs with other shortcuts using Alt as well, including Alt+W for LastPass.

    It seems to happen around half the time, possibly more frequently when I do the chord more quickly.

    I can't see Vivaldi catching on very much in Japan until this is fixed.



  • @rei67 said in [Bug] Switching to/from Japanese input defocuses from text box, as does any other hotkey using Alt:

    The keyboard shortcut to switch to/from Japanese and English is Alt+`, which brings up the window's context menu, making it necessary to re-focus the input box.

    I've tried multiple times to reproduce this bug, but I'm unable to. Alt + ` doesn't bring the context menu for me on Vivaldi ver. 1.5.658.56 (Stable Channel, 32-bit) on Windows 10 x64.

    @rei67 said in [Bug] Switching to/from Japanese input defocuses from text box, as does any other hotkey using Alt:

    The problem occurs with other shortcuts using Alt as well, including Alt+W for LastPass.

    I see some possible conflict here, as Alt + W is the default hotkey for bringing up the Window context menu, though I don't use LastPass, so I can't tell you whether there is a conflict using this shortcut for LastPass or not. Maybe somebody else could confirm that.

    @rei67 said in [Bug] Switching to/from Japanese input defocuses from text box, as does any other hotkey using Alt:

    I can't see Vivaldi catching on very much in Japan until this is fixed.

    Then perhaps you may find this surprising: ๐Ÿ˜œ

    Currently Japan is Vivaldiโ€™s number one market โ€“ which Von Tetzchner found somewhat surprising โ€“ though the overall user base is diverse in location.

    Source: http://www.forbes.com/sites/freddiedawson/2016/11/17/opera-co-founder-wants-super-browser-vivaldi-to-change-how-power-users-surf-the-web/



  • @pafflick said in [Bug] Switching to/from Japanese input defocuses from text box, as does any other hotkey using Alt:

    @rei67 said in [Bug] Switching to/from Japanese input defocuses from text box, as does any other hotkey using Alt:

    The keyboard shortcut to switch to/from Japanese and English is Alt+`, which brings up the window's context menu, making it necessary to re-focus the input box.

    I've tried multiple times to reproduce this bug, but I'm unable to. Alt + ` doesn't bring the context menu for me on Vivaldi ver. 1.5.658.56 (Stable Channel, 32-bit) on Windows 10 x64.

    @rei67 said in [Bug] Switching to/from Japanese input defocuses from text box, as does any other hotkey using Alt:

    The problem occurs with other shortcuts using Alt as well, including Alt+W for LastPass.

    I see some possible conflict here, as Alt + W is the default hotkey for bringing up the Window context menu, though I don't use LastPass, so I can't tell you whether there is a conflict using this shortcut for LastPass or not. Maybe somebody else could confirm that.

    @rei67 said in [Bug] Switching to/from Japanese input defocuses from text box, as does any other hotkey using Alt:

    I can't see Vivaldi catching on very much in Japan until this is fixed.

    Then perhaps you may find this surprising: ๐Ÿ˜œ

    Currently Japan is Vivaldiโ€™s number one market โ€“ which Von Tetzchner found somewhat surprising โ€“ though the overall user base is diverse in location.

    Source: http://www.forbes.com/sites/freddiedawson/2016/11/17/opera-co-founder-wants-super-browser-vivaldi-to-change-how-power-users-surf-the-web/

    Huh. Well I'm pleasantly surprised, then!

    On the other hand, that probably means I'm stuck with this problem.
    ๅˆ‡ใ‚Šๆ›ฟใˆใ‚‹ใจใใซใ€ใƒกใƒ‹ใƒฅใƒผใŒๅ‡บใฆใ—ใพใฃใฆใ€ๆ‰“ใฆใชใใชใ‚‹ใ€‚
    Half of the time, when I switch, the menu pops up, and it messes up input.

    alt text



  • @rei67 said in [Bug] Switching to/from Japanese input defocuses from text box, as does any other hotkey using Alt:

    Half of the time, when I switch, the menu pops up, and it messes up input.

    The only way I can reproduce the problem with the menu appearing is by pressing Alt and then releasing it (before pressing the modifier key). :confused:

    However, I am on UK keyboard.
    Maybe it is dependant on keyboard layout or (language setting)?



  • For me it also happens only when I release the [Alt] key without pressing anything else. I suspect it might be somehow related to the keyboard that you use.

    Do you use the native Windows "keyboard layout" functionality or do you use a third-party software? For me the default keyboard shortcut for switching the layout is [Windows Key] + [Spacebar]. [Alt] + ['] does nothing.



  • @pafflick said in [Bug] Switching to/from Japanese input defocuses from text box, as does any other hotkey using Alt:

    For me it also happens only when I release the [Alt] key without pressing anything else. I suspect it might be somehow related to the keyboard that you use.

    Do you use the native Windows "keyboard layout" functionality or do you use a third-party software? For me the default keyboard shortcut for switching the layout is [Windows Key] + [Spacebar]. [Alt] + ['] does nothing.

    I thought it might be AutoHotkey, so I tried turning that off, but no luck. I haven't otherwise tinkered with things too much; everything in Region and Language Settings is set to Canadian English.

    I've also tried Alt + W for LastPass in Canadian English mode; same issue.

    Windows + Space is actually a new addition as of Windows 8. Until then, it was Alt + Shift to switch between input modes, and Alt + Tilde to switch between Japanese and English (Roman) while still in Japanese mode. A lot of Japanese people use Alt + Tilde, as that's what let you switch between Japanese and English on Japanese versions of Windows since the Windows 3.1 days.

    The Alt button normally puts the keyboard focus on the window menu, so that much is normal.

    Hmm....

    Edit: Interestingly, Korean input seems to capture the hotkey (Right Alt) properly. Pressing Right Alt in Canadian English brings up the context menu, but in Korean, it switches to/from Korean input as expected.

    Edit 2: Turning on the Horizontal Menu also fixes the problem. Pressing Alt "activates" the menu, but it goes away the moment you let go, which is (was?) the correct behavior on Mac but not on Windows. Not that that's an issue, of course, but a side effect of that seems to be that it prevents the weird problem that I'm having.

    Would be nice to recover that screen space someday, especially on my tablet, but I can live with this.

    Thanks for the help!

    alt text



  • I do not reproduce any of your problems on my PC except of pressing Alt and ` at the same time too like pafflick.
    ่‡ชๅˆ†ใฎ็’ฐๅขƒใงใฏใพใฃใŸใๅ•้กŒใชใ„ใงใ™ใญใ€‚

    Windows 10 Home (64bit)
    Vivaldi1.6.689.29 (Official Build) (64-bit)
    IME ATOK2016 or windows default IME
    US Keyboard

    What about Just simply pressing Alt and then ` key ?
    ๆ™ฎ้€šใซAltใ‚’ๆŠผใ—ใฆใ‹ใ‚‰๏ฝ€ใ‚’ๆŠผใ—ใŸใ‚‰ใฉใ†ใงใ™ใ‹ใ€‚

    It seems to me that your IME changes alphabetic letters, โ€aโ€ into Japanese letters,"ใ‚" without your order, but I do not have any typing issue, related to changing alphabetic letters into Japanese letters vice versa. I am sorry and think that your annoying problems would occur under specific circumstance.
    ๅ‹ๆ‰‹ใซๅค‰ๆ›็ขบๅฎšใ•ใ‚Œใ‚‹ใ‚ˆใ†ใชใ“ใจใ‚‚ใชใ„ใงใ™ใญใ€‚่ฉฆใ—ใซใƒ‡ใƒ•ใ‚ฉใƒซใƒˆใฎIMEใซใ‚‚ๅค‰ใˆใฆใฟใพใ—ใŸใŒๅ†็พใงใใพใ›ใ‚“ใงใ—ใŸใ€‚



  • OS: Windows 10 Home (64bit)
    IME : windows default IME
    Vivaldi : 1.7.705.3
    US Keyboard

    I can reproduce it.
    It can be reproduced by quickly releasing alt + Tilde
    However, if you release alt slowly, it will not be reproduced.

    ไธŠ่จ˜็’ฐๅขƒใงๅ†็พใงใใพใ—ใŸใ€‚
    alt + Tildeใ‚’ๅŒๆ™‚ใซใ€ใ‹ใค็ด ๆ—ฉใ้›ขใ—ใŸใจใใฎใฟๅ†็พใ—ใพใ™ใ€‚
    altใ‚’ใ‚†ใฃใใ‚Šใจ้›ขใ™ใจๅ†็พใ•ใ‚Œใชใ„ใฎใงใ€ไบบใซใ‚ˆใฃใฆใฏๅ…จใใ“ใฎไบ‹่ฑกใ‚’่ฆ‹ใ‚‹ใ“ใจใ™ใ‚‰ใชใ„ใ‹ใ‚‚ใ—ใ‚Œใพใ›ใ‚“ใ€‚
    ใกใชใฟใซใ€ๅŒใ˜ๅ†็พๆ–นๆณ•ใ‚’ใ—ใฆใฟใฆใ‚‚ใ€Googleๆ—ฅๆœฌ่ชžๅ…ฅๅŠ›ใงใฏๅ†็พใ•ใ‚Œใพใ›ใ‚“ใงใ—ใŸใ€‚


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.