YouTube playback issues when using Hardware Acceleration



  • I'm experiencing varied issues with YouTube playback, that appear to be solved by simply disabling hardware acceleration in the browser options via vivaldi://chrome/settings/search#hardw

    One such issues is a vertical 'jitter' to the video, changed by the zoom level of the YouTube page, or by full-screening playback.
    Full screen to make this clearly visible: https://www.youtube.com/watch?v=42MiSMPSyS8

    Also, playback can result in large numbers of dropped frames, sometimes to the point of videos becoming practically un-watchable.
    Less severe example: http://i.imgur.com/GDZK0v6.jpg

    Running on a desktop machine with very high end components, raw performance should not be an issue.


  • Moderator

    I don't have any issues with the video jittering or flickering with hardware acceleration turned on. It might be related to the hardware (or perhaps even software?) that you use. The second issue is an old bug that AFAIK hasn't been fixed yet. Though, if not for the stats, I wouldn't probably even notice it... On my machine frames are dropped as well, but I can watch the whole video and it looks pretty normal.



  • Too bad both HW acceleration not working as it should and frame drop of 50/60fps YT videos are known problems, but the frame drop issue is "not reproducible" according to what it has been said to me from the bugreport I did. A quick workaround is just to hide the tab bar, for me the bottleneck it's just that, not even needed to switch to fullscreen.
    https://forum.vivaldi.net/topic/11638/vivaldi-and-youtube-stutter-and-dropped-frames/18
    Watching a 60fps video with 10% or more dropped frames is useless, at that point a normal 30fps video will have the same result =)



  • strange as the youtube video your watching in your photo is using the VP9 codec which is not normally hardware accelerated.

    i would pop over to the chrome extension store and pick up 'h264ify' which makes youtube [and other video sites] stream videos in the mp4 / H264 format which means they run smoother as they use hardware acceleration


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.