Previous/Next history gesture too sensitive



  • Hi, I'm having problems with the gesture that goes back/forward in history in Vivaldi. I keep activating it accidentally when scrolling and it's getting really annoying, especially with pages like Facebook, where you are then doomed to scroll for a long time to get where you were after reloading the page. Don't get me wrong, I'm really grateful that you added the feature, it's just that it didn't use to happen to me with Chrome. :(



  • I agree with you.
    Some time this feature is annoying, is there a way to turn it off? ;)



  • Hi,

    I didn't ever had such problem with mouse gestures. How exactly do you use gesture by an accident? I mean gestures are activated by right mouse button and move, so please descripe steps, what exactly you did.

    Also you can try to adapt mouse gesture settings: Vivaldi \ Tools \ Settings \ Mouse.

    • Edit gesture action: History Back / History Forward
    • Remove gesture action: History Back / History Forward
    • In worst case even Disable gestures completely: Allow Gestures

    Hint: Mouse gesture actions can be configured in latest Developer release, not in Stable release (1.1.453.59 (Stable channel) (64-bit)) yet.



  • I'm not speaking about that gestures. I disabled them already.
    I'm speaking about gestures which are active by using 2 fingers on the trackpad, often scrolling left to right accidentally activate the gesture to go to previous page.
    Actually Safari does the same.



  • Hi,

    then I guess you should change settings of your Touchpad drivers/application. Because as I get it, it has nothing to do with browser itself.



  • @stealth789:

    Hi,

    then I guess you should change settings of your Touchpad drivers/application. Because as I get it, it has nothing to do with browser itself.

    You right! It was a setting of OSX! I finally found a way to disable them from Setting!
    Thank you so much! :woohoo:



  • You're welcome! I'm glad to hear that it's working now ;).



  • Sorry for not responding!

    I'm indeed dealing with the Macbook's trackpad. Sure, I can disable it but it's very useful. It's just that to activate it in Safari/Chrome, you have to actually swipe left to right (90°), meaning it's hard to activate it by accident, whereas in Vivaldi, 45° is enough to activate it. :((

    Btw. I'm using the latest SS and the latest OS X.


  • Moderator

    I agree that disabling the feature system-wide is not really an option. When implemented correctly, it is actually really useful. The problem with Vivaldi's implementation is that even a small, slow two-finger swipe triggers history back. This has two consequences:

    • you can't scroll left on a page or within page elements
    • since the gesture is much more sensitive than in other browsers, it is very easy to trigger it accidentally

    In Opera, Firefox, and Safari, those issues are not present.



  • @stealth789:

    Hi,

    I didn't ever had such problem with mouse gestures. How exactly do you use gesture by an accident? I mean gestures are activated by right mouse button and move, so please descripe steps, what exactly you did.

    Also you can try to adapt mouse gesture settings: Vivaldi \ Tools \ Settings \ Mouse.

    • Edit gesture action: History Back / History Forward
    • Remove gesture action: History Back / History Forward
    • In worst case even Disable gestures completely: Allow Gestures

    Hint: Mouse gesture actions can be configured in latest Developer release, not in Stable release (1.1.453.59 (Stable channel) (64-bit)) yet.

    Are you on a Mac? This post makes me think you have not tested OP's problem on one. It is entirely too sensitive and as the person above me said, it makes it hard to scroll left within page elements



  • Hi guys!

    I would like to precise that i did not disabled all the gestures from mac os x, but only the back swipe with 2 fingers to reload previous page, all the other gestures are enabled.
    I agree that gesture are useful, i can still rotate, zoom-in, move windows with 3 fingers and so on… :)

    so if you really find it too sensitive you can disable it from System Preferences -> Trackpad -> Other Actions, here just disable the option that allows you to scroll back to previous page with 2 fingers.

    Hope it can be useful! ;)



  • @ChimeraTech:

    Are you on a Mac? This post makes me think you have not tested OP's problem on one. It is entirely too sensitive and as the person above me said, it makes it hard to scroll left within page elements

    Hi, no, I'm not on OS. As I didn't know in what OS problem appeared, I tried to use some general tips to help. But from comments I'm not sure if it's problem of browser or OS setting itself.
    So if problem is related to OSX only, I can't help you more with it. Maybe try to report this bug here -> https://vivaldi.com/bugreport/.



  • I agree that the back gesture is way too sensitive. I often trigger it unintended when scrolling down. It's working fine in Safari or Opera for me.



  • Adding another vote for "way too sensitive". It's most obvious when you're trying to scroll horizontally in an embedded element, like this page: http://thedailywtf.com/articles/the-latest-price

    In the "code" area of the post, scroll to the right to see the whole block, then scroll to the left to see the start- and you'll navigate back if you're not careful. Contrast to Chrome, where I can still trigger the navigate-on-scroll, but I have to work much harder to do it.



  • I get this as well. Sometimes even when swiping straight downward on the trackpad it might still go back to the previous page.



  • I've experienced problems with the Navigate Back being triggered when scrolling vertically as well. Almost any horizontal movement seems to return me to the previous page when using the two-finger scroll. It gets very annoying after a while.

    As t3knomanser mentioned as well, horizontal scrolling is messed up when trying to view overflowing text in fixed sized container boxes. Scrolling to the end of the text on a line is fine but trying to scroll back to the beginning triggers Navigate Back when it shouldn't.



  • It's been much improved in the latest version (1.2.490.39).



  • Swiping left on a magic mouse on Mac no longer goes back to the previous page. Anyone else on 1.2 stable?



  • ChimeraTech said:
    "Swiping left on a magic mouse on Mac no longer goes back to the previous page. Anyone else on 1.2 stable?"
    Well… Same problem here. And, unfortunately, it's also happening with version 1.3.501.6 (Snapshot).
    I wonder when this issue will be solved...



  • Just wanted to chime in that this is a big frustration for me too. I have given up using Vivaldi since this sensitivity issue showed up. I can't make my way scrolling through an article without accidentally triggering Previous. I'm on 1.2.490.39 (OSX).


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.