Touchpad oversensitive when scrolling



  • I just bought a Lenovo Yoga 500. When running Vivaldi and using the touchpad to scroll the page (two fingers), the scrolling function is oversensitive and the page rushes to the bottom. This only happens in Vivaldi, not in any other browser or any other application. Anyone familiar with this problem? Can it be fixed?



  • Same here, I have Lenovo flex 2. Scrolling with touchpad is absolutely useless. Even with final 1.0 release.



  • I have a Yoga 700 and had this problem in several apps, so I don't think this is a Vivaldi error. Acrobat was essentially unusable for this same reason. The problem was the Elan touchpad driver that Lenovo ships. I fixed it by installing the Elan driver from another laptop, which made my cursor less jumpy and two-finger scrolling the same speed in all apps.

    This may help you:
    http://forum.notebookreview.com/threads/installing-updated-elan-track-pad-drivers-for-y510p.751866/



  • Same problem happens here, I use a Lenovo G400S Touch laptop with Elantech touchpad. Scrolling using two fingers is useless, very fast.



  • I know this topic is very old, but I am also having this problem. I have a Lenovo Y50 and the scrolling with the touchpad is unusable and spoils what is otherwise a great browser.



  • Hello,

    I had a different issue. While using vivaldi on my surface book, scrolling was not sensitive enough. All other browsers worked fine. Oddly I turned off tab thumbnails and vivaldi's two-fingered-scrolled worked beautifully. Better than any other browser. Maybe try that. Settings > Tabs > Show Tab Thumbnails > uncheck. Restart vivaldi or re-install, then check two-finger-scrolling.



  • This happens occasionally here too, using a Logitech wireless mouse. I'm on Linux.



  • Hi there guys.
    I had this problem and I found a partial solution around the web.
    The problem seems the touchpad driver from Lenovo (elean), and then for have a "human" response of the two finger scroll please follow the procedure above:

    1. Find ETD Control Center and ETD Control Center Helper from Task Manager in Process section.
    2. Right click over one of them and open the file path folder, it will be used on the last step.
    3. Kill thoose two process.
    4. Press CTRL+R and then write "regedit" and press enter.
    5. With the left browser, go to HKEY_CURRENT_USER -> SOFTWARE -> Elantech -> Smartpad.
    6. Find ScrollControl_Mode on the main window, then change it value from 0 to 1.
    7. Close regedit, then search "Mouse settings" with cortana (or going device manager and find out by yourself) and change the number of lines to scroll to 3.
    8. Now you can go to the folder opened on point 2 and re-open ETD Control Center.

    Hope that this bizzarre solution works, on some cases you may notice a reduction of scrolling speed "system-wide", in my case explorer scrolling is a bit slow, but vivaldi and some others app are a bit fast (but not fast as before this solution!) then I found a compromise...

    In some other laptops, going to vivaldi://flags and enabling Scroll Prediction will help!


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.