Netflix and Vivaldi on Linux?



  • Now that vivaldi includes the DRM CDM, does netflix work out of the box? I read something about patched ffmpeg, which is shipped with chrome. Does vivaldi the patching for me, or do i (still) need to copy files from chrome to vivaldi? The howto i saw looked like quite a bit of work ...



  • Hello. I hope this helps you. It's a direct paste of my PERSONAL V Note that i've just now updated, having verified this works [fyi, i use Mint x64 17.3 KDE, so depending on your system some changes might be needed]:

    24/3/16 UPDATE:
    Brilliant discovery per wognath https://vivaldi.net/forum/vivaldi-browser-for-linux/8148-vivaldi-web-panels-audio-netflix#50372 –>

    1. Ensure that V's libffmpeg was updated per original steps below [A - D: this is only a once-off necessity].
    2. Install Google Chrome-Stable … BUT now this only has to be temporary...
    3. Navigate in Dolphin to /opt/vivaldi-snapshot/
    4. Therein, find the symlink libwidevinecdm.so [it points to [i]/opt/google/chrome/libwidevinecdm.so] & rename to [eg] libwidevinecdm_LINK.so [or even just delete it; the objective being to allow the following step, which otherwise gets blocked if this link is not renamed, moved or deleted].

    5. Navigate in Dolphin to /opt/google/chrome/ & copy [Admin privilege needed] file libwidevinecdm.so
    6. Return to /opt/vivaldi-snapshot/ & paste in libwidevinecdm.so
    7. Happily proceed to uninstall Google Chrome Stable again – yay.
    8. Launch V, browse to NF, & enjoy [note, the recent steps to also install & configure the Spoof extension are no longer needed].

    Preliminary, once-off:
    A. Browse to http://repo.herecura.eu/herecura/x86_64/

    B. Find the latest vivaldi-snapshot-ffmpeg-codecs-xx.0.xxxx.xx-x-x86_64.pkg.tar.xz [eg, vivaldi-snapshot-ffmpeg-codecs-48.0.2564.71-1-x86_64.pkg.tar.xz] & download it.

    C. Go to the Downloads folder, initiate Konsole therein, & run tar xf vivaldi-snapshot-ffmpeg-codecs-48.0.2564.71-1-x86_64.pkg.tar.xz –strip 2 [ie, obviously match the specific file from #3. This step pops out [i]libffmpeg.so into the folder]

    D. Run sudo install libffmpeg.so /opt/vivaldi-snapshot/libffmpeg.so [This step installs said file into Vivaldi-Snapshot folder]



  • I already copied the libffmpeg from the tar.xz like in the howto from ruari, but got the message the widevine plugin is out of date. I will try to extract it from chrome, even when i do not really want to install chrome. I guess i can extract it from some chrome package like the ffmpeg from the vivaldi package.



  • It works. Seems vivaldi ships the one part of the library, but not the other one?
    Anyway, great. So i can watch netflix without resorting to use chrome.

    By the way, does the DRM stuff run in the sandbox like the other plugins?



  • @allo:

    does the DRM stuff run in the sandbox like the other plugins?

    Sorry i don't know about that.

    FYI, here's my latest methodology update:

    The last couple of V SS updates overwrote my carefully placed "libwidevinecdm.so" file in "/opt/vivaldi-snapshot/", with the useless simple symlink pointing to the [non-existent] "/opt/google/chrome/", thereby once more breaking NF in V. Hence i amended my evolved methodology with this tweak.

    1. I manually recreated "/opt/google/chrome/" directory structure, but left said folders empty [ie, i did NOT simply reinstall Chrome again].

    2. From a backup copy i'd kept, "just in case":, i put Chrome's "libwidevinecdm.so" file into my "/opt/google/chrome/" directory [which now contains just that single file, nothing else].

    3. My logic is pretty simple & obvious; if ongoing V SS's are going to keep overwriting my real file with only the symlink & thus constantly breaking NF, then i will convert that symlink from useless to useful… by giving it exactly the target it seeks.

    4. After restarting V, i confirmed that NF again works, & the yuk Chrome remains off my SSD. With luck, future V SS updates will no longer break NF, & i hopefully will no longer need to keep fixing it.



  • Well RATS. Today was the first time i tried to stream NF since my V SS updated to 1.3.537.5 (Developer Build) dev (64-bit). Sadly, NF in V for me at least is once again broken:

    Whoops, something went wrong…
    Unexpected Error
    There was an unexpected error. Please reload the page and try again.
    Error Code: M7353

    Initially undaunted, i assumed it was time to update my now-old version of libffmpeg.so, so i repeated the good ole A - D as per my https://vivaldi.net/forum/vivaldi-browser-for-linux/9131-netflix-and-vivaldi-on-linux/reply/51395#50688 above. I grabbed vivaldi-snapshot-ffmpeg-codecs-52.0.2743.49-1-x86_64.pkg.tar.xz from herecura, & stripped out then relocated its shiny new libffmpeg.so, Nope, NF still gave same error [yes i did first restart V]. Humpfh.

    Next i wondered if maybe my version of libwidevinecdm.so [sitting quietly all by itself in [i]/opt/google/chrome/ as per my #1 in my https://vivaldi.net/forum/vivaldi-browser-for-linux/9131-netflix-and-vivaldi-on-linux/reply/51395#51395 above, & accessed by the symlink to it in /opt/vivaldi-snapshot/] was now incompatible, so [shudder] i reinstalled the latest version of Chrome Stable. This naturally fully populated the erstwhile empty-but-one-file in /opt/google/chrome/ & of course thus overwrote the older libwidevinecdm.so with the latest version. Chrome then happily streamed NF, but V still will not. Bugger.

    Note that both before & after running these procedures, all 3 videos at http://www.quirksmode.org/html5/tests/video.html worked fine.

    Is anyone else experiencing this NF hassle with the latest V x64 Deb SS, & have you managed to beat it?
    …....................................................................................
    My on-SSD OS = Linux Mint x64 17.3 KDE 4.14.2.

    PS -- I just noticed this oddity: Despite my work above, V SS is NOT displaying the latest version for Widevine, in Plugins:
    Vivaldi: vivaldi://plugins = Widevine Content Decryption Module - Version: 1.0.123.456
    Chrome: chrome://plugins/ = Widevine Content Decryption Module - Version: 1.4.8.885

    How on earth is this difference possible? That file is NOT physically present in /opt/vivaldi-snapshot/, but is merely symlinked to the latest file in /opt/google/chrome/ … so HOW can V SS report it differently?


  • Moderator

    I can confirm disfuctional detection of DRM plugin on Debian 8x64 KDE 4 with Vivaldi Latest Snap.

    I reported the bug as VB-19768 [Linux] Plugin "Widevine Content Decryption Modul" missing


  • Moderator

    Did you see this new gist from Ruario at https://gist.github.com/ruario/3c873d43eb20553d5014bd4d29fe37f1
    May be it helps for Netflix, but i can't test it (i have no Netflix).



  • Hi GD, thanks for both your posts.

    Regarding your first one, i don't properly understand the technical meaning, but it seems that you believe this new problem might actually be a bug in the latest x64 V Deb SS, rather than something i did or didn't do with libffmpeg.so & libwidevinecdm.so … am i understanding correctly?

    Regarding your second one, no i had not seen Ruario's page til i followed your link. Wow, it's fantastic! I copied & ran his bash script in a Mint KDE VM which did not previously have libwidevinecdm.so nor even /opt/google/chrome/, & as it ran i watched it do all its tricks. Once it finished i launched V, but NF there failed with the identical error i already showed in my post yesterday for my real Mint KDE OS, ie:

    Whoops, something went wrong…
    Unexpected Error
    There was an unexpected error. Please reload the page and try again.
    Error Code: M7353

    I assume, based on your first post, that there's now nothing more i can do til the Devs fix this in a future V SS… is that right?


  • Moderator

    Please report a separate bug for Netflix on Linux to https://vivaldi.com/bugreport/


  • Moderator

    And for Netflix
    1. clear cookies
    2. start Vivaldi on shell with
    vivaldi-snapshot –user-agent='Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36'


  • Vivaldi Team

    Close all tabs related to netflix and then delete all netflix cookies. Before trying Netflix again, make sure that H.264 works (try the first video on http://www.quirksmode.org/html5/tests/video.html ). If that works check http://demo.castlabs.com to confirm that DRM is working. Then if both work login to Netflix again.

    P.S. You do not need to adjust your user agent in Vivaldi. We do that for Netflix for you.



  • Thanks for your replies Gwen-Dragon & Ruario. I am deeply embarrassed to have to advise that i have solved my "problem" now… i stress MY problem, NOT a NF or V problem, but 100% a Silly Steffie problem. A few weeks ago i'd installed extension Disable HTML5 Autoplay. You can now guess the rest. Yes, i had not realised that this extension was active on my NF tab. Once i finally remembered just now that i had this extension, & that i should check its status on my NF tab, i saw that it was Active when i had intended it to be Inactive there. Once i deactivated it for NF, reloaded the page, & tried again to stream NF, it behaved properly. I feel such a dope. Sorry to have wasted your time, but thanks for trying to help an idiot anyway.


  • Vivaldi Team

    As long as it works in the end it is all good!


  • Vivaldi Team

    @Gwen-Dragon:

    I can confirm disfuctional detection of DRM plugin on Debian 8x64 KDE 4 with Vivaldi Latest Snap.

    I reported the bug as VB-19768 [Linux] Plugin "Widevine Content Decryption Modul" missing

    Be careful using the term "snap" or people could start thinking we offer the new hyped up Snap packages. Which we don't. Yet :)

    //C


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.