Sync your Vivaldi web calendar with Vivaldi browser and Android



  • Following guide is of course not the only way to achieve calendar sync between Android and Vivaldi desktop browser. You can ignore the Vivaldi web calendar, use Google’s web calendar (server), which is already synced with your Android install and simply create a Google calendar account in the desktop browser. The downside is that Google will annoy you with a login request on every Vivaldi start and you will be logged in to all Google services throughout your session, including Youtube, Chrome web store, &c. As of writing logging out from your account, while the session is ongoing, will trigger the Google login window repeatedly up until you lose your patience and delete your Google calendar and mail accounts for good… Which leads us to this:

    Vivaldi

    1. Open vivaldi://settings/calendar/ and click the + button.
    2. Input your credentials, pick Vivaldi.net as account type.
    3. Click “Create Account“.

    This will sync the browser calendar with the vivaldi.net instance of your account. So far so good.

    Android

    1. Open the Play Store app and search for “Open Sync”. Install. This additional app is needed to sync to the Vivaldi server with CalDAV. You could potentially use another app for this purpose, pick your poison.
    2. Open the app and give it Calendar permissions.
    3. Click on the big + sign to add an account.
    4. Select the “Login with URL and user name” option.
      • Base URL: https://calendar.vivaldi.net/calendars/
      • User name: username@vivaldi.net
      • Password: your Vivaldi account password
    5. Click “Login”.
    6. Your Vivaldi account should be visible in a big rectangle—click it.
    7. Under CalDAV tick the checkbox for your calendar.
    8. Click the cogwheel at top to adjust settings like sync interval.

    Open Sync automatically integrates with Google Calendar. If all went well, you should be able to see your vivaldi.net account in the Calendar app and an Open Sync entry in your Android Account settings.



  • When I tried this advice, at first events I added in Vivaldi weren't showing up on my phone, though the opposite direction worked. It turns out, in vivaldi://settings/calendar/ under the "Calendars" section, there was a dummy entry above the Vivaldi.net calendar. Vivaldi was putting events I created through it in this dummy calendar, instead of the Vivaldi.net calendar that was being synced. After removing the dummy entry and setting the Vivaldi.net calendar as the default, syncing worked ^^



  • @Crimsonshade Glad it worked for you. I’m not sure about the dummy calendar. Isn’t that just the default instance of the vivaldi.net calendar sync? I deleted the original on day one and never got to test the setup you are describing.



  • Possible.

    When I set up the new Vivaldi Calendar account, there were already entries for "Local Account Vivaldi.net" and "Local Account Local". I removed the Local Account Vivaldi.net before adding the Vivaldi.Net account according to the instructions here.

    Later, when I scrolled to "Calendars", I found my Vivaldi.Net calendar, but above it was an unlabelled entry. By "unlabelled", I mean that in the list of Calendars, there was a blank row - no picture or text at all. Apparently however, this blank entry was the "default" calendar and all the events were being put here. What was interesting is, after I removed this blank entry, next time I created an event, I was provided with an option to choose which calendar to put the event in - however, this option had not appeared before I deleted the blank entry.



  • Hello.
    I have my account correctly synchronized with webdav. The problem is that when I add an event to the calendar, with a specific time. In the android calendar it works correctly, but in the vivaldi browser it comes out as an all day event.
    Can you tell me if it happens to you too?



  • @dividi This works for me, correct time is being transferred. Make sure the timespan arrives at your vivaldi web calendar, I’d assume it doesn’t.



  • I have already found the problem. If in the Android calendar, the start and end time of the event is the same, in the vivaldi browser calendar it is interpreted as if it was the whole day. The problem I have now is that if I add an event from vivaldi browser for tomorrow or for another future day, in the Android calendar, it is created for the present day.



  • @dividi So, I never created an event with same start and end time, don’t know whether that’s a bug, but might be worth looking into. The second problem you are talking about I definitely don’t have, inputting future events works correctly for me.



  • OK, newbie here so be patient.

    I want to sync my google calendar w vivaldi calendar (going back & forth)
    I log into my vivaldi.net account. So far, so good. I select "+"
    In the first set of instructions, I'm asked to create a new account -- type vivaldi.net. I'm asked to provide account name, UN & PW. I add a name, my vivaldi username & my vivaldi pw resulting in "Please check your credentials & try again".

    I can't seem to get past this & I can't figure out why. Clearly I'm missing something but don't know what I'm doing wrong. Can anyone further assist me? TIA



  • @janrifkinson Read it again. You don’t visit the vivaldi.net account for your user on the web, but you open the internal settings page for the calendar in the browser (url above). From there proceed. Be aware this guide is for using the vivaldi webmail calendar server for syncing the calendar on the browser with a calendar app on android. The calendar app on android can be google, but it will not sync your existing google calendar server events! Instead it will introduce new calendars to your google calendar app that are being controlled by the vivaldi server. So in order to get your existing events synced, you will have to import them into the vivaldi calendar server. Just to make sure we are on the same page here.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.