Drag & Drop to Dropbox doesn't work



  • I searched the forum for a solution and found someone else who has the same issue, but no solution.

    I have used Vivaldi for Windows 10 and now Vivaldi for Linux and the behavior is the same: dropping a file or image into Dropbox or Google Drive results in a new tab opening a plain google search page. That's all. It forces me to either use another browser to drag and drop or upload via "new file" click. I prefer drag & drop and according to the thread linked above it should just work.

    Here is the "About" info for my current Vivaldi version:

    Vivaldi 3.1.1929.45 (Stable channel) (64-bit)
    Revision 1eb3263017ed42270818939fbff241845938a81f
    OS Linux
    JavaScript V8 8.3.110.13
    Flash (Disabled)
    User Agent Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.119 Safari/537.36
    Command Line /usr/bin/vivaldi-stable --flag-switches-begin --flag-switches-end --disable-webrtc-apm-in-audio-service --save-page-as-mhtml
    Executable Path /opt/vivaldi/vivaldi
    Profile Path /home/mchipeur/.config/vivaldi/Default

    Please advise how to make drag & drop work.



  • @mchipeur Welcome to the Vivaldi Community 🙂 👍

    Drag & drop on Dropbox works for me here on Windows 10, tested in latest snapshot and stable (clean profile).

    You're saying this is both on Linux and Windows?
    What is the similarity between the installs - same extensions for instance?

    Have you tried in a Guest profile?
    https://help.vivaldi.com/article/guest-view/

    You can test a completely clean profile by launching with:
    --user-data-dir=$TMP/vivaldi


    modedit fixed wrong path delimiter


  • Moderator

    Upload to Dropbox works for me by Drag&Drop files from Desktop and Dolphin folders with Vivaldi 3.1.1929.45 Stable / Debian 10.4 KDE 5 Plasma



  • @Pathduck Thank you for your response.

    Yes, in both Linux & Windows the drag & drop function doesn't work. I am not sure what you mean by "same extensions" - they were standard installs for each OS from the Vivaldi.com website: Windows was .EXE and Linux Mint was .DEB.

    I am on Linux Mint 20.04.

    I just tried a Guest Profile and it worked. How do I get my profile to work???



  • @Pathduck I think I just figured out what you meant by "extensions" - the "add-ons" from the Chrome Store, right?

    No, not using extensions. Just the web pages. That's how I do it on other browsers: Chrome, Firefox.



  • @mchipeur Yes - it's pretty rare that users have absolutely no extensions installed. Since they account for a huge part of the errors users have, we have to make sure.

    If it works in a guest profile, something in your profile is interfering. And since we want to avoid you having to reset your profile to default we need to keep digging.

    Please go to the URL vivaldi://system and click the expand button next to extensions. Copy + paste the list that appears here.

    Check also Menu > Tools > Extensions.

    If you've activated sync a full reset is not so painful, unless you've also done a lot of modifications.



  • @Pathduck - now that I understand your question about extensions I do have several engaged. I thought you meant extensions specific to Dropbox. Additionally I found out which extension was causing the problem. Thank you @Pathduck for getting me onto the correct track to solve.

    The troublemaker was "Super Drag & Drop" I use to open links in new tabs by dragging the link a small distance and dropping. I changed the settings from "On All Sites" to "On Click" and the trouble was solved. (It makes sense that this would be the extension that was causing drag & drop troubles.) 🙂

    Screenshot of settings:
    bce29c57-4df2-4d7e-93ce-b3d460c0fe69-image.png



  • @mchipeur That's great 🙂 👍

    I kind of understand this from your writing "not using extensions. Just the web pages" 😉

    Feel free to add the extension in this thread with an explanation what it breaks:
    https://forum.vivaldi.net/topic/8129/list-of-incompatible-extensions


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.