Umzug von Extensions



  • Hi zusammen ich habe heute einen Rechner neu installiert und wollte die Einstellungen etc von einer Standaloneinstallation zur anderen machen. Also Browser installiert und das Default-Verzeichnis kopiert. Trotzdem funktionieren die Extensions nicht. [i]vivaldi://extensions[/i] zeigt mir auch keine an. Was mich noch mehr wundert: im Chromestore kann ich z.B. µBlock nicht installieren, da er anscheinend Vivaldi nicht als Chrome-Klon erkennt. Wo ist der Denkfehler bzw. was muss ich tun? Danke schonmal derDay P.S. das gleiche Prozedere hat bei O12 weniger als 5 Minuten gedauert, ein Traum



  • Hatte interessanterweise das gleiche Problem mit Opera. Default folder kopiert, alles funktioniert nur Extensions nicht… Liegt vielleicht eher an Chromium als an Vivaldi.

    Extensions neu zu installieren ist jedoch kein Problem. Einfach im chrome web store danach suchen und auf "add to chrome" klicken, um die Extension zu installieren. Opera addons funktionieren ebenfalls, man muss sie nur neu packen.



  • lustig, wenn ich jetzt im Chromestore eine Extension installieren will, ist dies ohne Probleme möglich und ich bekomme die "Hinzufügen" Schaltfläche, die du auch im Screenshot zeigst; dies war gestern definitiv nicht der Fall.

    Ok, dann ist mir erstmal geholfen. Auch wenn ich natürlich alle Einstellungen in den Extensions neu vornehmen muss.
    "Trotzdem" Danke :)

    €dit:
    die Einstellungen zu den Extensions stehen wohl noch woanders im Profil, denn diese funktionieren direkt so wie bei der alten Installation (um so einfacher)



  • Ich konnte den Default-Ordner kopieren, Auch in eine andere Standalone, und auch Erweiterungen, die vorher im anderen Standalone liefen, laufen.



  • ich hab mal nachgesehen, in den Dateien des Profils sind ja keine absoluten Pfade, drin die stören könnten. Also kann eine hin und her kopieren.

    Es sei denn eure installierten Erweiterungen haben so einen Murks.
    Oder Dateiberechtigungen passen nicht.



  • Ich weiß jetzt (glaub' ich) warum du die Extensions nicht direkt installieren konntest. Hab heute versucht vom google chrome store eine zu laden, aber nur der "available for chrome" button war da. Dann habe ich bemerkt das ich als user eingeloggt war…. schnell ausgeloggt und konnte installieren.

    Komisch die ganze Sache, hoffentlich wird sich das in den kommenden snapshots bessern.



  • Habe das gerade einmal (eingeloggt) probiert, hat wie erwartet funktioniert.



  • Scheint dass das nicht für alle der Fall ist, könnte durchaus der Grund sein warum OP Schwierigkeiten hatte.



  • Ich habe das gerade mit einer Standalone (Linux) Version probiert und einen Haufen Erweiterungen über den Hinzufügen-Button ohne Probleme installieren können.

    Vivaldi 1.0.231.3 64bit



  • @luetage:

    Scheint dass das nicht für alle der Fall ist, könnte durchaus der Grund sein warum OP Schwierigkeiten hatte.

    nope, bin eigentlich niemals bei Google eingeloggt. Zumindest nicht, wenn ich mit Vivaldi surfe

    Ich glaube langsam, dass es an den Dateiberechtigungen lag, denn da musste ich mich häufiger mit meinem Adminlogin anmelden. Wobei, mhh, nee, eigentlich auch nicht, weil die alte Standaloneinstallation auch in einem neu erstellten Ordner irgendwo auf der Festplatte lag, also keine Sonderordner wie C:\Programme oder im Profil o.ä.

    Wie gesagt, heute konnte ich ja auch normal die Extensions installieren. Gibt's evtl. Probleme direkt nach der Installation oder sowas? Ohne Neustart des Browsers/Rechners?



  • Ahh, ihr habt recht, hatte nichts mit dem ein/aus-loggen zu tun, war nicht das Problem sondern eine unnötig komplizierte Lösung.

    Ich hab da jetzt noch ein bisschen herumprobiert. Scheint als ob es darauf ankommt ob man den link zum web store auf der vivaldi extensions seite verwendet, oder aber den chrome web store selbst ansteuert.

    https://chrome.google.com/webstore/category/extensions?hl=en-US
    https://chrome.google.com/webstore/category/extensions

    Mit dem ersten link (vivaldi://extensions) funktioniert es nicht, mit dem zweiten schon.



  • @luetage:

    https://chrome.google.com/webstore/category/extensions?hl=en-US
    https://chrome.google.com/webstore/category/extensions

    also ich bekomme bei beiden die richtige Schaltfläche (beim ersten Link logischerweise die englische Version "add to chrome").
    Und wenn ich den Link aus der Erweiterungsseite nehme (Mehr Erweiterungen herunterladen) dann bekomm ich garkeinen Button angezeigt :huh:



  • Scheint als ob es darauf ankommt ob man den link zum web store auf der vivaldi extensions seite verwendet,

    Das ist ein bekannter Bug von Vivaldi, dass der Webstorebutton auf der Extensionsseite so weiterleitet, dass das Installiere nicht klappt.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.