Twitch video stream lagging on new window instance



  • Heyo fellow forum users

    I'm writing about my problem here, because I think this post could help someone in the future so I want it visible for everyone.

    I've encountered a bug, which occurs when I open a new window by drag-and-dropping a list with a Twitch livestream on it or right clicking that list and choosing Move list to -> New window. When new window opens, whole page starts lagging really heavily, not only a stream, but all animations too (eg. writing a message in chat). This bug doesn't disappear on page refresh BUT when I open a new fresh list in a window with lagging list, it's working properly. For me, this is reproducible on any twitch live stream.

    I'm running a double monitor setup one with 144Hz and one with 60Hz. It doesn't matter what combination I use (old and new window on 144Hz; old window on 144Hz and new on 60Hz etc.) it's lagging all the same.

    I've tried disabling/enabling gpu-blacklist and software acceleration flags and disabling/enabling hardware acceleration and use animations in settings.

    This is first time it's happening, it does work normally in Chrome and Firefox browsers.

    Technical specifications:
    Vivaldi version: 2.4.1488.36
    CPU: Intel Core i5-8400
    GPU: GeForce GTX 1070 Ti


  • Community Manager

    Sorry for the trouble and thanks for sharing it here. Please copy paste it also on our bug report page so that the dev team can try to reproduce it and fix it. Thanks in advance for your help ๐Ÿ™


  • Moderator

    @gaelle @Myliak I already reported this a while ago, but it was marked as CNR (VB-50885). The same thing can also happen by tiling the page.



Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.