Opens small, half off-screen, on Start Page instead of my homepage?



  • My Vivaldi 2.1.1337.36 (Stable channel) (32-bit) on Windows 10 has begun opening in a small window, halfway off-screen, showing the default Start Page instead of my homepage. It puts tabs at the bottom, but ignores most of my other choices. Same version (but 64-bit) on Antergos Linux still works properly.

    I'm not sure, but I think this began several days after the most recent update. I check my settings and all are still as I like. As soon as I expand the window and open a new tab, it redraws everything to my preferences and works fine.

    I've tried all the "set it properly and close it without opening anything" tricks, and nothing makes any difference. It obviously remembers the correct settings, it just ignores them when first opening. What could this mean?


  • Moderator

    @lorenamelang Something could be corrupted in your profile. You might try refreshing your profile.



  • @ayespy Before I start that job (I have several worse bugs to attack today), could this be the problem:

    Command Line "C:\Users\loren\AppData\Local\Vivaldi\Application\vivaldi.exe" --flag-switches-begin --flag-switches-end -- https://view.e.economist.com/?qs=3d14xxxxd2114aad46c4907189bd1111ae517d47b7cb6469e06fa01ddc2b870acfaad0f5da5d18e58fa825c5067b802278d401e972b63a748753cfbf1c0bfee87e6e69120049f11c

    (I masked my ID with the xxxx, won't work for you.)

    I can't tell how old that economist link is (they always show you the latest issue), but I can't believe it belongs there. Maybe Vivaldi is trying to parse it into settings? Can I just go edit that Command Line somewhere?

    Could be much quicker than redoing all my settings and appearance and extensions! That will have to wait...


  • Moderator

    @lorenamelang So that link is not part of the browser. Don't know how it got in there. Let me see if I can figure out where these switches are stored.

    This is the standard command line for a standalone:
    Command Line "C:\Users\USER\AppData\Local\Vivaldi\Application\vivaldi.exe" --vivaldi-standalone --flag-switches-begin --save-page-as-mhtml --enable-features=PasswordImport,fill-on-account-select --flag-switches-end --ppapi-flash-path="C:\WINDOWS\system32\Macromed\Flash\pepflashplayer64_31_0_0_122.dll"



  • I just thought of another possibility... I use the NirSoft BrowsingHistoryView program to view and search all history from all browsers in one place. It always has opened full screen. But just about the time Vivaldi began opening in an odd size, so did the HistoryView! Likewise, I restore it to full screen and it works until it is closed. And starting just about that time, whenever I use the right-click "Open with" option in Windows Explorer, it asks me which program I want to open it with, even for things where there are no new options or no choices at all.

    I'm wondering if Windows 10 (1803, 17134.345) has broken something...


  • Moderator

    @lorenamelang I could hardly guess. But Nirsoft also has its fingers in the works, obviously, and I hesitate to theorize what impact that might have.



  • I've had a week of more serious problems with other machines, so I never got back to this. But today my Vivaldi stopped playing audio. Each new page would play about a tenth of a second and then go silent, despite all the settings showing audio properly enabled. All other browsers would play the same media fine.

    So I went looking and found Windows "Cumulative Updates", a new Flash Player, and Vivaldi 2.1.1337.47 (Stable channel) (32-bit). With no other changes, my audio is back and my Vivaldi starts full screen on my proper homepage.

    And yes, the weird Economist link is now gone from my Command Line:

    Vivaldi 2.1.1337.47 (Stable channel) (32-bit)
    Revision 9b2ff69dbecc420197a07a2e28ef5cc7b92ed5bf-refs/branch-heads/3538@{#1079}
    OS Windows
    JavaScript V8 7.0.276.38
    Flash (Disabled)
    User Agent Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.103 Safari/537.36 Vivaldi/2.1.1337.47
    Command Line "C:\Users\loren\AppData\Local\Vivaldi\Application\vivaldi.exe" --flag-switches-begin --flag-switches-end
    Executable Path C:\Users\loren\AppData\Local\Vivaldi\Application\vivaldi.exe
    Profile Path C:\Users\loren\AppData\Local\Vivaldi\User Data\Default

    It says Flash is disabled, so I guess the Flash update was only relevant to other browsers.

    Oh, and NirSoft BrowsingHistoryView began opening properly by itself earlier in the week, so that must have been unrelated.



  • So I was wondering why my 64-bit system had 32-bit Vivaldi. Looks like the older forum posts are saying 64-bit is not ready for prime time, but now it seems the web page just defaults to 32-bit unless you dig for the "other systems" page and explicitly choose 64-bit. So I installed 64-bit. It first opened with the brag page about the new Quick Commands, and About showed that in the command line:

    Command Line "C:\Program Files\Vivaldi\Application\vivaldi.exe" --flag-switches-begin --flag-switches-end https://vivaldi.com/newfeatures?hl=en-us&version=2.1.1337.47&os=W10.0.17134

    I closed it and re-opened it (had to replace my taskbar icon), and the link was gone from the Command Line. So I guess that "About" display shows whatever started the current run of the browser - not some cast in stone default command. The Economist suspicion above was probably meaningless.



Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.