Mouse gestures do not trigger



  • Hi,

    I've been having a problem with Vivaldi since about 2.0 that mouse gestures will not trigger. I use the following gestures:

    New tab: up
    Close tab: down and right
    Next tab: up and right
    Last tab: up and left
    History back: left
    History forward: right

    At first I thought it was my mouse button so I opened it up and cleaned it however that did not change anything. I do not have any problems with the same gestures on Firefox 63. So I do not believe that it's a hardware or OS issue. In fact even the trackpad has problems getting the gestures to trigger.

    Vivaldi Version in use is: 2.1.1337.36 (Stable channel) (64-Bit)
    MacOS: Mojave
    Mac: MacBook Pro 13" Late 2017

    The following extensions are installed:

    Canvas Defender
    Cookie AutoDelete
    ScriptSafe
    SmoothScroll
    uBlock Origin

    I've also removed my profile and all saved files that Vivaldi uses with AppCleaner and I still have this issue. Is this a known issue or should I submit a bug report?



  • @gixxa Try to adjust the gesture sensitivity in vivaldi://settings/mouse/. Unlikely that this is your issue when none of the gestures trigger, but worth a try.



  • Yeah I already tried that, sadly it did not work. At the moment I'm back on Firefox as mouse gestures are one of the features I use most.



  • @gixxa That's funny, the only reason I really dislike Firefox is because it doesn't have native mouse gestures. And the extensions all either don't work reliably, or they way I want them to.



  • Same here. 15" MacBook Pro (Mid 2014), Mojave 10.14.1, Vivaldi 2.1.1337.36 (Stable channel) (64-bit)

    Extensions: uBlock Origin, SaveToPocket

    In version 1.15 mouse gestures worked flawlessly, now in 2.x they sometimes do, given that the page has been freshly loaded.

    In most cases the right mouse button just triggers the context menu. I love Vivaldi, but since I actually bought an Opera license back in the 1990s, I have not used a browser without gestures any more. I'm very much tempted to go back to Firefox.

    I have similar problems on Linux (current Mint), only not so bad. Windows seems to work fine.



  • So I just updated to 2.1.1337.47 (Stable channel) (64-Bit) still no luck.

    Just as @amanessinger said some times they trigger but in 99% of the time I just see the right click context menu. I just tried opening a new tab and I needed 14 attempts to get the gesture to trigger. On Windows it works flawlessly.

    @luetage

    Yeah it sucks that there is no native gestures because you can use them anywhere you want unlike with firefox that blocks addons on some sites. If you do ever use Firefox again try using Gesturefy. Easy to use, lots of actions and they trigger to 100%.



  • Just as a info I just filed a bug report, maybe the team can fix it failry quick.



  • I've upgraded to 2.1.1337.51 today and this seems to solve the problem. We're back from "does not work 99% of the time" to a workable "does not work 2% of the time".

    @Gixxa : thanks for filing the bug report!
    Thanks to the team for fixing it 🙂



  • @amanessinger OK, false positive, I feel foolish now 🙂

    I've just tried it this morning after waking my Mac from sleep. Same page as yesterday evening, my Flickr stats, and using a gesture to open a link in a new tab does not work. 100% not. I always get the context menu immediately. It did work after the upgrade. When I open the same page in another tab, it works.



  • @amanessinger

    Looks like the team can't reproduce the problem:

    @gwen-dragon said in What is the status of VB (=already reported bug/issue)?:

    @gixxa said in What is the status of VB (=already reported bug/issue)?:

    VB-46367

    Tester closed as Not Reproducible on macOS 10.14.1

    Guess that means I'm on Firefox again and will drop Vivaldi.


  • Moderator

    @gixxa said in Mouse gestures do not trigger:

    VB-46367

    That was tested as Not Reproducible on a Snapshot 2.2.1373. Did you check with 2.2?



  • @gwen-dragon

    I did not. I tested it only with stable.

    Edit:

    Works again with the latest snapshot:

    2.2.1373.4 (Offizieller Build) (64-Bit)

    Do you have an eta on when it will be stable?


  • Moderator

    @gixxa said in Mouse gestures do not trigger:

    Do you have an eta on when it will be stable?

    No.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.