Cookies werden scheinbar ignoriert



  • Nachdem ich ein paar Wochen mit Snapshots gearbeitet habe, bin ich wieder zurück zur letzten Stable (1.15.1147.52).

    Jetzt habe ich auf einmal das Problem das ich mich überall erneut einloggen muss wennn ich den Browser schließe. Hier im Forum, Amazon, Ebay, etc. - auf allen Seiten sind Cookies vorhanden, doch scheinbar werden diese Cookies nicht mehr verarbeitet.

    Ich habe das gleiche Problem auf zwei verschiedenen Rechner (w7 64bit), auf einem läuft Vivaldi 32bit, auf dem anderen Vivaldi 64bit. Auf beiden hatte ich zuvor den letzten Snaphot laufen.

    Meine bisherigen Versuche: löschen von Cookies, Cache und Anwendungsspeicher - keine Änderung.
    Dann habe ich versucht aus einem älteren Backup den kompletten \AppData\Local\Vivaldi Ordner zurück zu kopieren. Hier bekomme ich beim Start von Vivaldi die Fehlermeldung das ein Konflikt vorliegt.

    Hat jemand einen Tipp wo ich noch schrauben kann?


  • Moderator

    Zur Cookie-Lebensdauer im Browser dann schau mal nach wenn du in Adresszeile eingibst
    vivaldi://settings/privacy/
    Abschnitt Cookies


    Dann schau nach ob intern Ausnahmen für Cookies existieren:
    chrome://settings/content/cookies


    Ansonsten fallen mir ein:

    • in Vivaldi installierte Erweiterungen welche Cookies manipulieren
    • Im Betriebssystem Programme (z.B. Antivirus, CCCleaner), die aus Privatsphäre Inhalte löschen


  • das sieht alles gut aus.
    Bis auf 'Adblock' 'Google Image View' habe ich keine Erweiterungen installiert.

    Ich hatte ja noch nie Probleme damit, erst als ich anfing die Snapshots zu testen.
    Sollte ich Vivaldi komplett deinstallieren und neu installieren?


  • Moderator

    Auf meinem Windows 10 x64 hat sich woas noch nicht mit Cookies ereignet und ich teste ja auch die internen täglichen Snapshots, die manchmal noch seltsamer reagieren.

    @mangold said in Cookies werden scheinbar ignoriert:

    Sollte ich Vivaldi komplett deinstallieren und neu installieren?

    Schadet nicht.

    Kann auch sein ,dass irgendwo durch Abstürze irgeneien Einstellung ne Macke hat. Snapshots ind zeitweilig instabil.
    Du könntest mal versuchen als allerletztes Mittel das Vivaldi-Profil zu resetten.



  • Kann ich die gespeicherten Daten, wie Lesezeichen, Schnellwahl (inkl. Bilder), Tastenkombinationen aus dem bisherigen Ordner \AppData\Local\Vivaldi\User Data\Default wieder zurück kopieren?

    Die Passwörter kann ich wohl exportieren und später importieren.


  • Moderator

    @mangold diese Dateien kannst du zurück kopieren:

    Login Data
    Bookmarks
    Notes
    Favicons
    Top Sites
    History
    Shortcuts
    Last Session
    Last Tabs
    

    Mehr weiß ich jetzt auch nicht.
    Erweiterungen musst du neu hinzufügen.



  • OK, sind 'Login Data' die gespeicherten Passwörter?

    Ich habe jetzt zwar den Passwort Export aktiviert, finde aber auch nach dem Neustart nirgends die Möglichkeit die Passwörter zu exportieren.



  • @mangold Wie bist du denn zur letzten Stable zurückgekehrt, hast du dein Profil kopiert und weiterverwendet?



  • Und Passwort Export musst du in vivaldi://flags aktivieren, danach ist die Export-Funktion in den chrome settings vorhanden.


    0_1531318227232_Screenshot 2018-07-11 16.09.35.png



  • Bei der Deinstallation des Snapshots konnte ich auswählen ob ich die Browserdaten auch löschen möchte, das habe ich dann nicht aktiviert. Anschließend habe ich die Stable drüber installiert.

    Den Export habe ich aktiviert, ich habe allerdings nicht den Export-Button

    Edit: Ich habe noch ein System-Image vom letzten Monat als noch kein Snapshot installiert war. Eigentlich sollte Vivaldi doch mit den zurück kopierten Daten wieder normal laufen. Warum bekomme ich ein Profil-Konflikt angezeigt? Muss ich evtl. noch mehr Daten zurück kopieren als den \AppData\Local*Vivaldi* Ordner?

    Bild Text
    Bild Text



  • @mangold Du musst das in den chrome settings tun, nicht vivaldi settings – chrome://settings/
    Und ja, ein neues Profil (snapshot), in einer älteren Installation (stable) zu verwenden, führt dazu dass dein Profil korrumpiert wird. Ganz schlechte Idee.



  • @luetage said in Cookies werden scheinbar ignoriert:

    chrome://settings/

    ahh, OK
    Ich werde allerdings von chrome zu vivaldi umgeleitet.
    Jetzt habe ich's gefunden. Ich musste allerdings erst nach Password suchen und konnte dann über die drei kleinen Punkte den Export-Button aufrufen - schon sehr versteckt.

    Ich hoffe der Import funktioniert dann auch in der neuen Installation. Ich denke mal das ich die Import-Funktion erst frei schalten muss, und dann auch über diese drei Punkte gehe.



  • @luetage said in Cookies werden scheinbar ignoriert:

    @mangold Du musst das in den chrome settings tun, nicht vivaldi settings – chrome://settings/
    Und ja, ein neues Profil (snapshot), in einer älteren Installation (stable) zu verwenden, führt dazu dass dein Profil korrumpiert wird. Ganz schlechte Idee.

    Nein, so war das nicht. Ich habe den kompletten Ordner und deren Unterordner vivaldi gelöscht. Es waren also unter *\AppData\Local\Vivaldi* keine Daten mehr vorhanden. Danach habe ich aus dem alten System-Image diesen Ordner, inkl. der Unterordner rein kopiert. Anschließend die Stable drüber installiert.



  • @mangold Ja, kannst du so nicht machen. Würd ich jedenfalls nicht empfehlen.



  • Jetzt habe ich meine beschriebene Kopier-Aktion genau so erneut durchgeführt, allerdings aus einem zwei Monate alten System-Image. Und siehe da, alles funktioniert wieder, in allen Foren und Webseiten werde ich wieder automatisch eingelogt. Möglicherweise war im letzten System-Image doch schon die Snapshot installiert.

    Wenn es dennoch wieder Probleme gibt werde ich alles neu aufsetzen. Danke für eure Unterstützung.



  • Ist ja immer der gleiche Ärger, keine vernünftige Backupfunktion bedeutet doch immer wieder dieselben Probleme, aber vielleicht wird ja dieses Hauptärgernis bei Vivaldi ja doch mal angegangen.
    Die Grundfunktionen müßten doch wegen Sync eigentlich vorhanden sein.


  • Moderator

    @stevehh said in Cookies werden scheinbar ignoriert:

    Ist ja immer der gleiche Ärger, keine vernünftige Backupfunktion bedeutet doch immer wieder dieselben Probleme

    Die von dir gewünschte Backupfunktion löst doch nicht das Problem der kaputten Cookies von @Mangold.
    Sync funktioniert ja gut. Aber wie hättest du da Mangolds Problem gelöst? Vielleicht hast du ja eine Idee.



  • Sync hat für mich nur das Problem das vertrauliche Daten auf einem fremden Server gelagert werden.(Was ein Rechtliches Problem bedeutet für Arbeits- oder Kundenverträge)
    Mir wäre sogar auch eine externe Lösung recht, praktisch Sync für den Hausgebrauch, nur eben mit Speichermöglichkeit eigene Festplatte, ist das wirklich so ein großes Problem?



  • @stevehh Über persönlichen Sync und auch offline Sync wurde schon gesprochen, du wirst halt darauf warten müssen.



  • Tun wir ja halt schon länger, sonst würd ich hier ja meinen Senf nicht dazugeben.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.