Mailto Protocol



  • Been trying to get mailto protocol working (with google inbox). Works fine in chrome but not in Vivaldi.

    Vivaldi was supposed to have mail but did that ever happen?
    Re: Mailto doesn't work inside Vivaldi with webmail


  • Moderator

    @azenix Vivaldi community has free webmail (5GB storage). The Vivaldi browser has an email client integrated into its internal test versions. It's not quite ready for public beta testing yet.



  • In Chrome, inbox.google.com will eventually request to handle the "mailto" protocol. Usually it'll show up when you click the 3 lines on the left to show/hide your other folders. You'll see an icon in the address field that you can click on and choose "allow". When you do that, Default Apps (on Windows 10) will open where you can then set Chrome as the default mailto handler on the system so that mailto links outside of Chrome launch Chrome so they can also launch a compose page at inbox.google.com. mailto links on pages inside of Chrome will launch inbox.google.com too.

    I'm not seeing the notification in the address field in Vivaldi either. But, I don't know if Vivaldi has implemented the UI for this or not.

    I was going to say that to work around it, when you're on the inbox.google.com page, hit ctrl + shift + i to load the developer tools, switch to the console tab and enter:

    navigator.registerProtocolHandler("mailto", "https://inbox.google.com/?mailto=%s", "inbox.google.com");
    

    But, that doesn't work either, which I'm surprised. I also turned that into a javascript URL and invoked it in the address field for the inbox.google.com tab, but that also didn't work.

    Vivaldi also doesn't show up as an option for the default mailto client either. "mailto" is listed in HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Vivaldi\Capabilities\URLAssociations in the registry like Chrome, but there's something missing somewhere that makes Vivaldi not show up (but see below).

    There is one way that works though.

    First, make sure custom handlers are allowed at vivaldi://settings/handlers.

    Then, close Vivaldi.

    Use JSONEdit, to edit "C:\Users\yourusername\AppData\Local\Vivaldi\User Data\Default\Preferences".

    Copy the following to the clipboard:

    {
       "enabled" : true,
       "ignored_protocol_handlers" : [],
       "registered_protocol_handlers" : [
          {
             "default" : true,
             "protocol" : "mailto",
             "url" : "https://inbox.google.com/?mailto=%s"
          }
       ]
    }
    

    Right-click on the root node in the Preferences file in JSONEdit and choose "Paste as child from clipboard". Then, rename the pasted object to "custom_handlers" and save your changes. (This is assuming you don't already have some custom handlers. If you do have some, you just need to add to the registered_protocol_handlers array.

    In Vivaldi, go to vivaldi://settings/handlers, click the 3 dots to the right of the inbox.google.com entry (that's now there) and choose "set as default". Then you can go into Default Apps in Windows and set Vivaldi as the default mail client. Then you should be good to go.

    On a side, for Gmail (mail.google.com), it's:

    navigator.registerProtocolHandler("mailto", "https://mail.google.com/mail/?extsrc=mailto&url=%s", "mail.google.com");


  • @burnout426 Nice investigation! I will give it a try! 🙂

    But anyway, there is also a feature request that you and @Azenix may upvote: https://forum.vivaldi.net/topic/25257/add-protocol-handler-to-settings



  • @burnout426 Works nicely. Thanks for this! Some remarks:

    • Opening vivaldi://settings/handlers directly didn't work for me. It just showed the standard Vivaldi preferences. However, opening chrome://settings/handlers would auto-forward me to to vivaldi://settings/handlers with the custom-handlers setting being displayed. Strange...
    • In a standalone Vivaldi installation the Preferences file is at <Vivaldi Program folder>\User Data\Default\Preferences
    • Make a backup-copy of the Preferences file before editing in case something goes wrong 🙂


  • @wolfram said in Mailto Protocol:

    Opening vivaldi://settings/handlers directly didn't work for me. It just showed the standard Vivaldi preferences. However, opening chrome://settings/handlers would auto-forward me to to vivaldi://settings/handlers with the custom-handlers setting being displayed.

    Yeah, Vivaldi does that to you. Then, when you copy from the address field, it gives you the Vivaldi version that doesn't work. I forgot to correct it. Thanks.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.