[1.14.1077.45] Blank browser window - Ubuntu 14.04.5 LTS



  • After updating 1.13 to 1.14 the browser always starts without any elements in the window.
    i have tried remove ~/.config/vivaldi dir, but it doesnt help.

    0_1517999990143_vivaldi 1.14.png

    [modedit] Added version in title



  • If run it from terminal, this is output:
    [1:1:0207/144409.645510:ERROR:chrome_content_client.cc(428)] Failed to locate and load the component updated flash plugin.
    [6956:6956:0207/144409.751778:ERROR:chrome_content_client.cc(428)] Failed to locate and load the component updated flash plugin.
    [6956:6956:0207/144410.016025:ERROR:gpu_process_transport_factory.cc(1009)] Lost UI shared context.


  • Moderator

    Which vivaldi version?


    Can you logout from Linux account and re-login.

    Check if Vivaldi processes are running, if yes terminate them.
    Search in subfolders of .config/vivaldi/ all files "Current *" and "Last *"and delete them


    If that fails:
    Did you check your OpenGL GPU/ drivers up to date?
    What happens if you start in shell vivaldi --disable-gpu



  • @gwen-dragon vivaldi-stable_1.14.1077.45-1_amd64.deb this package has been installed.



  • @gwen-dragon run with vivaldi --disable-gpu doesnt help. the same result with the same output in the shell:
    [1:1:0207/145313.174997:ERROR:chrome_content_client.cc(428)] Failed to locate and load the component updated flash plugin.
    [8343:8343:0207/145313.288217:ERROR:chrome_content_client.cc(428)] Failed to locate and load the component updated flash plugin.
    [8343:8343:0207/145313.300443:ERROR:gpu_process_transport_factory.cc(1009)] Lost UI shared context.


  • Moderator

    @xghost2008 See my updated post ↑



  • @gwen-dragon ive tried to logout/restart then remove the files and run vivaldi or vivaldi --disable-gpu. always result is blank screen. first run after removing the files there is one more row in output:
    [1:1:0207/150830.134521:ERROR:chrome_content_client.cc(428)] Failed to locate and load the component updated flash plugin.
    [11964:11964:0207/150830.265982:ERROR:chrome_content_client.cc(428)] Failed to locate and load the component updated flash plugin.
    [11964:11964:0207/150830.555440:ERROR:gpu_process_transport_factory.cc(1009)] Lost UI shared context.
    [1:10:0207/150830.636274:ERROR:command_buffer_proxy_impl.cc(134)] ContextResult::kTransientFailure: Failed to send GpuChannelMsg_CreateCommandBuffer.


  • Moderator

    Do you use a special command line parameter when starting Vivaldi?



  • @gwen-dragon both: "vivaldi" and "vivaldi --disable-gpu".
    ContextResult::kTransientFailure: Failed to send GpuChannelMsg_CreateCommandBuffer. - this string appears only with run without --disable-gpu parameter. during run with --disable-gpu parameter output contain only 3 rows


  • Moderator

    You run as regular user?
    Hmmm.
    On my Ubuntu 16 LTS Vivaldi Stable 1.14 alls starts fine.

    What happens if running in shell
    /opt/vivaldi/vivaldi --user-data-dir=/tmp/V/ https://vivaldi.com/



  • i have regular user (not super user).
    /opt/vivaldi/vivaldi --user-data-dir=/tmp/V/
    [1:1:0207/154336.786259:ERROR:chrome_content_client.cc(428)] Failed to locate and load the component updated flash plugin.
    [17481:17481:0207/154336.899447:ERROR:chrome_content_client.cc(428)] Failed to locate and load the component updated flash plugin.
    [17481:17481:0207/154337.236216:ERROR:gpu_process_transport_factory.cc(1009)] Lost UI shared context.
    appears the same blank window


  • Moderator

    @xghost2008 Then it is not related Vivaldi to your browser profile.
    I fear it is something with your GPU drivers on Ubuntu 14 LTS.

    I try to test on my machine, but i have to setup a VM or a USB stick to boot from.
    Please wait…


  • Moderator

    I tested a fresh installed and updated Ubuntu 14 x64 LTS on my USB stick.
    I installed a Vivaldi 14 Stable. It started without issues.

    Perhaps something on your Vivaldi installation on you Ubuntu is broken.

    1. Please check if you have all Ubuntu repos activated.
    2. Please try as regular user to reinstall:
    rm -fr .local/lib/vivaldi/
    sudo apt purge vivaldi-stable
    sudo apt-get clean
    sudo apt update
    sudo rm -fr /opt/vivaldi*/
    wget https://downloads.vivaldi.com/stable/vivaldi-stable_1.14.1077.45-1_amd64.deb
    sudo dpkg -i vivaldi-stable_1.14.1077.45-1_amd64.deb
    sudo apt-get -f install
    

    Does this help?



  • Hi , today i cleaned profile dir one more time, then run vivaldi from command line with options vivaldi "--disable-gpu" "--display=" , and now it works well.Then i return my old profile dir to .config dir and it still working. Many thanks for the help.


  • Moderator

    Running Vivaldi with --disable-gpu will force Vivaldi into a slower mode as the CPU has to do the work for display.

    Perhaps you can override the GPU blacklist
    Open vivaldi://flags/#ignore-gpu-blacklist
    Set to Enabled
    Restart Vivaldi



  • Thanks, it seems to it is getting faster now, but may be it only seems :) anyway thank you.



  • Same problem on Ubuntu 16.04.3. I reinstalled following the instructions above. Nothing changes. Here are the errors I see:

    $ vivaldi -enable-logging=stderr
    [21374:21374:0218/191233.965553:INFO:CONSOLE(39)] "Background page activated", source: chrome-extension://ckjefchnfjhjfedoccjbhjpbncimppeg/background.js (39)
    [21374:21374:0218/191234.582985:INFO:CONSOLE(79)] "TEST: {"result":"invalid_argument"}", source: chrome-extension://ckjefchnfjhjfedoccjbhjpbncimppeg/background.js (79)
    [21374:21374:0218/191234.990515:INFO:CONSOLE(1)] "Uncaught RangeError: Unsupported time zone specified undefined", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js (1)
    ^C
    
    $ uname -a
    Linux xyz 4.13.0-32-generic #35~16.04.1-Ubuntu SMP Thu Jan 25 10:13:43 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
    
    $ lsb_release -a
    No LSB modules are available.
    Distributor ID:	Ubuntu
    Description:	Ubuntu 16.04.3 LTS
    Release:	16.04
    Codename:	xenial
    

    I removed it and installed the latest 1.13 version from the older versions page (vivaldi-stable_1.13.1008.44-1_amd64.deb). That works:

    $ vivaldi -enable-logging=stderr
    [6885:6885:0218/192605.518655:WARNING:api_permission_set.cc(79)] Unknown permission[contacts].
    [6885:6885:0218/192605.678893:INFO:CONSOLE(39)] "Background page activated", source: chrome-extension://ckjefchnfjhjfedoccjbhjpbncimppeg/background.js (39)
    [6885:6885:0218/192606.246240:INFO:CONSOLE(79)] "TEST: {"result":"invalid_argument"}", source: chrome-extension://ckjefchnfjhjfedoccjbhjpbncimppeg/background.js (79)
    [6885:6885:0218/192606.268259:INFO:CONSOLE(1)] "Unhandled rejection: VersionError: The requested version (240) is less than the existing version (320).
        at G.rejectionMapper (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/background-common-bundle.js:1:274175)
        at K (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/background-common-bundle.js:1:223442)
        at IDBOpenDBRequest.<anonymous> (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/background-common-bundle.js:1:265107)
        at IDBOpenDBRequest.<anonymous> (chrome-extension://mpognobbkildjkofajifpdfhcoklimli/background-common-bundle.js:1:225327)", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/background-common-bundle.js (1)
    [6885:6885:0218/192606.987538:INFO:CONSOLE(17)] "Promise from setWindowAttributes resolved in 175 ms", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/vendor-bundle.js (17)
    [6885:6885:0218/192606.992632:INFO:CONSOLE(17)] "Promise from vivaldiSettings resolved in 5 ms", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/vendor-bundle.js (17)
    [6885:6885:0218/192606.993824:INFO:CONSOLE(17)] "Promise from PrefsCache resolved in 1 ms", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/vendor-bundle.js (17)
    [6885:6885:0218/192606.994830:INFO:CONSOLE(17)] "Promise from VivaldiFeatureFlags resolved in 1 ms", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/vendor-bundle.js (17)
    [6885:6885:0218/192606.998078:INFO:CONSOLE(17)] "Promise from SearchEngineActions resolved in 1 ms", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/vendor-bundle.js (17)
    [6885:6885:0218/192607.001418:INFO:CONSOLE(17)] "Promise from PanelActions resolved in 6 ms", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/vendor-bundle.js (17)
    [6885:6885:0218/192607.090144:INFO:CONSOLE(17)] "Promise from createProfile resolved in 95 ms", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/vendor-bundle.js (17)
    [6885:6885:0218/192607.309017:INFO:CONSOLE(17)] "Promise from CommandActions resolved in 9 ms", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/vendor-bundle.js (17)
    [6885:6885:0218/192607.364712:INFO:CONSOLE(17)] "Promise from BookmarkActions resolved in 85 ms", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/vendor-bundle.js (17)
    [6885:6885:0218/192607.365979:INFO:CONSOLE(17)] "Promise from NoteActions resolved in 86 ms", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/vendor-bundle.js (17)
    [6885:6885:0218/192607.514876:INFO:CONSOLE(17)] "Promise from PageActions resolved in 235 ms", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/vendor-bundle.js (17)
    [6885:6885:0218/192607.515619:INFO:CONSOLE(17)] "Promise from TrashActions resolved in 235 ms", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/vendor-bundle.js (17)
    [6885:6885:0218/192607.610605:INFO:CONSOLE(17)] "Promise from HistoryActions resolved in 95 ms", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/vendor-bundle.js (17)
    [6885:6885:0218/192607.684497:INFO:CONSOLE(17)] "Promise from ContentScript resolved in 169 ms", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/vendor-bundle.js (17)
    [6885:6885:0218/192607.687825:INFO:CONSOLE(1)] "JS init startup: 878.634033203125ms", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/bundle.js (1)
    [6885:6885:0218/192613.543227:INFO:chrome_cryptauth_service.cc(222)] Profile is not authenticated yet; waiting before starting CryptAuth managers.
    


  • @pmontrasio

    Hi, I had the same problem on Linux Mint 18.2 and succeeded to fixed it on the latest version of Vivaldi.

    In my environment, the problem seems related to timezone (as shown in your error log). Latest Vivaldi seems to have changed the way handling it.

    The solution is one of below:

    1. Set environtment TZ and start vivaldi.

    eg. (export TZ=JST+9; vivaldi-stable)

    1. Correct /etc/localtime and /etc/timezone.

    eg.
    cd /etc
    sudo sh -c 'echo "JST-9" > timezone'
    sudo cp /usr/share/zoneinfo/Japan localtime

    Please modify timezone to your location.

    Hope this helps.


  • Moderator

    @piulento Sorry to say, for your hint: But a blank browser window in Vivaldi Stable is not a result of a broken timezone. I tested it.
    Mint 18.2 has a timezone set.


  • Moderator

    @pmontrasio Please, what is your Timezone setting?

    zdump /etc/timezone
    
    echo $TZ
    

Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.