Disable all typed history



  • Re: Disable typed history

    I have unchecked 'show typed history', but I still get a list of visited pages when I use my address bar. I already know what I'm trying to go to when I start typing in the addressbar.

    I really want to switch from Firefox to Vivaldi, but this is a deal breaker for me. I don't want the visual noise of all these suggestions from my history.

    I especially don't want it for privacy reasons. I have a job where people need to look over my shoulder sometimes, and I just don't want people seeing my browsing history when I start to type in a URL.

    Is there really no way to disable all dropdowns from the address bar? This is why I never adopted Chrome as a browser.


  • Vivaldi Team

    @3x5 Hey, if head over to the settings -> Address Bar: You will find "Address Field Drop-Down Menu" and "Address Auto-complete" Disabling both of these will let you type in the address field with peace of mind.

    Hope this helps!
    Happy browsing



  • @3x5 Does this help?
    Settings > Address bar > "Show Drop-Down when Typing": OFF



  • Vivaldi 1.12.955.38 (Stable channel) (32-bit)
    Is there also a solution without turning off the whole Address drop down?

    Essentially, I don't want any history, but I do want my bookmarks to show in the dropdown. In Firefox this is easily accomplished by unchecking history in the privacy settings menu. However in Vivaldi turning off any option in settings* related to history still results in a large history section in the dropdown. Is this a bug (since the options are off) or is there another way to turn this section off?
    Additional question: Why isn't there any option to simply don't remember any history? The lowest I can go is to have it remembered for a day, but there is no option to turn it off...

    *The relevant options as far as I could find:
    Privacy:

    • Any option related to suggestions is turned off
      Search:
    • Allow Suggestions everything is unchecked
      Quick Commands:
    • History entries is turned off
      Address bar:
    • Address Bar Dropdown has 'Show Bookmarks' checked
    • Address Bar Dropdown has 'Show Typed History' unchecked
      (I would expect this last check is the only option needed, but a History section still shows in my dropdown bar)

Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.