src="https://update.vivaldi.com/stats/piwik.php?idsite=1&rec=1&bots=1" style="border:0;" alt=""

Is there a way to disable spacebar moving the page?



  • This obnoxious keyboard shortcut is not configurable and doesn'T even go away after disabling single-key shortcuts.

    Super annoying on youtube where I want to pause the video, not move the page.



  • Untick "space for fast forward" in vivaldi://settings/keyboard/



  • Nope, I talk about scrolling the page, in other words the fact that pressing spacebar acts as page down, which is ridiculous.



  • That's exactly what this setting does. If I disable it space doesn't scroll the page anymore. If it still scrolls for you, you might have an extension installed which causes you problems regarding this.



  • I disabled all my extensions and it still scrolls the page on youtube. Even after restart.


  • Moderator

    @punchyrascal Irrespective of settings, when I press spacebar in a YouTube video, it pauses or re-starts it. It only scrolls if no video is playing. Something in your profile is screwing up the action of ths spacebar.

    What version of windows are you using? Perhaps I should try another one.



  • I think what you mean depends on whether the video has focus, not whether it's playing or not. If you click outside the video and press spacebar, it should scroll (unfortunately).



  • If the video has focus, the spacebar will pause and restart it.

    If the page has focus, the page will scroll down. I see no way to turn it off. Fast Forward is not equivalent to scroll down.

    Shift space scrolls up.



  • There isn't an easy way to disable Space working as Page Down in any browser to my understanding. Since the function is annoying you in this specific use case, I would recommend not using [Spacebar] to pause/play YouTube video, because it is not the dedicated key for this action.
    [K] is the dedicated key for pausing and resuming YouTube video. Additionally, [J] is for rewinding 10 seconds and [L] is for fast forwarding 10 seconds.



  • @AceFool Thanks for the tip, however spacebar is much more convenient and it is just strange to have non-configurable keyboard shortcut, so I would consider this a bug.



  • @punchyrascal Then it is a bug that exists in every browser I have tried (Chrome, Chromium, Internet Explorer, Mozilla Firefox) which makes me think that it is somehow a default action for browsers unless overwritten. However, I would also like to see an option to disable this action and repurpose the [Spacebar]. I recommend adding this as a feature request if you have not already: forum.vivaldi.net/topic/15385

    Although, if you were able to disable it, when attempting to pause a video, simply nothing would happen instead of scrolling down (admittedly, still an improvement), and you'd then still need to use the mouse to put the video into focus/pause. For this reason, you should break your habit of using [Spacebar], and use [K] so that you always get the result you are looking for; I see that as being the most convenient. Without using [K], you will not get the desired result 100% of the time unless Google changes the dedicated pause/play key for YouTube video (not going to happen).



  • @punchyrascal said in Is there a way to disable spacebar moving the page?:

    I would consider this a bug.

    Well, it's not a bug. It is the intended behaviour. Every browser I ever used scrolls the page with the space bar; even my PDF viewer does it, and shift + spacebar scroll up. It is a very convenient feature. Shift space can be assigned to another command, but spacebar cannot. If the video has focus, the spacebar works as you like.

    I have never used "k" to pause a video — only now did I learn about it. I either use space or click.

    The "k" shortcut does not work on Vimeo, but the "space" shortcut does.



  • @Pesala

    The "k" shortcut does not work on Vimeo, but the "space" shortcut does.

    This shortcut is indeed exclusive to YouTube, implemented by their developers.



  • @AceFool Good info - I didn't know the [k] shortcut either.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.