Netflix don't find widevine and I'm pretty desperate now



  • Hello, I spend my afternoon trying to resolve this problem but nothing worked.
    I have vivaldi 1.6.689.46 (Stable channel) (64 bits) on Xubuntu 16.04.
    I was with the latest Snapshot before but I tried to uninstall it and move to the stable to try but with no luck.

    I used this script https://gist.github.com/ruario/3c873d43eb20553d5014bd4d29fe37f1 it worked, I now have a opt/google/chrome/libwidevine.so but to no avail since Netflix keep giving me the same error message M7702-1003 and can't find the components needed.

    I tried everything I could on this forum before and I am pretty desperate to run netflix on vivaldi. I hope someone could help me. And I'm sorry if my english is a little broken it's not my mother tongue.

    Thank you ! :3



  • Hello,
    Maybe you need the vivaldi ffmpeg codecs mentioned by Steffie in the 2nd post here under "Preliminary, once-off": https://forum.vivaldi.net/topic/6672/netflix-and-vivaldi-on-linux/2 Good luck!



  • Thank you for your quick response. I have already done this before. I tried to reinstall the latest snapshot and I did it again carefully step by step but still nothing. I have an error message telling me to go to chrome://components and update widevine or something. But when I go to vivaldi://components widevine doesn't show but I think it's normal since it use a link to chrome's widevine or something ?

    Should I install chrome and see if it works ?



  • Sorry that didn't help. I see now you said that you had already tried everything on the forum. Someone will have ideas on how you can get Vivaldi working.
    Lately I have been using Chromium for Netflix because Vivaldi is too slow (my computer is old :(). In my experience, Chrome always works and Chromium just requires a link to the widevine lib to work. Incidentally, when I test Vivaldi 1.7.735.29 snapshot, Netflix fails with error M7355-1204, but when I revert to 1.6.689.34 it plays.



  • Allright I installed Chrome, and now it works on Vivaldi. I have absolutely no idea why. I'm on my snapshot 1.7.735.36

    Well, There is that and the snapshot was updated. So it's one or the other. Hope it will help someone. At least for now my problem is resolved. Thank you wognath for your kindness <3



  • @wognath -- what, what, my ears are burning, did someone mention lil ole me?



  • @wognath -- golly, this is weird & really unfortunate. I stream NF every night, in V [1.6 Stable, on Lappy], just fine, & intermittently some days in latest SS on Tower [& just retested right now, writing this; fine again]. It all just "works" [tis a long time since i had to do all those shenanigans we previously discussed].



  • @Peachpidon
    That github ruario script
    https://gist.github.com/ruario/3c873d43eb20553d5014bd4d29fe37f1
    extract libwidevinecdm.so from downloaded google-chrome package but forgot to symlink it to vivaldi or vivaldi-snapshot folder. That's why it doesn't work.



  • @Steffie "weird & really unfortunate" Not so bad...I use Vivaldi for everything but Netflix :/



  • @wognath -- Yes, but we want V to be our "One Browser To Rule Them All" [i hope you know your Tolkien].


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.