Snapshot 1.0.435.29 - Vivaldi 1.0 final RC1


  • Vivaldi Team

    Today's snapshot is Vivaldi 1.0 Release Candidate 1. Assuming no major, new issues are discovered, we will rebuild this with a few more updates to translations and set it to update users of our beta channel, in the near future.

    See the full blog post here



  • Thanks, Ruari! 🙂

    Saving a web page still doesn't work correctly and closing Vivaldi leaves some of its processes still running. Restarting Vivaldi opens to the SpeedDial page.

    Windows 7 x64 | Vivaldi x64 (x86 test next after some housekeeping)


  • Vivaldi Team

    The fact that you see the speed dial is a symptom of it not shutting down. This is not something we can reproduce. Do you know how you got into this state?



  • Ruari,

    I wrote it up better on the '435.26 page but basically LakeInHolland found the problem:

    File/Save Web Page As/Web Page, Complete doesn't save anything and 'hangs' with the Taskbar icon showing a partially complete download.

    Closing Vivaldi leaves processes running.

    Restarting Vivaldi opens SpeedDial and the Extensions work.

    I haven't tried the Vivaldi/Chrome Task Manager to try to switch to other still-running Tabs.


  • Vivaldi Team

    Interesting. one of the guys internally reported that but I could never reproduce. Which page exactly are you trying to save.



  • stop stealing focus



  • This Comment page on vivaladi.net and the '435.26 page both 'hang' during the Save and never complete unless I Save As HTML Only with no images.

    The Forum pages seem to Save correctly and, so far, other sites like Google and my YouTube page save correctly with images and do not 'hang'.



  • It is mentioned earlier, but just in case.

    The favicons of the tabs in a private window disappeared. I think this should be fixed before final.

    Vivaldi 1.0.435.29 32 bit, windows 7 64 bit



  • Nor does it seem that in beta! For so far I had no problems with the 64-bit version. (Windows 8.1)
    Thanks for the great browser! 🙂
    Waiting quite the email client 😃
    Congratulations team! Great work! 😃
    Sorry for my English! Brazil 😃


  • Vivaldi Team

    I just saved this page without issue. I tried saving the .26 page as well and that also saved without problems.



  • Thanks! The panels load fine again for me! \o/

    .. now a language chooser for linux would be nice 😉



  • Hmm, for me it doesn't like saving any of the Comment pages Complete, only HTML.

    I don't have a spare machine but I'll try another fresh install on a completely different drive/directory and I'll try the x86 version too.


  • Vivaldi Team

    not for version 1.0 but will we will to add it. In the mean time start it from a terminal, like so:

    $ LANGUAGE=nb-NO vivaldi-snapshot

    That would start it in Norwegian Bokmål. Adjust the language code as needed, see www.lingoes.net/en/translator/langcode.htm for a list



  • Still not working with Google play music couldn't play track name skipping ahead



  • One of the problems that has occurred a few snapshots ago that never happened before were some websites that would flicker or flash when you toggle the panel in and out. The panel itself is also very laggy in UI performance, in that it would lag when toggling in and out. Also, the audio icon for pinned tabs moves whenever you go to a different tab and go back to that pinned tab. Other than that, you are pretty much ready for the final release. More polishing and refining can make it into the next version. 🙂


  • Vivaldi Team

    works for us here in testing. You may have been asked before but what OS and OS version? I am looking for a pattern.



  • Oh great to hear 🙂 thank you for the info and the tip.. for now I edited the *.desktop file by prepending
    env LANGUAGE=en
    in the exec line.



  • OSX 10.11.4



  • I may need to clean install. I just don't want too 🙂


  • Moderator

    Initially, I thought that VB-14890 was not fixed for my YouTube Panel, but apparently the "Loading …" message was due to problems with my webplus.net server, which is often intermittent.

    I wonder what should happen if a web panel server is unavailable. Would it show just a blank page, or should there be a dead bird icon or a warning of some kind?

    BTW: Although I can log in OK, I get an "Invalid Token" message if I try to reply to this blog using Opera 12.17. That may be a sign that I need to start using Vivaldi. Unfortunately, I need email, custom mouse gestures, mnemonic keyboard shortcuts, and a few other things before I can let go of Opera 12.17.


Locked
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.