Amazon digital music library does not play



  • Attempting to play music in Amazon digital library results in no response.
    Likely Chromium related as i have the same symptom in Opera 42 and Chrome 55
    Firefox is unaffected.

    OS is KDE Neon 5.8.5


  • Vivaldi Translator

    @robertbrenner
    I'm not sure if you actually mean Amazon Digital Music.
    Amazon Digital Library seem for books.
    Could you give sample site?

    Also
    I got doubt to suggest you to read;
    Video playback problems, troubleshooting and solutions on Linux
    because you said it also doesn't work in GChrome 55.

    I don't have Amazon account to test.
    But, the sample songs on Amazon Digital Music work for me, if I disable all my ads blocker. If not, the site ask for Flash player.

    Note:
    For some reason amazon.com think I'm from India. :laughing:
    I'm 2 ocean apart.



  • @dLeon It is a service that requires an account.

    I have not tried to play the song samples that are attached to music product pages.

    I'm still digging into the issue on my end - just noticed it last night.

    I'm working with a new laptop and re-installed OS since the last time I've accessed this on Amazon feature, so I've not eliminated all possible variables. But as this issue is common to all my Chromium browsers, I thought it worth posting.

    I've not encountered any other video or audio problems since the ffmpeg codec location issue with Chromium 55 a month ago.



  • Update - the issue appears to be limited to my OS/computer.

    Tested on my daughter's laptop with Peppermint OS7 - both Chrome 56 and Vivladi 1.6 work.

    Tested on my wifes laptop with Mint 17.3 Cinnamon - Chrome 56 works...she wouldn't let me install Vivaldi :-(

    So it seems to limited to my install of KDE neon. I reinstalled all three chromium browsers, but the issue persisted.

    Looks like I'll be distro hopping this weekend.



  • @robertbrenner said in Amazon digital music library does not play:

    Looks like I'll be distro hopping this weekend.

    --> Maui !! :-)

    .....................................................................................................
    Tower & Lappy = Maui 2.1 "Blue Tang" x64 Plasma 5.8.4.



  • Ended up with Mint 18.1 Cinnamon.

    Distros that allowed Amazon to play: Ubuntu 16.10 Unity, Peppermint OS, Mint Cinnamon & XFCE, Solus

    Distros that did NOT allow Amazon to play: Neon (5.9), Maui, Mint KDE and MATE, Ubuntu MATE

    Issue is solved for now, but my curiosity is piqued - Most of these are 16.04 based (i did not test anything Arch or Fedora derived), so the base does not seem to be a cause. KDE and MATE DE's seem to be affected, while Gnome 3 and XFCE/LXDE based ones do not.

    Do DE's handle perhaps handle Flash or Google's plugins differently?

    Also, as a side note - I got screen tearing (accross the desktop, not just in Vivaldi) with Mint KDE and Maui, but not with Neon - another brain teaser.


  • Vivaldi Translator

    @robertbrenner

    Do DE's handle perhaps handle Flash or Google's plugins differently?

    DE = Desktop Environment right?
    No DE (Gnome, KDE, Cinnamon, XFCE etc.) ever coded to use/alter Flash nor other Google plugins.
    Except of course, Chrome OS DE, which is could be called (jokingly) Chrome Window Manager.
    Flash & Google Plugins are for browser only.

    The only way DE could interfere Flash is it Compositing feature. Some Compositing settings known to interfere with Flash Video or any Videos with any players like make tearing, black screen, flipping, rainbow effect or even help to spike system resource when video is playing.



  • Ok so i just wanted to try it and found that i apparently did buy a CD via amazon years ago :D happy testing..

    I clicked on play and nothing happened....
    So i read again and thought why are you talking about flash. There is no flash running...
    Flash was blocked by vivaldi (my settings) so i allowed it and reload the page. It did not seem to make a change but when i clicked on play again the music started.

    I am on openSuSE Tumbleweed with KDE Plasma 5.9.0 and flash-player-ppapi 24.0.0.194-1.1 (used to be called pepper?? nah) from Packman Repository.
    So KDE is not the crook.

    As for the tearing issue i guess the Distros have different default settings about v-sync or page flipping. Or maybe they ship with different video drivers (proprietary, non-proprietary, gallium), that have different defaults.



  • Not working today :-( Firefox working - Ubuntu OS, Try again in a month...



  • It's just a Flash Player issue
    Resolved by installing per these instructions:

    https://gist.github.com/ruario/215c365facfe8d3c5071

    Verified to work on KDE Neon 5.9.3 and Ubuntu Mate 16.10.
    Looks like some distros ship with the flash player installed


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.