Saving *jnlp files when chosen to Open them



  • Hello everyone,
    I am using Vivaldi for a while, but now I run into an annoying problem. I've started using java-based web application, which results in downloading *.jnlp files. Problem is, whenever I choose to Open, viz picture:
    0_1484215886740_vivaldi1.png

    this dialog always follows:

    0_1484216023097_vivaldi2.png

    And when I choose Keep button, file is saved into default location, as if I've chosen Save in previous dialog, with checkbox Always save Files to Defalult Download Location checked.

    I am opening this application many times, which generates anoying amount of jnlp files in my default location for saved files, where I keep only important files. I'd like these *jnlp files to be downloaded to TEMP directories, when I choose to Open, not to Save them

    This behaviour is not observed for other files, such as potentially dangerous .exe files or other.

    I would like to ask, whether this behaviour can be supressed by some settings, or if it is a bug and can be fixed.

    Thanks in advance

    Jiri



  • Nobody can help me? No advice?
    Jiri



  • there is no easy solution for now, the expert hackers can (after closing Vivaldi) open
    C:\Program Files\Vivaldi\Application\1.8.770.9\resources.pak
    with an hexeditor, search "jnlp" (the hex pattern should look like 04 6A 6E 6C 70 10), change the j to x (xnlp) and after that the extension checked will be xnlp
    repeat for every extension you need to stop being warned about.
    Make a backup of the file before trying, and more important, don't come back to me crying if you mess up your Vivaldi installation.



  • You can write a bugreport for this issue.
    https://vivaldi.com/bugreport/



  • @iAN-CooG Thanks for your suggestion, although it doesn't solve problem with location, where the file is "saved for opening", it solved my problem with that annoying confirmation popup. Thanks for your help.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.