Favicon not loading properly



  • Hi, New Vivaldi user here. I would like to take this opportunity to inform you guys about a bug/issue that favicons for websites doesn't load sometimes and since favicon doesn't load, the colors ( the one which paints the tabs depends upon the favicons) doesn't work. Suppose if I browse vivaldi forums and then I switch to a tab to a site where favicon is not loaded, it will still show the vivaldi tab color there too. Please see this link for the GIF picture of this issue : http://imgur.com/a/D0Adc Note: Favicon of omgubuntu.co.uk shows up in other browsers properly. You can also test with some randoms sites if you want. Hope you fix this soon. Thanks.



  • Works for me with 1.4 Final.



  • For me its doesn't work. I mean for some sites, I don't get favicon fetched.

    My system info:
    1.4.589.11 (Stable channel) (64-bit)
    Windows 7 64 bit.



  • @burnzero:

    I mean for some sites, I don't get favicon fetched.

    My system info:
    1.4.589.11 (Stable channel) (64-bit)
    Windows 7 64 bit.

    We cant test such issue without more description on which URLs that happens and what you are doing there to get the pages.
    Please give us more information.



  • HI,

    I already posted a GIF ( imgur link) in my first post showing the issue. Even websites like amazon.com, flipkart.com, forum.xda-developers.com, the favicons doesn't load and due to that the tab color not changes.

    /// and what you are doing there to get the pages.

    I just input the address of a website in address bar.

    If you have any tips or troubleshooting steps, please let me know so that I can try.



  • Strange. May be a bug with Vivaldi and Windows 7.

    Please try this:

    A)
    1. Close Vivaldi
    2. Delete these files in browser's profile path (shown in vivaldi://about):
    Favicons*
    Last*
    Current*
    3. Restart Vivaldi

    B ) refresh your browser's profile
    See https://vivaldi.net/forum/all/14141-refreshing-or-cleaning-your-profile

    I hope this will help you.



  • My Vivaldi is 1.4.589.11 64bit | Win 10x64

    I tested your described sites and after most of the content is loaded the favicon is detected and the color oft the tab changes.

    Favicon loads at end of loading in Firefox and Chromium, too.



  • I can confirm this issue, I am having it as well. Can also confirm that resetting my profile (was done for a separate reason) did not fix the issue. Will try solution A.

    EDIT: Solution A did not work.



  • I think that this is not solved yet. I'm having the same issue in Vivaldi for linux 1.7.735.46 (Stable channel) (64-bit)

    The fact is that in a private window, favicon apears



  • @vilory One of these usually helps with solving such issues:

    1. Force reload the page and all of its contents including scripts, styles and images (by default: press [CTRL] + [SHIFT] + [R] or [CTRL] + [F5]);
    2. Open the page in Private Window (by default: press [CTRL] + [SHIFT] + [N] to launch a new Private Window or select Menu > File > New Private Window). If the page works in Private Window, then go to step 4.
    3. Disable all extensions (if this resolves your issue, then try enabling them one by one to check which one is causing the trouble);
    4. Clear browsing data and restart the browser if necessary;
    5. Refresh your profile (as a last resort).


  • @pafflick , thank you for your help. I've already done that before my previous post but that did not work. I've even removed my profile directory and started "from zero" but it did not work.

    I've discarded problems into the favicon file as it works on a private window so my guess is with the call:
    <link rel='shortcut icon' href='/favicon.ico?1489486212' />

    I know this is the windows forum, and I'm using linux but it's the same issue. Maybe it is solved in Windows but not in Linux.

    Anyway, it is not such an important thing, it only happens in our open redmine (http://www.redmine.org) but it is a little bit frustrating as the url bar is not colored.



  • @vilory Can you take a look at similar thread that I just replied to, to check if anything there helps you with this? Perhaps there is some bug in Vivaldi, but we need more tests to make sure how exactly does it behave and how to reproduce it...



  • @burnzero

    I agree.
    Favicons won't load properly when bookmarks are imported from Chrome. (in my case)
    Eventually they will load, but this can take a very long time.
    However if you enter websites manually and bookmark them, they will usually show their true colors.



  • Hi @pafflick,

    Sorry for the late response.

    The post you linked implies modification of the site which, for now, I cannot do. We did not modify the favicon either.

    I've realized a couple of things though that might help you:

    • The site is https, if any request is made to http it is redirected to https (RewriteRule ^(.*)$ https://%{HTTP_HOST}$1 [L,R=301])
    • The site has htacess. I don't think this is relevant as private window works but may be something to have into account.
    • The favicon does appear in "typed urls" section that appear when I type in the address bar.

    It is weird and, until now, I have not faced this issue with any other site.



  • 8.1 (x64) here, fresh install, same issue.

    Examples of missing favicons: AOL Mail, Fosshub.

    Again, the issue does not concern the bookmark section but the tabs, so one makeshift solution on the devs side would be to implement an option to disable favicons on tabs entirely, same way the bookmark bar can be set to the text-only view.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.