Procesy zombie po zamknięciu Vivaldi na Linuksie



  • Witam ;-) Chwilowo musiałem odstawić Vivaldi ponieważ po zamknięciu pozostawiała wiele procesów zombie ( przy ponad czasami 10-cioma zakładkami - a 10 to standard u mnie ) i cały czas odczytywała jakieś dane z dysku co ciekawe po zamknięciu odczyt pozostawał do momentu wykonania polecenia : killall -9 vivaldi-bin Poczekam jakiś czas jak wyjdzie może v2.0, a chwilowo wróciłem do poczciwego Chromium A dystrybucja KDE neon 16.04 (xenial) User Edition 5.6 zakładki ( strony ) są różne i z reguły odczyt danych z dysku z prędkością 1-1,5 mb/s zaczyna się jak przechodzę z FB (znaczy jakiś link odsyłający gdzieś tam ) i wtedy zaczyna się odczyt z dysku i trwa dopóki nie ubiję wszystkich procesów ( oczywiście najpierw zamykam vivaldi ) ale co jest odczytywane to możecie mnie zastrzelić nie mogę namierzyć ;-) Dzieje się tak wersji stabilnej i snapshot ( może wam się uda namierzyć co się mogło dziać, ale wątpię bo to mógł być przypadek jeden na milion ), puki co opisałem tylko na FB na grupie i tutaj, nie zgłaszałem błędu bo z moim angielskim to by wyszło masło maślane ;-) Pozdrawiam liczę że jak wyjdzie v2.0 to nie będzie można się do niczego przyczepić ;-) Wczoraj była aktualizacja KDE neon 16.04 (xenial) User Edition 5.7 w wolnej chwili przetestuje czy takie same rzeczy się dzieją.



  • Witam ;-)

    Chwilowo musiałem odstawić Vivaldi ponieważ po zamknięciu pozostawiała wiele procesów zombie ( przy ponad czasami 10-cioma zakładkami - a 10 to standard u mnie ) i cały czas odczytywała jakieś dane z dysku co ciekawe po zamknięciu odczyt pozostawał do momentu wykonania polecenia :
    killall -9 vivaldi-bin

    Poczekam jakiś czas jak wyjdzie może v2.0, a chwilowo wróciłem do poczciwego Chromium

    A dystrybucja KDE neon 16.04 (xenial) User Edition 5.6
    zakładki ( strony ) są różne i z reguły odczyt danych z dysku z prędkością 1-1,5 mb/s zaczyna się jak przechodzę z FB (znaczy jakiś link odsyłający gdzieś tam ) i wtedy zaczyna się odczyt z dysku i trwa dopóki nie ubiję wszystkich procesów ( oczywiście najpierw zamykam vivaldi ) ale co jest odczytywane to możecie mnie zastrzelić nie mogę namierzyć ;-)

    Dzieje się tak wersji stabilnej i snapshot ( może wam się uda namierzyć co się mogło dziać, ale wątpię bo to mógł być przypadek jeden na milion ), puki co opisałem tylko na FB na grupie i tutaj, nie zgłaszałem błędu bo z moim angielskim to by wyszło masło maślane ;-)

    Pozdrawiam liczę że jak wyjdzie v2.0 to nie będzie można się do niczego przyczepić ;-)

    Wczoraj była aktualizacja KDE neon 16.04 (xenial) User Edition 5.7 w wolnej chwili przetestuje czy takie same rzeczy się dzieją.



  • Wydzieliłem Twój post z wątku Mateusza do osobnego wątku.

    Czy tak się zachowywała każda poprzednia wersja Vivaldi, której używałeś, czy od ok. wersji stabilnej 1.2 tak się dzieje?
    Daj znać, czy na wersji 5.7 przestało to zachowanie występować.

    Jak często to się zdarza?
    Czyli jesteś w stanie zauważyć, że będą procesy zombie po zamknięciu po tym, że jak klikniesz link na Facebooku, to zaczyna się odczyt z dysku? I trwa nawet po zamknięciu przeglądarki, aż do wydania komendy killall? A po zamknięciu chociaż część procesów się zamyka i trochę pamięci się zwalnia, czy znika interfejs przeglądarki, ale wszystkie procesy pozostają?

    Czy liczba kart ma znaczenie? Mógłbyś sprawdzić czy przy jednej karcie też uda Ci się to odtworzyć?
    I czy mógłbyś podać przykładowy link, po kliknięciu którego zaczyna się ten odczyt z dysku?

    A nie masz narzędzi w Linuksie, żeby ustalić z których plików czyta proces vivaldi-bin? Na pewno można to sprawdzić, a bardzo by to pomogło naprawić problem.
    W Vivaldim jest też Menedżer zadań - wywoływany z menu Narzędzia. Czy nie pokazuje on który proces/karta jest nadaktywna / czyta dużo danych? Czy zamknięcie wszystkich kart i otworzenie tylko jednej pustej nie zatrzymuje czytania z dysku - i nie powoduje umożliwienia zamknięcia przeglądarki bez procesów zombie?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.