Blurry/fuzzy text



  • Sometimes Vivaldi displays web pages with blurry text. I have no idea what makes it happen. But it's connected to a specific tab. All of a sudden the text displayed in a certain tab will go blurry. If I go to any other web page in that tab, it will also have blurry text. However, if I copy the URL from that tab into another tab, the text will be displayed fine there. I have tried disabling and enabling DirectWrite. I think it doesn't happen when DirectWrite is disabled, but I haven't tried that much, since having it disabled is not really an option. It's too hard to read text that way. I'm attaching two screen captures, both taken of the same web page, open in two different tabs at the same time. Maybe I should post this as a bug report somewhere... Attachments: [img]https://forum.vivaldi.net/uploads/attachments/83559/VivaldiCapture1.PNG[/img],[img]https://forum.vivaldi.net/uploads/attachments/83559/VivaldiCapture2.PNG[/img]



  • Is this Snapshot 1.3.534.3 or stable? I used to have this issue before but now it seems to be fixed.



  • The version is 1.2.490.43 () (32-bit)



  • I just discovered something. This happens when I click to open a link in a new window or tab. Seems to happen every single time. For instance, go to google.com and open any link in a new window or tab. To compare copy that URL manually into a new tab.





  • Thanks. Since I already have the current stable version, I'm not sure how I should proceed. I'd really like to have this annoying issue fixed, but I don't want to introduce a host of other bugs instead. I guess the best would be to wait for this bugfix to be included in the next stable version? Any idea when that will be released?



  • I'm a bit confused. Den_po writes that this is fixed in snapshot 1.3.534.3. But in the following thread, it seems that this snapshot has even bigger font rendering problems:
    https://vivaldi.net/en-US/forum/vivaldi-browser/12782-bring-back-directwrite-flag

    What's the connection between the bug I described and what people are complaining about?



  • Something similar has happened in Chrome time ago. It was a memory problem (font cache). Deleting cache and cookies solved the problem.


  • Moderator

    Sorry! I misunderstood that this was a different topic.

    Den _pro explained it below.



  • @nicknu:

    I'm a bit confused. Den_po writes that this is fixed in snapshot 1.3.534.3. But in the following thread, it seems that this snapshot has even bigger font rendering problems:
    https://vivaldi.net/en-US/forum/vivaldi-browser/12782-bring-back-directwrite-flag

    What's the connection between the bug I described and what people are complaining about?

    What has been fixed is blurred fonts in child tabs.
    Fonts in UI elements is MUCH older problem.



  • @Pesala:

    None whatsoever. nicknu is a new forum member who does not understand how to use the forum yet..

    The Direct Write problem created by Chrome will not be fixed unless they have a change of heart, so don't wait for it. Look for work arounds such as increasing the UI scaling.

    Perhaps a moderator could move the off-topic posts to their own thread? Reporting posts doesn't work now either.

    How is it off-topic when I'm asking about the connection of this topic (which I started) and something else? Please tell me what rule it is I'm violating.

    Thanks to Den_po for answering my question though.



  • @nicknu:

    How is it off-topic when I'm asking about the connection of this topic (which I started) and something else? Please tell me what rule it is I'm violating.

    Thanks to Den_po for answering my question though.

    Actually, you didn't ask about a connection. Your post just said

    Fixed in the latest snapshot

    Perhaps something was omitted or edited by mistake?
    But that is what caused the confusion for nicknu

    You didn't violate anything, don't worry ;)



  • @TbGbe:

    Actually, you didn't ask about a connection. Your post just said

    Fixed in the latest snapshot

    Perhaps something was omitted or edited by mistake?
    But that is what caused the confusion for nicknu

    You didn't violate anything, don't worry ;)

    That post was not from me. You seem to be a little confused about who posted what.



  • Apologies, you are correct.
    I meant to say Den_po just posted the link which caused YOUR confusion.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.