入力エリアにフォーカスがある状態で一度タブ切り替えて再び入力始めると、1文字目が未確定なのに確定される



  • Twitter 経由で教えてもらった不具合なのですが、入力エリアにフォーカスがある状態で、一度マウス・クリックやキーボード・ショートカットなどでタブを切り替えた後、再び元のタブに戻して入力エリアで日本語入力を始めると、最初の一文字目が未確定なのに確定されてしまいます。 確定されるパターンは、たぶんこのフォーラムに以前書いた『アドレスバーのオートコンプリートを使用可能にしてると、アドレ​スバーで日本語検索時、1文字目が未確定なのに確定される』と同じで、例えば「かわら」と入力しようとすると「kあわら」、「わたなべ」と入力しようとすると「wあたなべ」と言った具合になります。 アドレスバーのオートコンプリートを使用可能にしてると、アドレスバーで日本語検索時、1文字目が未確定なのに確定される↓↓ https://vivaldi.net/forum/japanese/8665-1 そのためアドレスバーのオートコンプリート設定を無効にしてみたところ、こちらの不具合の場合は無効にしていても発生しました。 ちなみに私が発生を確認したのは、 [ul] [li]・このフォーラムのトピック作成画面の『Subject』欄[/li] [li]・[url=http://news.yahoo.co.jp/]Yahoo!ニュースのニュース検索用の入力ボックス[/url](※左側の方)[/li] [li]・[url=https://twitter.com/]Twitter 公式WEB[/url]右上の検索ボックス[/li] [/ul] です。ただし私の環境(Vivaldi Snapshot 1.3.501.6、Mac OS X El Capitan 10.11.5、Google 日本語入力 2.17.2400.1)の場合、起きたり起きなくなったりするようです。 あとこの不具合を教えてくれた方([url=https://twitter.com/HAK_JF/status/745949750042714112]こちらの方の環境は、OS が Windows で、使用IMEは MS-IME と Google 日本語入力[/url])によると、 [ul] [li]・Google 検索[/li] [li]・Twitter のキーワード検索[/li] [li]・mixi[/li] [li]・Googleハングアウト[/li] [/ul] などで発生するそうです。 当該ツイート↓ [url=https://twitter.com/HAK_JF/status/745957798714945536]https://twitter.com/HAK_JF/status/745957798714945536[/url]


  • Vivaldi Team

    ご報告ありがとうございました。
    アドレスバーでの問題は未だに再現できていないのですが、この問題は私の環境(Windows, Mac共に)再現することができました。
    ただ、どのタブでも再現するというわけではなく、スピードダイヤルに切り替えた後に、該当タブに戻って入力する際に発生します。何れにしても、確実な再現方法が分かっているので、なるべく早く修正するように対応したいと思います。



  • @tatsuki:

    …ただ、どのタブでも再現するというわけではなく、スピードダイヤルに切り替えた後に、該当タブに戻って入力する際に発生します。

    この点なのですが、私の環境も冨田さんと同じ症状なのですが、この不具合を教えてくださった方によると、その方の環境(Windows10、MS-IME)だと「スピードダイヤル以外のタブに切り替えても発生する」とのこと。

    当該ツイート↓
    https://twitter.com/HAK_JF/status/746100571971653636



  • この問題、正式版 1.7 で解消されたと思っていたのですが、どうやら完全には解消されていないようです。「同様の問題が発生する」とツイートされてる方を、昨日と今日見かけました。以下は関連ツイートのリンクです。

    rubrofemoratus さんのツイート↓

    nh4F3v6toUP1BM9 さんのツイート↓

    お二人とも環境が Vivaldi 正式版の最新版(1.7.735.46)、OS が「Windows 10」、IME が「Google 日本語入力」との事なので、この環境だとまだ発生するのかも…しれません。(^^;

    ちなみに私の環境では、この問題は発生しませんでした。

    【使用環境】

    • Vivaldi Snapshot 1.8.755.3
    • Google 日本語入力 2.20.2700.1
    • macOS Sierra 10.12.3


  • @Connie said in 不具合報告・要望2 - Vivaldi 1.1以降:

    テキストボックスに日本語で入力した時、特定の条件で1文字目がアルファベットで確定してしまいます。
    自分が確実に再現出来る状況は、

    1.タブを2つ以上開く。
    2.一つ目のタブでテキストボックスをクリック。
    3.タブバー上でスクロールして二つ目のタブに切り替える。
    4.タブバー上でスクロールして一つ目のタブに切り替える。この時テキストボックスはクリックされたままの状態で「 | 」が点滅している。
    この状態で日本語入力すると1文字目がアルファベットで確定されます。
    「ゔぃゔぁるでぃ」と入力すると「vいゔぁるでぃ」となります。
    Google日本語入力を使用していますが、Microsoft IMEでも同様に起こります。

    Vivaldi : 1.7.705.3

    自分の環境でもこの手順でまだ再現出来ます。

    • Snapshot 1.8.755.3
    • Google 日本語入力 , Microsoft IME
    • Windows 7 32bit


  • @kyu3a said in 入力エリアにフォーカスがある状態で一度タブ切り替えて再び入力始めると、1文字目が未確定なのに確定される:

    nh4F3v6toUP1BM9 さんのツイート↓

    先の書き込みでツイート紹介した nh4F3v6toUP1BM9 さんですが、その後、最新の Snapshot(1.8.755.3)を試したそうですが、そちらでも同じ症状が出たそうです。あと Microsoft IME でも、同様の症状が発生するそうです。

    関連ツイート↓
    https://twitter.com/nh4F3v6toUP1BM9/status/835855150971420673


  • Moderator

    こちらのバグですが、バグ報告はソプラノによってされており(VB-23354)、修正のため開発者が割り当てられている状態です。

    私の記憶が正しければ、アドレスバーでの類似したバグ(VB-16325)が修正された以後も、そのまま改善されず残っていたかと思います。



  • @knokmki612 said in 入力エリアにフォーカスがある状態で一度タブ切り替えて再び入力始めると、1文字目が未確定なのに確定される:

    こちらのバグですが、バグ報告はソプラノによってされており(VB-23354)、修正のため開発者が割り当てられている状態です。

    私の記憶が正しければ、アドレスバーでの類似したバグ(VB-16325)が修正された以後も、そのまま改善されず残っていたかと思います。

    そうでしたかぁ〜!ちなみにこのバグ、Mac 版では起きない(私の環境では起きない & このバグに関してツイートされてる方の中に Mac 版使ってると言う方がいない)みたいなのですが、Mac 版は解消されてて、発生するのは Windows 版だけなのでしょうか?


  • Moderator

    @kyu3a

    たしかに私の環境でもMacでは再現できなかったのですが、他の方の

    • 1.7.735.46 (Stable channel) 64bit
    • macOS Sierra ver. 10.12.3 on MacBook Pro(13-inch, Early 2011)

    の環境で再現したようです。

    この他Linuxでも再現できました。



  • windows 32bit ですが、Snapshot 1.9.804.3 で、挙動が変わりました。
    1文字目の入力が確定するのではなく、未確定状態にはなるのですが、未確定の文字が表示されていないという状態です。
    何らかの修正をしたようですが、修正が不完全なのでしょう。
    もう少し頑張ってほしいです。


  • Moderator

    確認ありがとうございます!

    (VB-24467)は一度修正完了となりましたが、ソプラノメンバーによって仰る通りの挙動について共有されています。

    割り当てられた開発者によればChromiumでの修正が必要だったようです。

    ですので、Chromiumのリリースに当該の修正が含まれ、Vivaldiに反映されるまでお待ちいただければと思います!



  • Windows7 32bitの環境で Snapshot 1.9.811.13 ですが、また元の症状に戻ってしまいました。


  • Moderator

    @kawais070
    Snapshot 1.9.818.40にて修正が取り込まれたようです!

    Chromiumで修正が必要だった箇所ですが、Vivaldi側でパッチを当てて対処された模様です!
    よろしければご確認いただければと思います!



  • @knokmki612 確認しました。対応ありがとうございました。


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.