Sticking with Firefox because Vivaldi fonts rendering is softer



  • Hi, I'm running 1.3.501.6 (Developer Build) (64-bit) on Windows 10 and the way Vivaldi renders fonts is just too soft for me, when comparing the same sites on Firefox. Firefox system seems to display the fonts slightly darker and less (very very slightly) less fuzzy or grey or what every. Any hints on how I can change any settings for Vivaldi to make font rendering close to Firefox?



  • One dubious benefit of getting older is that all text looks fuzzy, so I don't notice such details. If text is hard to read, I just zoom in a bit more. I have to zoom in really close to spot any difference. A minute difference like this would not stop me using a browser that suited my needs better.

    Top is Firefox, bottom is Vivaldi.

    [attachment=3817]TextRendering.png[/attachment]
    Attachments:



  • Same here. But this goes for every browser based on webkit/blink. Something about how the tab sandboxing works that limits using the font engines in Windows. This is something you'll either have to accept or not accept if you intend to use a blink-based browser. Are the features of the browser more important than the font quality?

    Firefox has much more option for font management. I am able to tweak the use of Cleartype and GDI font rendering (have a look at the Anti-aliasing tuner extension).

    I don't see why font support is such a mission, but then I guess Windows doesn't help with that by offering different methods of font rendering. I don't see the problem on linux-derivatives. Using a Fedora VM with Infinality patches gives me consistent and excellent font rendering across browsers. Also consistently crap across all without those Infinality patches. :P

    The rendering can drive me mad on my DELL U2711 with its harsh AG coating, but at my office with some DELL 23" IPS panels with glossy covering it winds up being reasonably acceptable.



  • Get A+ Font Rendering Enhancer. This will make the fonts a lot better, even better than Firefox:
    https://chrome.google.com/webstore/detail/font-rendering-enhancer/hmbmmdjlcdediglgfcdkhinjdelkiock?utm_source=chrome-app-launcher-info-dialog]



  • Not sure if this will work for everyone (there seems to be some kind of bug which I've had triggered by visiting the Chrome web store, and makes everything even blurrier) - but this has fixed things most of the time for me:

    go to "chrome://flags"
    Search for "LCD text anti-aliasing" and enable it
    I think you have to have directwrite turned on if you've disabled it in an attempt to fix things.



  • @thigger:

    go to "chrome://flags"

    If you give the full URL with the anchor, no one will need to search for it

    chrome://flags#lcd-text-aa



  • You should disable directwire in vivaldi:flags. vivaldi://flags/#disable-direct-write
    But it's kinda broken in 1.2:
    https://vivaldi.net/en-US/forum/vivaldi-browser/11680-fonts-problem-with-disabled-directwrite


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.