H.264/mp4 video not working



  • For some reason, I can't play any html5 h.264/mp4 videos in Vivaldi, html5 video encoded as WebM or Ogg play just fine. This problem exists since some time and all things I tried so far didn't work out. This is for example a problem on www.imdb.com where I can't see any trailers (I get a red error message reading: "Sorry, this video is unsupported on this browser"). The test page at [url=http://www.quirksmode.org/html5/tests/video.html]http://www.quirksmode.org/html5/tests/video.html[/url] doesn't render the h.264 video, I only see (inactive) player controls. Some details: [ul] [li]- I'm running Windows 10 (x64)[/li] [li]- Graphics card is an (old) Intel 945 Express[/li] [li]- the problem is present in Vivaldi 1.1.453.45 (x86), Vivaldi 1.0.380.2 (x86, standalone), Vivaldi 1.1.453.47 (x64, standalone)[/li] [li]- Chrome 50.0.2661.87 plays h.264 videos just fine (and so does MS Edge)[/li] [li]- booting into Ubuntu 15.10 and running Vivaldi for Linux, the h.264 videos play without problems[/li] [li]- I tried with a clean profile & without any extensions but to no avail[/li] [li]- installing the latest K-lite codec pack didn't change anything[/li] [li]- I tried disabling the video hardware-acceleration in flags and also tried with --disable-gpu-sandbox option[/li] [/ul] I thought it might be a driver problem (due to the very dated hardware), or maybe a codec problem, but since Chrome 50 does render those videos without problems, I'm really out of ideas what's wrong here.



  • Chrome has own codecs incorporated in program.
    Vivaldi uses the installed Windows codecs.

    May be it is a setting in KLite which hinders Vivaldi to use it.
    Please checks this.

    May be your hardware does not run Hardware Acceleration which is needed for H.264.
    Please open chrome://gpu
    In first section are there some not green?

    This video https://labs.gwendragon.de/blog/Web/Browser/Vivaldi/big_buck_bunny.mp4 plays for me in Windows 10x64 (version 10.0.1511 Build 10586.218 )



  • No external codec needed on windows to get vivaldi working, although the LAV filters, usually, won't mess anything unless specifically instructed.

    Pleas check if the MS codecs are set as default and registered correctly with one of the many codec setup tools.

    Also uninstalling the Klite package, usually resets the windows settings to the stock status



  • Thanks a lot for your suggestions. I tried with the CodecTweakTool to fix potential problems (General->Fixes) and also had a look at the DirectShow codecs, they are all installed and activated. I also tried to set the preferred splitters to the ones recommended by the tool (in most cases LAV). Windows Media Player correctly plays any h264 or mp4 video, so I think the codecs should be set up correctly. Additionally I ran a scan with the quite old tool "Filmerit" which reported no problems with the installed codecs. Also trying to uninstall (+reboot) K-Lite didn't change the problems.

    The page chrome://gpu in fact shows quite a number of problems - like I wrote, my graphics chip is quite dated… See the spoiler for the reported problems:

    ! Graphics Feature Status
    [ul]* Canvas: Software only, hardware acceleration unavailable
    * Flash: Software only, hardware acceleration unavailable
    * Flash Stage3D: Software only, hardware acceleration unavailable
    * Flash Stage3D Baseline profile: Software only, hardware acceleration unavailable
    * Compositing: Software only, hardware acceleration unavailable
    * Multiple Raster Threads: Disabled
    * Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    * Rasterization: Software only. Hardware acceleration disabled
    * Video Decode: Software only. Hardware acceleration disabled
    * Video Encode: Software only, hardware acceleration unavailable
    * WebGL: Unavailable
    [/ul]
    Driver Bug Workarounds
    [ul]* clear_uniforms_before_first_program_use
    * disable_d3d11
    * disable_discard_framebuffer
    * disable_msaa_on_non_webgl_contexts
    * exit_on_context_lost
    * scalarize_vec_and_mat_constructor_args
    [/ul]
    Problems Detected
    [ul]* GPU process was unable to boot: GPU process launch failed.
    Disabled Features: all
    * The Intel Mobile 945 Express family of chipsets is not compatible with WebGL: 232035
    Disabled Features: accelerated_2d_canvas, webgl, flash_3d, flash_stage3d
    * All Intel drivers before 8.15.10.2021 are buggy with Stage3D baseline mode: 172771
    Disabled Features: flash_stage3d_baseline
    * Accelerated video decode interferes with GPU sandbox on older Intel drivers: 180695, 298968, 436968
    Disabled Features: accelerated_video_decode
    * Some drivers are unable to reset the D3D device in the GPU process sandbox
    Applied Workarounds: exit_on_context_lost
    * Clear uniforms before first program use on all platforms: 124764, 349137
    Applied Workarounds: clear_uniforms_before_first_program_use
    * Always rewrite vec/mat constructors to be consistent: 398694
    Applied Workarounds: scalarize_vec_and_mat_constructor_args
    * Old Intel drivers cannot reliably support D3D11: 363721
    Applied Workarounds: disable_d3d11
    * On Intel GPUs MSAA performance is not acceptable for GPU rasterization: 527565
    Applied Workarounds: disable_msaa_on_non_webgl_contexts
    * Framebuffer discarding can hurt performance on non-tilers: 570897
    Applied Workarounds: disable_discard_framebuffer
    * Accelerated video decode has been disabled, either via about:flags or command line.
    Disabled Features: video_decode
    * Accelerated rasterization has been disabled, either via about:flags or command line.
    Disabled Features: rasterization
    * Raster is using a single thread.
    Disabled Features: multiple_raster_threads
    * Native GpuMemoryBuffers have been disabled, either via about:flags or command line.
    Disabled Features: native_gpu_memory_buffers
    [/ul]

    So yes, there are in fact problems with my graphics card, however since everything else (Chrome, Edge, Vivaldi @Linux, WMP) render those videos without problems, it's really quite strange why Vivaldi (on Windows) and only Vivaldi has this problem. :unsure:


  • H264 video on Vivaldi needs Hardware GPU acceleration for decoding and your hardware and driver cant work with a GPU.
    That happens with Vivaldi on all systems: no hardware acceleration, no H264.

    You cant compare all browsers and OS against Vivaldi.
    On Linux the codecs are different than on Windows. These are the codecs built from libffmpeg.
    On WIndows Chrome does not use Windows codecs but uses own builtins.
    What Edge and WMP do, i dont know. But i think as they are a part of Windows, they use a different interface than Chromium based browsers.

    Yes, that is not a good experince, but i dont know how we can change it.



  • Out of curiosity try the current Opera .

    As a rule of thumb. If Opera Plays the videos it's a Vivaldi problem, If opera shows the same problem, your problem is in windows/drivers/codecs/ or maybe unsupported HW, as you told.

    Anyway I'm using a no so recent Intel GMA4500 That while newer than yours isn't surely the latest novelty, and Vivaldi://gpu as a fairly long list of compatibility issues and disabled features.



  • Thanks a lot to both of you for your ideas.

    Well, the current Opera developer doesn't play h264/mp4 videos as well. So it really seems to be an issue with my (old) graphics device not supporting hardware acceleration for the codecs used by Vivaldi/Opera. It's really a pity and with more and more sites switching to html5 video instead of flash (which in general is a good development imho) it would be great to have a solution for this problem…



  • Hope I'm not hijacking anything, but can I ask what Vivaldi should or shouldn't play vs other browsers, specifically Chrome ?

    Have been experimenting a bit with media player Emby in Vivaldi and it doesn't play an awful lot of media - doesn't like MKV files as far as I can tell. Would that be my PC or can't Vivaldi do that (yet) ? Can play this stuff fine in Chrome.

    Thanks very much.



  • H.264 codec are mostly used in mp4 files and are much complex at its core. So whenever you try to compress and render, sometimes it may give you error. Try Sony Vegas to do so. I prefer it because I too faced the same issue but when I changed the interface, the matter was solved. You could understand more about H.264 codec on Repair H.264.
    Few video files need to be converted before they are used in your iPhone, iPad, iPod, or Apple TV. You need to convert them to a playable format.
    Those videos that are not iTunes Store might not play on your iPhone, iPad, iPod, or Apple TV. To convert them to a playable format use iTunes.
    For iPhone or iPod

    1. Open iTunes.
    2. Select the video that you want to convert.
    3. From menu bar (at the topmost of your computer screen or at the top of the iTunes Window) choose File > Convert > "Create iPod or iPhone Version."
      For iPad or Apple TV
    4. Open iTunes.
    5. Select the video that you want to convert.
    6. From the menu bar (at the topmost of your computer screen or at the top of the iTunes Window) choose File > Convert > "Create iPad or Apple TV Version."
      To know more about fixing mp4 files on mac devices you

Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.