Stutters and flashes, and slow performance - Antergos (Arch Linux distro) on HiDpi screen



  • I just downloaded the browser and i really love the design and functionality so far, but as you will see in the next video it's practically unusable. I experience heavy stutters and flashes (at the color of the top bar) all over the screen as i browse. The browsing is also super slow, opening new tabs, moving between tabs, and even typing this text. It happens all the time, but especially on heavy websites and full screen. I have a HiDPI screen resolution, it might has something to do with the issue. Here is a video showing the problem: [video width=425 height=344 type=youtube]PA2TfnhvYrA[/video] Here is my system's specs (Click to enlarge): [url=http://postimg.org/image/76bwlv1hp/][img]http://s30.postimg.org/76bwlv1hp/Screenshot_from_2016_04_14_21_49_42.jpg[/img][/url] I'm really sad since as you can see it's totally impossible to surf the web that way, and i like the browser from what i've seen so far. Hope there's some solution to the problem.


  • Moderator

    Perhaps a vsync problem.
    Try command line parameter –disable-gpu-vsync starting Vivaldi in shell or desktop shortcut



  • @Gwen-Dragon:

    Perhaps a vsync problem.
    Try command line parameter –disable-gpu-vsync starting Vivaldi in shell or desktop shortcut

    It worked! But the browser is still really slow, any solution to that?
    I don't think that a web browser in a computer with relatively high specs should be that slow in performance..



  • Thanks Gwen, I have the same issue with flickering (also on Arch with a computer that's becoming a bit old now, i.e. not high spec anymore). I disabled vsync for now and will see whether flickering happens again (anyway vsync was not really helpful for me, according to http://vsynctester.com)

    I also experience slowness here and there, especially with tab opening and tabs switching/cycling. I usually have "a lot" of tabs open, around 15, and reducing their number to 5 or so helps a great deal. I guess that having the UI rendered in Blink is not helping, browsing has never really been a top notch experience on linux to boot :/


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.