Flash player doesn't work



  • I'm trying vivaldi also on linux (lubuntu), but I can't make work the pepper flash yet. I already installed the pepperflashplugin-nonfree and the adobeflash-plugin but still not see anything in the plugins. On firefox works, but it uses another type of plugin xD



  • Strange. On my Ubuntu 14.04 all is fine after installing pepperflash package.
    Which Ubuntu?

    Please try:```
    sudo apt-get update
    sudo apt-get install pepperflashplugin-nonfree
    sudo update-pepperflashplugin-nonfree --install



  • Section Plugins du navigateur ouvert, option "+ Détails" activée : à quel emplacement Vivaldi indique-t-il devoir récupérer flash ? Car il semblerait que le problème soit simplement causé par une erreur de chemin d'accès. C'était en tout cas le cas chez moi…
    1. Fichier de configuration à modifier /opt/vivaldi-snapshot/vivaldi-snapshot (ou /opt/vivaldi-stable/vivaldi-stable, ou /opt/vivaldi-beta/vivaldi-beta : tout dépend de votre version installée) :

    sudo gedit /opt/vivaldi-snapshot/vivaldi-snapshot
    ```2\. Llignes 85 à 100 ; en fonction de votre version de Linux (ci-dessous, les miennes corrigées) :
    
    > if [ -f "/opt/vivaldi-snapshot/PepperFlash/libpepflashplayer.so" ]; then
    > FLASH_PATH="/opt/vivaldi-snapshot/PepperFlash/libpepflashplayer.so" # google
    > elif [ -f "/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so" ]; then
    > FLASH_PATH="/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so" # debian/ubuntu
    > elif [ -f "/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so" ]; then
    > FLASH_PATH="/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so" # arch/slack
    > elif [ -f "/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so" ]; then
    > FLASH_PATH="/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so" # openSuse 32-bit
    > elif [ -f "/usr/lib64/chromium/PepperFlash/libpepflashplayer.so" ]; then
    > FLASH_PATH="/usr/lib64/chromium/PepperFlash/libpepflashplayer.so" # openSuse 64-bit
    > elif [ -f "/usr/lib/pepflashplugin-installer/libpepflashplayer.so" ]; then
    > FLASH_PATH="/usr/lib/pepflashplugin-installer/libpepflashplayer.so" # ppa:skunk/pepper-flash
    > elif [ -f "/usr/lib/chromium-browser/libs/libpepflashplayer.so" ]; then
    > FLASH_PATH="/usr/lib/chromium-browser/libs/libpepflashplayer.so" # rosa/mandriva 32-bit
    > elif [ -f "/usr/lib64/chromium-browser/PepperFlash/libpepflashplayer.so" ]; then
    > FLASH_PATH="/usr/lib64/chromium-browser/PepperFlash/libpepflashplayer.so" # rosa/mandriva 64-bit
    > fi
    
    3\. Enregistrer et rouvrir Vivaldi… Flash devrait maintenant fonctionner.


  • I think our french person means you should edit the vivaldi start script to set the path to libpepflashplayer. But this will be overwritten after new updates!

    Please try to find libpepflashplayer.so on your system

    find / -name libpepflashplayer.so
    


  • Sorry for the use of my native language but my English is not perfect. I'm still going to tried…

    Yes it's a temporary solution. The only i've found.
    My own system indicates the file in 4 different locations (correct for the first 3 ?) :

    • in /usr/lib/pepflashplugin-installer/libpepflashplayer.so
    • /usr/lib/chromium-browser/libs/libpepflashplayer.so
    • /usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so
    • and in a folder created on the model of an older version of google-chrome-stable /opt/vivaldi-snapshot/PepperFlash/libpepflashplayer.so (really productive ?)


  • Where can I download pepperflash for Red Hat based OS? do I need to install and extract it from Chromium directly? Does it works? and one more thing: does it works with stable version? I downloaded it from the flash page but doesn't seems to be working



  • ! fear you have to install chromium or extract pepperflash from the package.



  • Guys is pretty simple.

    Find the location of the installed library, as indicated by Gwen

    Then copy or link it in one of the places where vivaldi is looking for it

    You have them listed in c.debard's message.



  • Ok, I'm pretty noob at linux, I missed the path part ^^
    The laptop in which I had vivaldi doesn't work anymore (was lubuntu 15.10), however for now I can try with lubuntu 14.04 in my other pc.
    So I'll simply check where is the file and put in one of that folders linked above.
    I'll probably go for extraction method, I don't want chrome on that machine.
    Probably with a link will be persistent also after any update, but it's better to try before to say it :D

    edit
    Seems to be some problems, the package is installed, but no .so file anywhere (the find says "permission denied" to any path it looks, if I do as root, nothing happens). However some files are in the /usr/lib/pepperflashplugin-nonfree folder and some others are in /tmp folder (without .so files). There's a source package to gather that file?
    The machine is x86, so probably wont extracted for that reason…
    EDIT
    It worked!
    I took latest unstable chrome from here and I unpacked from it the libpepflashplayer.so file in /usr/lib/pepperflashplugin-nonfree/ folder


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.