Proxy settings on windows – why force me to use IE settings - I would like to enter custom settings



  • I love to see new browsers come out out and currently run IE, Chrome, FF, Opera, and now Vivaldi. The problem is Vivaldia forces me to use IE's proxy settings. I would like to be able to put in custom proxy settings for Vivaldi only or browse in no-proxy mode. Firefox does this best. In chrome I had to install an extension to bypass it. If I can't bypass it, it is a deal killer for me and I won't use it. I rarely use Opera for this reason. Thank you.



  • Vivaldi is just a thin shell over Chromium. So we get all the annoying bullshit that comes with Chromium, like this. It's the one thing that immediately has me thinking less of Vivaldi, probably because I'm still upset about Opera throwing out their entire GUI when they went to Chromium too; I assume they had no choice, but it was still traumatic.

    One of the numerous reasons I went to Firefox with a bunch of addons (all-in-one sidebar, FMV Speed dial etc) instead of Chrome or remaining with Opera 2x, and why I'm just mildly excited about Vivaldi. Though I have to say, the page transforms in the task bar are great, and I love that there are built-in notes. Granted, not yet feature complete notes, but they're there. So maybe there's hope.



  • Yes, the browser has some positives, i will keep an eye on it and start using it if I can use the non-IE proxy settings



  • You CAN force an individual proxy setting by using the command line or modifying the desktop shortcut in the same way as you may do it with chrome for the session.
    Just add the parameter for example

    --proxy-server=127.0.0.1:4001 
    ```so it will use a local proxy listening on port 4001\.
    
    I tested both win7 and ubuntu 14.4, seems to work.
    [http://digitizor.com/2010/03/23/set-proxy-google-chrome-separately/](http://digitizor.com/2010/03/23/set-proxy-google-chrome-separately/)
    Of course, use path to vivaldi instead of chrome. Copy the desktop shortcut to have one with proxy and one without as workaround.
    
    With Linux you may start vivaldi from terminal with
    

    ~$ vivaldi --proxy-server=127.0.0.1:4001

    
    Not sure if this works, but I guess:
    [http://www.chromium.org/developers/design-documents/network-stack/socks-proxy](http://www.chromium.org/developers/design-documents/network-stack/socks-proxy)
    
    Take notice of this statement on that site:
    
    > The –proxy-server flag applies to URL loads only. There are other components of Chrome which may issue DNS resolves directly and hence bypass this proxy server. The most notable such component is the "DNS prefetcher".Hence if DNS prefetching is not disabled in Chrome then you will still see local DNS requests being issued by Chrome despite having specified a SOCKS v5 proxy server.
    
    I think, it's the same here (untested).
    
    Michael


  • Just downloaded and install vivaldi remembering the good old days of opera 2… sadly I just found out is just and skin to Chomium... Can not even configure a custom proxy, different from the one in my system.
    The start parameter is not an option; given that this browser is for the power user I was hopping to find something like custom browser configuration for any given site... including proxy access...

    I hope the developers realize that the old opera users still lurking the web still looking at the most radical options and customization that the old opera brings to the table... Heck today even should have TOR - I2P network integration for the no tracking option / paranoid user.


  • Moderator

    Vivaldi is not yet a power user browser. It is just trying to grow up to be one. And it's growing like a weed, if you ask me.

    Not only is Jon aware of Olde Opera users lurking on the web, he is counting on them to populate the userbase of this browser as it becomes more and more able to step into the shoes of that venerable old browser. The very existence of such lurkers is what drove him to create the browser in the first place.



  • Yes, this is really annoying! I don't want IE dialogs and Vivaldi has its own proxy panel like all other available options.



  • Hi all, I've managed to get this working on Vivaldi 1.6.x in Windows 10:

    • I couldn't get --proxy-server to work, at all.

    • As Vivaldi uses Blink, Chrome extensions all work, go to: vivaldi://extensions

    • Install something like "Proxy SwitchSharp", which worked for me, but many other proxy switching extensions are available for you to choose from.

    Hope this helps, it is an annoying issue, and it would be nice if Vivaldi supported a built-in override to the OS proxy settings.

    Kind regards,
    arfonzo


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.