Libpepflashplayer.so very high disk write consumption



  • The flash player remains hanged even after closing the browser and writing who knows what


  • Moderator

    Versions? Flasplayer?Linux? Windowmanager? Vivaldi?



  • Browser: Vivaldi Browser > v.1.0.403.24
    OS: linux Ubuntu 14.04.4 LTS
    flash version: /opt/google/chrome/PepperFlash/libpepflashplayer.so ( 20.0.0.306 )
    Attachments:


  • Moderator

    Please install and try with Latest Snapshot! https://vivaldi.net/en-US



  • Done, works great! 😉


  • Moderator

    Disk I/O less now?



  • yes


  • Moderator

    Fine, good to hear your problem is solved now! 🙂



  • I am having the same problem.

    Browser: Vivaldi Browser v.1.0.403.24
    OS: linux Debian 8.4 (kernel 3.16.0-4-amd64)
    flash version: /opt/google/chrome/PepperFlash/libpepflashplayer.so ( 20.0.0.306 )

    I tried newest snapshot, but the problem remained. It writes around 10MiB every second - this could be a problem, especially if you have SDD (like me).



  • It started happening again. It fails in the stable version and in the last snapshot. I think is a difficult problem to detect because although the disk usage is high it not so evident to disguise why is happening. It also somemtimes could be not so noticeable because the computers continues working and not necesarily freezes the computer, althout sometimes it really slow down everything. But is still there.



  • I've had this issue on other versions:
    https://vivaldi.net/en-US/forum/vivaldi-browser-for-linux/8905-couple-of-annoyances-bugs-on-both-linux-and-windows#49517

    Try killing all the stalled processes, removing these files, and restarting vivaldi:
    "~/.config/vivaldi-snapshot/Default/Top Sites"
    "~/.config/vivaldi-snapshot/Default/Top Sites-journal"

    I believe that's how I solved it. Updating and downgrading versions never fixed anything.



  • Same here. High I/O rate on Top Sites. Delete "Top Sites" fixed the problem.

    54327 be/4 cpyang 620.76 M 1511.27 M 0.00 % 50.86 % libpepflashplayer.so –ppapi-flash-version=21.0.0.213 [Chrome_DBThread]

    Distributor ID: Ubuntu
    Description: Ubuntu 16.04 LTS
    Release: 16.04
    Codename: xenial

    ii vivaldi-snapshot 1.1.453.30-1 amd64 A new browser for our friends



  • same here with Vivaldi 1.3.501.6 64bit, Shockwave Flash 13.0 r0 (Version: 13.0.0.214, /opt/google/chrome/PepperFlash/libpepflashplayer.so),
    I filed a bug.

    Edit: Unfortunately this also happens when the plugin is deactivated. That's odd and by now makes Vivaldi kind of enerving…
    Edit2: With libpepflashplayer.so 21.0.0.242 it seems to be the same as below (no idea why my system used old /opt/google/PepperFlash/ version before, until I just moved it away…)
    Edit3: does not seem to have anything to do with Flapper…

    my console snippet to kill libpepflashplayer process, after closing Vivaldi (use at own risk, this will also kill Vivaldi if its still running):

    kill -9 $(sudo iotop -n2 | grep libpep | awk '{print $1}')
    


  • @AsterX:

    my console snippet to kill libpepflashplayer process, after closing Vivaldi (use at own risk, this will also kill Vivaldi if its still running):

    kill -9 $(sudo iotop -n2 | grep libpep | awk '{print $1}')
    

    …Or just this should do it too:

    killall -9 vivaldi-bin
    ```;)
    
    Did Deleting 'Top Sites' after killing the process and before starting vivaldi again help at all?


  • @hekel:

    @AsterX:

    …Or just this should do it too:

    Thats true, just thought it would be pep related…
    @hekel:

    @AsterX:

    Did Deleting 'Top Sites' after killing the process and before starting vivaldi again help at all?

    It seems to help at least for the moment (with at first glance no real side effects besides SpeedDial has to reload thumbs).


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.