TAB key not working?



  • To me Vivaldi is non-usable since 1.418 (at least). The TAB key does not work, at all, it is as if it does not exist as far as I can tell. Also, in text fields, like the one I am writing this, the numeric keys ("1", "2", ...) change tabs instead of writing "1", or "2". Removing most of the keyboard usability absolutely kills it, and making the keys work is not a super-duper-feature, it is just about the most expected thing to have... I am stuck on version 1.403... (I'm using Linux, so I post here, but it may happen on other OSs)


  • Moderator

    Do you use a special extra keyboard or the numpad? Which Linux? Which Windows manager?
    What do you want to do with the Tab key? Please explain.

    Try this: Open Vivaldi Settings and try to reset Keyboard settings and the Disable Single Key Shortcuts.

    if you use such old version as 1.0.403.x you get security problems!
    Please update to Latest Snapshot.

    I cant confirm such key problems on my Debian 8.3 x64 KDE 4.14.2 and Unbuntu 14.04 x64 LTS.



  • @Gwen-Dragon:

    Do you use a special extra keyboard or the numpad?

    No

    @Gwen-Dragon:

    Which Linux?

    OpenSuse

    @Gwen-Dragon:

    Which Windows manager?

    XFCE

    @Gwen-Dragon:

    What do you want to do with the Tab key? Please explain.

    It does nothing, I want it to do something. The expected behaviour is to do the expected behaviour as stated on the preferences pages: to cycle through links and form controls and so on.

    @Gwen-Dragon:

    Try this: Open Vivaldi Settings and try to reset Keyboard settings and the Disable Single Key Shortcuts.

    Reinstalled 1.0.430. Tried that. TAB still does nothing (i.e. it does not cycle controls, it doesn not cycle links, it does not insert a TAB character, it does nothing you may think of) The TAB key it works on others apps and on 1.0403 (i.e., it cycles through controls, it it cycles through links, or it inserts TAB character) so the key itself is working fine

    @Gwen-Dragon:

    if you use such old version as 1.0.403.x you get security problems!
    Please update to Latest Snapshot.

    The latest does not work because it fails to support basic features.
    1.0.403 is the latest Beta, from early this month. Is it is a dangerous version?

    @Gwen-Dragon:

    I cant confirm such key problems on my […]

    With this second installation I also had no problem with the key "1" and "2" as before.


  • Moderator

    Try this:
    Vivaldi Settings
    Wepages
    Webpage Focus
    (*) Focus all Controls and Links



  • Thanks.
    But no effect, either.
    I tried just about every combination of preferences on the "keyboard" section but I probably would not try that one.

    While trying that I noticed a few places - while using / focused on the Vivaldi browser - where TAB (kind of) works

    Alt-TAB : works as expected, captured by the window manager to change windows (i.e. Vivaldi does not mess with it at that "higher" level)

    Ctr-TAB: works as expected (!), it changes tabs within the browser. That is the one only thing it does correctly that I've noticed.

    TAB: works while on the search field of the properties page. But it inserts a tab characher, while the expected behaviour would be to switch to the next control


  • Moderator

    Please: dont use old Beta 3; install Latest Snapshot from https://vivaldi.net/ ! Many bugs are fixed now.



  • I can not use a browser that lacks the most basic functionality… Quite simply it makes no sense. I got used to Vivaldi, so it is 'my' browser now, meaning I very much dislike the idea of changing again. I like my software to be stable, as possible.

    I will install the next versions (actually I think I have not yet tried the latest, so I'll do that soon). And I guess I'll file a bug report. And wait for a while. But... Not being able to see videos, or ear sound in a couple of places is not a huge problem, lack of basic keyboard is. So I have to stay with a working browser.

    Again, thank you.


  • Moderator

    Did you check your Vivaldi Settings -> Keyboard?
    You should select(!) [x] Disable single key shortcuts

    Dows this work?



  • Yes, I tried that.
    No, it made no difference (related to this TAB key issue)



  • Off-topic:

    @Gwen-Dragon:

    You should select(!) [x] Disable single key shortcuts

    Not the best interface, having to select to disable… I hope the devs switch that around some day.



  • @rkzn:

    Off-topic:

    @Gwen-Dragon:

    You should select(!) [x] Disable single key shortcuts

    Not the best interface, having to select to disable… I hope the devs switch that around some day.

    Thank You Gwen-Dragon,

    I have a post regarding keyboard issues where I mentioned this (in Linux).

    I also have had to disable the Ctrl+Shift+B (Bookmark Bar) as I cannot BCC someone in Google Mail with this enabled, even if that page has focus!


  • Moderator

    This option is always selected for a installation. If not, something may have happened with configuration (crash?) or in earlier Snapshots/betas while testing.

    I didn't have made the User Interface for the browser. But i think little improvements may be needed to make some Settings easier to understand.
    I hope after first Final (it has priority #1 at this time of development) such improvements will be done by developers.
    Please wait.

    Please, if you like send us a bugreport about the misunderstanding in Setting at our bugtracker https://vivaldi.com/bugreport/



  • Thanks Gwen-Dragon,

    Perhaps I will do that as one should expect the available shortcut keystrokes on a site to take precedence over browser shortcuts (as they do in other browsers.
    I believe all the Chromium based browsers have the same issue with possible misunderstandings. One group wants to be exacting in the language used while another wants the language to be understandable for non-technical users.
    Both have valid points but perhaps a meeting somewhere in between would be nice.

    Cheers



  • I also have XFCE (Xubuntu) and tab stopped working a few snapshots ago. Doesn't work in 1.0 stable either. I tried to change settings but no effect.



  • @greybeard:

    one should expect the available shortcut keystrokes on a site to take precedence over browser shortcuts (as they do in other browsers

    Not this one :-)
    I use the browser more often than any site (obviously, assuming I visit more than only one site), So I'd rather my browser options to take precedence. Or maybe an option to choose which… maybe even by site



  • @elektronicznypank:

    I also have XFCE (Xubuntu) and tab stopped working a few snapshots ago.

    Thank you. So it is not only me! :-)

    I note we share the use of XFCE window manager, but not the Linux dstribution (OpenSuse vs. Xubuntu)



  • Same thing here in 1.0 stable, TAB-key doesn't jump through fields in a form. Using Slackware / XFCE. This absolutely needs a fix. Worked fine in a snapshot from mid-March.



  • Hey everyone,

    The same problem occured here, I'm using Ubuntu with KDE Plasma, in any page, the tab key don't change of fields. i've tryed all configs in this post, but the problem persist.



  • Another bump.

    Vivaldi

    Vivaldi : 1.0.435.40 () (32-bit)
    Revision : 575538bc320e213510be1e66f3521382e615129d
    OS : Linux
    Blink : 537.36 (@0)
    JavaScript : V8 4.9.385.33
    Flash : (Disabled)
    User Agent : Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.110 Safari/537.36 Vivaldi/1.0.435.40
    Command Line : /usr/bin/vivaldi-stable –ppapi-flash-path --ppapi-flash-version --always-authorize-plugins --disable-translate --window-depth=24 --flag-switches-begin --flag-switches-end

    Fedora 22 : 4.4.6-200.fc22.i686

    XFCE

    Installed Packages
    Name : xfdesktop
    Arch : i686
    Epoch : 0
    Version : 4.12.3
    Release : 2.fc22
    Size : 3.1 M
    Repo : @System
    From repo : updates
    Summary : Desktop manager for the Xfce Desktop Environment
    URL : http://www.xfce.org/
    License : GPLv2+
    Description : This package includes a desktop manager for the Xfce Desktop Environment.

    Name : xfwm4
    Arch : i686
    Epoch : 0
    Version : 4.12.3
    Release : 1.fc22
    Size : 2.0 M
    Repo : @System
    Summary : Next generation window manager for Xfce
    URL : http://www.xfce.org/
    License : GPLv2+
    Description : xfwm4 is a window manager compatible with GNOME, GNOME2, KDE2, KDE3 and Xfce.



  • Same here with Mint Cinnamon.

    As a laptop user (mostly no mouse) I depend on the Tab key to be able to get from one input field to the next.

    Here's hoping the devs at Vivaldi can resolve this.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.