I cannot set Vivaldi as default Browser



  • Hi!! I'd like to set Vivaldi as default Browser. The settings is right, but if I click some link (ex. From thunderbird), vivaldi didn't open. I manual set Vivaldi as default (open the Default Application for link). This is the info get from about window: Vivaldi 1.0.420.4 (Developer Build) dev (64-bit) Revision 086206ef10bc3cef44adb9be6ed9c84d2783f3e8 OS Linux Blink 537.36 (@0) JavaScript V8 4.9.385.29 Flash (Disabled) User Agent Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.91 Safari/537.36 Vivaldi/1.0.420.4 Command Line /usr/bin/vivaldi-snapshot --user-data-dir=/home/mino/.config/vivaldi-snapshot --ppapi-flash-path --ppapi-flash-version --always-authorize-plugins --disable-translate --window-depth=24 --flag-switches-begin --flag-switches-end --enable-smooth-scrolling --enable-tab-audio-muting Executable Path /opt/vivaldi-snapshot/vivaldi-snapshot Profile Path /home/mino/.config/vivaldi-snapshot/Default Variations 16e0dd70-3f4a17df f19a86b5-55d854e7 918346b9-3f4a17df cf5ed6e1-3f4a17df 775ebbd7-3d47f4f4 f5dd6118-2f5721af 4ea303a6-3f4a17df 3d7e3f6a-2eb01455 dbffab5d-f51b51 c8b9b12d-d93a0620 867c4c68-3f4a17df



  • What are your Linux OS details? Have you also specifically told Linux that you want V as your default? I know that in Windows the auto-setting of the default sometimes seems to work better than in Linux. I adopted V as my daily default browser ~ a year ago, so can't recall exactly what hassles i had at the time – i can however remember vaguely some initial hassles. Anyway, in case it helps you to get it resolved in your Linux OS, here's some pics [Mint x64 17.3 KDE]:

    [attachment=2825]Selection_001_20160315_11:25:24.png[/attachment]

    [attachment=2826]Selection_001_20160315_11:25:41.png[/attachment]

    [attachment=2827]Selection_001_20160315_11:28:23.png[/attachment]

    [attachment=2828]Selection_001_20160315_11:28:03.png[/attachment]
    Attachments:
    ,,,



  • Thank for your answer!

    I solved setting the Default application for Web manually, see screenshot in attachment.

    [attachment=2834]Selection_188.png[/attachment]

    [attachment=2835]Selection_189.png[/attachment]

    But is useful can set the Default application for web when the Browser ask for it at Startup.

    [attachment=2836]Selection_190.png[/attachment]

    But If I clink on "Set as Default" nothing change
    Attachments:
    ,,



  • Yay, congratulations!

    Yes i agree with you about what should happen when ticking that Default box in V's Settings. I don't know if the fault lies with V or with Linux. However, last year i deduced that other way to do it, via the various settings in Linux [Mint KDE in my case]. I am glad it's now also working for you.



  • @ITA003:

    [attachment=2835]Selection_189.png[/attachment]

    I don't have Vivaldi listed in my drop down menu for browsers. I'm using the snapshot version if that makes a difference?



  • Look at the picture ist says Vivaldi (snapshot) ;)

    In my manjaro/xfce it is the same I set default browser in the system settings, but I do this füor many years I don't trust programs to do it correctly…



  • @RocknRolf:

    Look at the picture ist says Vivaldi (snapshot) ;)

    In my manjaro/xfce it is the same I set default browser in the system settings, but I do this füor many years I don't trust programs to do it correctly…

    Doh! :whistle:

    My settings menu doesn't have Vivaldi listed. Anyone have any idea why? I have it installed (in Ubuntu 16.04) using the PPA and it's at the latest version. :unsure:


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.