Passwörter aus Opera12.18 importieren klappt nicht



  • Hallo, ich benutze schon recht lange Opera, jetzt in der Version 12.18 Über die Jahre haben sich da natürlich sehr viele Lesezeichen und Passwörter angesammelt. Die Lesezeichen konnte ich problemlos importieren, aber die Passwörter wurden leider ignoriert, trotz Auswahl der Option. Ist das ein Fehler in dieser Betaversion 1.0.403.24 (Beta 3) (32-Bit)? Wird es in der Finalversion funktionieren? Ansonsten finde ich Vivaldi schon recht gelungen, aber um ihn richtig testen zu können benötige ich eben die Passwörter. MfG



  • Falls du früher ein Masterpasswort benutztest, musst du das in Opera 12 erst abschalten.
    Dann gehts.



  • Ich habe kein Masterpasswort gesetzt, das Feld ist blank, kann also daran nicht liegen.
    Attachments:



  • Beim Import der Paßwörter bei mir auch nur das: Anhang
    Und es läßt sich nicht abbrechen.
    Attachments:



  • Ich fage mal die Entwickler.
    Antwort:
    Es darf kein Masterpassword gesetzt sein
    Es muss ein existirendes Opera-12-Profil sein

    Bei mir klappt der Import in Vivaldi Beta 3.
    Ich habe mal nur Passwörter angehakt und dann über den Dateiordnerauswahl den Opera-12-Profilordner in der die operaprefs.ini liegt, gewählt.



  • So, kleine Korrektur.
    Wähle ich den profile-Ordner, importiert es ganz schnell.
    Aber, Menü-> Werkzeuge-> Privatsphäre sieht dann so aus: Anhang
    Attachments:



  • Habe es jetzt genau so probiert wie von Gwen-Dragon beschrieben, aber die Passwörter werden einfach nicht importiert. Habe den Vivaldi auch schon als Admin gestartet und Opera nach einem Systemneustart nicht gestartet, aber immer das gleiche Ergebnis -> meine Passwörter werden nicht importiert.

    Hat noch jemand eine Idee? Wäre echt schade sonst.



  • Bei dir sieht es genauso aus?
    Werden andere Sachen als Paßwörter importiert?
    Attachments:



  • @nokiafan
    das ist mit Sicherheit der Falsche Ordner den Du da ausgewählt hast.
    Versuch es mal mit "Opera Standardverzeichnis auslesen", damit wurden meine Notizen und Lesezeichen importiert, nur eben die Passwörter nicht.



  • Du mußt den Ordner auswählen wo die wand.dat gespeichert ist. Hat bei mir funktioniert. Nur muß ich die jetzt wieder alle löschen, oder die Login Data vom Backup wiederherstellen… .-)

    mf



  • @Mikefield:

    Du mußt den Ordner auswählen wo die wand.dat gespeichert ist. Hat bei mir funktioniert. Nur muß ich die jetzt wieder alle löschen, oder die Login Data vom Backup wiederherstellen… .-)

    mf

    das ist bei mir das Opera-Standverzeichnis -> C:\Users*****\AppData\Roaming\Opera\Opera



  • @nokiafan
    das ist mit Sicherheit der Falsche Ordner den Du da ausgewählt hast.

    Garantiert nicht, er importiert ja.
    Es ist nur das Layout zerstört. Einige URLs sind bei mir sehr, sehr lang.

    Richtig ist, es muß der profile-Ordner gewählt werden mit der darin enthaltenen wand.dat.

    Opera: Standard kann nur der wählen, der keine USB-Installation gewählt hat. Sonst wird die Checkbox nicht frei.



  • Korrekt, es muss ein existentes(!) Profil sein und ausgwählt wird der Ordner mit der wand.dat.

    Das Problem mit den zu langen URLs ist bekannt. Ich habe es nochmals im Bugtracker angesprochen.
    Das ist de Bug VB-13773 "Can't individually delete password for long URL"

    Musst du halt in der Zwischenzeit die URL chrome://settings/passwords/ nehmen, um die anzuschauen. Leider.



  • also bei mir befindet sich im Ordner "profile" keine Datei "wand.dat"



  • also bei mir befindet sich im Ordner "profile" keine Datei "wand.dat"

    Dann sieh mal zu, wo deine wand.dat ist. :)

    Logins in Opera gehen noch? Überprüfe das nochmal!



  • @nokiafan:

    also bei mir befindet sich im Ordner "profile" keine Datei "wand.dat"

    Dann sieh mal zu, wo deine wand.dat ist. :)

    Logins in Opera gehen noch? Überprüfe das nochmal!

    wie schon mal geschrieben befindet sich die Datei bei mir im Opera-Standartverzeichnis



  • Standard geht nur, wenn bei der Installation nicht-USB gewählt wird.



  • Bei mir funktioniert es auch nicht mit den Passwörtern. Es sind nach dem Import nur die vorhanden, die ich selbst in Vivaldi angelegt habe. Die ganzen Lesezeichen und Notizen sind aber da, den richtigen Ordner hat Vivaldi also erkannt.
    Den Ordner selbst auszuwählen bringt auch nichts, es kommt immer sofort die Meldung "Import fertiggestellt". Man sieht nicht einmal, dass Vivaldi versucht etwas zu importieren.

    Gibt es irgendwelche Sonderzeichen, die nicht kompatibel sind?



  • Möglicherweise sind Einträge in deiner wand.dat defekt?
    Wir haben da auch schon eine Bugmeldung, die wir noch überprüfen müssen. Bug: VB-14513 "Saved password data will not import from Opera 12.18"

    Oder zu groß? Wie groß ist die wand.dat?
    Oder ist das mit einem Masterpasswort geschützt?



  • Wie erkenne ich denn defekte Einträge? Mit dem Tool "OperaPassView" werden mir 676 Einträge angezeigt, die Datei ist 423 KB groß.
    Ein Masterpasswort zu setzen und wieder zu löschen habe ich schon versucht, brachte aber keinen Erfolg.

    Gibt es die Möglichkeit Vivaldi mit ner Konsole oder so zu starten, wo der mir dann genau jede kleine Aktion des Browsers anzeigt?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.