I can't pin Vivaldi to my Docky



  • I'm using Fedora 23 with a Docky and I can't pin Vivaldi to it. Does anyone else have this problem? How do I fix it?


  • Moderator

    Is this a new children's blindfold party game? Pin the Vivaldi on the Docky?



  • Have you tried adding this line to Vivaldi's .desktop launcher?

    StartupWMClass=vivaldi-preview
    

    I have Ubuntu and the file name is /usr/share/applications/vivaldi-beta.desktop

    You will have something like this:

    [Desktop Entry]
    Version=1.0
    Name=Vivaldi (beta)
    StartupWMClass=vivaldi-preview
    
    

    You will need root or sudo privileges. Let me know if that helps.



  • Start Vivaldi. Then you see it in docky. right click make a starter. go to docky settings to vivaldi entry. extra settings and snap it and pick the vivaldi browser.



  • If I open Vivaldi from the menu it's icon will appear on Docky but I cannot pin Vivaldi to it. If I open Vivaldi from the desktop shortcut the icon doesn't show on Docky and Vivaldi will be on the same icon as my file manager.
    Attachments:



  • In my case I ran Vivaldi from launcher then on a command line I typed this

    xprop | grep CLASS
    

    and hit enter. Then clicked on Vivaldi window

    The output was

    WM_CLASS(STRING) = "vivaldi-preview"
    

    This is the value I added to StartupWMClass field on Vivaldi's launcher file (.desktop)

    [Desktop Entry]
    Version=1.0
    Name=Vivaldi (beta)
    StartupWMClass=vivaldi-preview
    
    

    Go into your home folder with a file browser, press Ctrl H, open the .cache folder, then the docky folder and delete the cache file inside. Reboot your PC.

    The problem is application's launcher filename and exec value don't match

    Other solutions:
    [ul]



  • I seem to find Docky confusing & contradictory, compared to my default Cairo-Dock. However, to your question, this worked for me:
    Start Vivaldi. Then you see it appear in Docky. Right click on this new V icon in Docky & select "Pin to Dock". If you later wish to remove it, unintuitively you cannot simply reverse those steps, as right-clicking on an already-pinned pgm does not produce a useful context menu for that [stupid design!]. Instead, simply left click on the target icon & drag it off the dock.



  • @Steffie:

    Then you see it appear in Docky. Right click on this new V icon in Docky & select "Pin to Dock".

    I know how to use Docky. Unlike my other applications I cannot pin Vivaldi to it, the option doesn't appear.



  • @efelix:

    Have you tried adding this line to Vivaldi's .desktop launcher?

    StartupWMClass=vivaldi-preview
    

    I have Ubuntu and the file name is /usr/share/applications/vivaldi-beta.desktop

    You will have something like this:

    [Desktop Entry]
    Version=1.0
    Name=Vivaldi (beta)
    StartupWMClass=vivaldi-preview
    
    

    You will need root or sudo privileges. Let me know if that helps.

    thanks for the tip.

    works with plank on debian as well. without any need to restart vivaldi or the computer.



  • Just remember to edit Vivaldi's .desktop launcher again after you upgrade Vivaldi. You will lose changes.

    Here's a command to do it easily:

    sudo sed -i '/^[/a StartupWMClass=vivaldi-preview' /usr/share/applications/vivaldi-beta.desktop[/code]
    

Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.