Prompt for Keyring Password When Opening Facebook or Fastmail



  • This issue has been discussed here before but I didn't find a way to stop the box from popping up the first time I open Facebook or Fastmail after opening Vivaldi [don't know if this popup appears with other email services because this is the only one I use]. The box says "Enter password for keyring 'default keyring' to unlock. An application wants access to the 'default keyring' but it is locked" plus there's a space for my password. I can dismiss the box merely by pressing the "Escape" key & can still log in to either Facebook or my email account with no problems. I saw that I could remove the keyring password by opening the terminal & typing ~/.local/share/keyrings/* however I always get this result: "bash: /home/dave/.local/share/keyrings/default: Permission denied" [without quotes in this instance] & could go no further. Any ideas about what I can do to disable this annoying popup or will that get fixed in the final/stable version of Vivaldi? I've never had this problem with other browsers. Thanks & regards!


  • Moderator

    the user keyring manager window should only appear one time.
    For me that works fine with kwallet.



  • I don't use kwallet &, from searching the contents of my OS [Linux Mint 17.2 Mate] installation, it's not there & I don't know anything about it This hasn't been an issue with Opera so I would hope it won't be with the stable versions of Vivaldi. Since I can get rid of this popup by merely pressing "Escape" it's not too important but I hope this gets addressed in the future.


  • Moderator

    Please report your problem as a bug, describe explicitly with information about OS and Window Manager for a bugreport at https://vivaldi.com/bugreport/



  • I discovered that my keyring password issue seems to be a Linux/Mint issue after I upgraded to Opera's latest [but not greatest] version & began getting the same box when visiting password-protected sites there, too. I visited Linux-Mint's help forums & they had a couple of fixes. One was to try some commands they had for Chrome or Chromium browsers in the Terminal but neither were recognized. Another was to go to Menu>Preferences>Passwords & Keys & disable it there but for some reason "Passwords & Keys" isn't there. Possibly that got corrupted but everything else works fine. However, I tried once more to select "Continue" from the "Keyring Password" box without entering any password & this time it allowed me to, although with a warning that this wouldn't be as secure which I already knew. I'm certain that I tried this several months ago & it wouldn't allow me to continue without entering a valid password which I didn't have but I was able work around it by hitting the Esc key whenever this box appeared. Now, however, I can access password-protected sites without seeing the keyring password box so this issue appears to be resolved. Hope this is helpful if you get more complaints about this issue. Regards!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.