Address bar behavior - "generic" search, search shortcuts and local hostnames



  • Hi, I'm at a bit of a loss how to address this. I don't think this is a bug, but it differs excruciatingly from Opera up to 12 (which I had been using for more than 15 years, so... old habits ;) ) Most of us are used to just typing a web address without the http:// prefix - Vivaldi handles this just fine. Maybe some of us are actively using local ( = not fully qualified host names, for example "http://localserver" - or in short form just "localserver") host names. Now, Opera could be configured to try local host names first - and if local hostnames didn't resolve, go to "general search in address bar". Vivaldi, on the other hand, doesn't - it just jumps to "search from address bar". (btw, is this a Google problem? Android has similar problems with local host names) So, I have to explicitly type "http://localhostname" everytime I want to open a local URL (which is often). If I go and "disable search in address bar", this doesn't happen anymore - but then also the search shortcuts are disabled. So this should maybe be a feature request: best way: add "check local host names first" option alternatively: add "disable search in address bar, but allow search shortcuts" Any opinions on this? Regards Sebastian



  • I strongly support a decent behavior - before sending data off to some search engine, any browser should make sure this string is not a valid server name, e.g. on the local network.

    I found a hint on chrome which has the same (IMO stupid) behavior: Type a trailing slash / after the hostname. It works in vivaldi, too.



  • The hostname issue is known. No fix yet.



  • Only works if you include the protocol, though - which kind of remedies the effort :D

    IMHO gold standard solution: be able to disable search from address bar completely, except if explicitly "ordered" with configured search engine shortcut, e.g. "g www" to search 'www' with google.com or whatever. Sadly, the corresponding option also disables search engine shortcuts :-(

    This might make most of the problem without actually solving the underlying "hostname resolution" problem which I suppose is imported from chromium…


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.