Ability to delete URL autocomplete suggestions



  • Chrome does this - use SHIFT+DELETE (not backspace) to delete a record that shows up in your auto-complete and stop it from returning. Can we port this over to Vivaldi please?


  • Moderator

    When you hover over a link in the list, an x icon appears on the right. Use that to delete the entry from the list.



  • This does not fix the issue, it only allows one to delete History from the autocomplete list, not actually remove erroneous auto correcting.

    How to Recreate:

    1. Type in a broken / erroneous link to a real site (such as "nytimes.com/broken") without quotes
    2. Let the page load a 404 error
    3. Now, in a new tab, type a partial URL such as "nyt"
    4. Confirm the erroneous url continues to autocomplete despite it being literally broken [ http://i.imgur.com/ggtZmPC.png ]
    5. Confirm that there are no "x"'s, or history objects to remove
    6. Confirm that Ctrl+Delete does not remove the literally broken autocomplete
    7. Confirm that you are entirely incapable of removing broken autocompletes and will ALWAYS land on the now broken page anytime you ever attempt to go to nytimes.com nyt nytimes nytimes.com/ or any other url and no matter what you do except for explicitly deleting the un-requested and literally broken suggestion, the broken autocomplete takes over your url and lands you on the wrong page 10 out of 10 times

    WORKAROUND: Don't trust the system, re-read every URL, expect it to append broken and useless information to your URL that will break your browsing. Just because you typed it doesn't mean Vivaldi is going there, so expect Vivaldi to break your urls frequently, read carefully, and make sure to hand-delete any broken additions to the url

    Expected Result:

    When I hit ctrl+del on an incomplete url that has an autocorrect attempting to finish it, I expect that autocorrect record to be completely and irreversibly removed so that I will never ever get that autocorrect ever again unless I add it again.

    Chrome:
    Chrome 50.x correctly interprets the ctrl+del command and removes all reference to the autocorrect suggestion so that it stops appearing



  • This won't work on "Typed" category. So also +1 for this option.



  • As of release 1.2.485.14 (Developer Build) (64-bit) we can now delete typed entries with "X':
    Added X to delete typed history directly from URL dropdown

    Thank you!

    It would be nice to have also keyboard shortcut for this function as suggested though.


  • Moderator

    The keyboard shortcut (already as a feature wish in bugtracker) will come as Vivaldi is a browser for keyboard users, too!



  • @gwen-dragon Grüß Frau Drachen! Does anyone know if we now have a keyboard option for deleting the currently selected auto-complete suggestion? I think in Firefox it was Alt + Delete (in Windows at least). @stealth789 @Pesala
    -Eric



  • @ehm shift-del



  • @ian-coog Tried that per @5eagull's post at top, but to no effect.

    Eric, Vivaldi 1.13 64-bit on Windows 10 64-bit

  • Moderator

    @ian-coog No, Shift+Del works only for typed entries.



  • I have this issue after migrating from Opera to Vivaldi.
    In Opera I use a lot of 2 letter shorthands for local newspapers.
    I type vg and hit enter, to get vg.no
    I type db and hit enter to get db.no
    it and enter, for itavisen.no
    and so on.

    After installing vivaldi, and importing all my bookmarks and history from Opera, typing db autocompletes on an address I have only used once.
    It takes me to db.no's dbtv.no/url_for_some_video_they_had
    I have tried deleting my entire history, and I have clicked the x, to remove it from typed history, but as soon as I type db, the autocomplete takes over.

    same thing with images.google.com.
    I do a lot of reverse image lookups, and I was always able to just type image, in opera, to get autocomplete to image.google.com
    Now it somehow autocompletes to imageshack.us, a website I have not visited for many many years.
    I didn't even know it was still in my Opera history, and I can not remove the autocomplete.

    This must be fixed.

    Just before hitting submit, I decided to try and clear all private history for all time, and I still get the same autocomplete.
    I then decided to search my bookmarks, and it turns out that I had a bookmark hidden away in some forgotten subfolder, and because of this, it autocompleted.
    I then deleted the bookmark. It still autocompleted, while the bookmark was in the trash. Deleted form trash, and now the autocomplete found a different bookmark to autocomplete to, from the same dbtv.no domain.

    I have now deleted all bookmarks from dbtv that I could find, and also all imageshack bookmarks that I never use anyway, and there is no autocomplete at this moment.

    So it seems the fix for this might be to delete the bookmark it autocompletes to.



  • @popupkiller
    Hi, may you have "Always Prefer Bookmarks" in the vivaldi://settings/addressbar/ setting.
    Cant remember if it is default in Vivaldi.
    If I type goo I get google.de

    Cheers, mib



  • @mib2berlin yup. You are right. I did have that enabled.
    I don't know if it's standard either. I might have activating it, now knowing what it actually did.
    Thanks for the tip.



  • @popupkiller
    an underrated feature is the nickname for a bookmark. Assign a nickname to a bookmark and you will get to the desired address just as quickly as type the first characters. Especially good for URLs which contain not only the domainname (like a youtube video for example)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.