src="https://update.vivaldi.com/stats/piwik.php?idsite=1&rec=1&bots=1" style="border:0;" alt=""

Bug: Vivaldi Not Playing Well With KDE Activities



  • I'm having trouble with Vivaldi in KDE Plasma 5.4.2. I have three activities or workspaces, depending on your preferred nomenclature. When I switch activities, everything works correctly. All the open windows associated with that activity pop up and windows associated with other activities go away. It seems that Vivaldi is not playing well with activities. When I open Vivaldi, it stays on all activities. This defeats the purpose of using activities. I've attached screenshots of my activities. As you can see the same instance of Vivaldi is persistent across all activities. [attachment=2237]ws1.png[/attachment] [attachment=2238]ws2.png[/attachment] [attachment=2239]ws3.png[/attachment] Attachments: [img]https://forum.vivaldi.net/uploads/attachments/71895/ws1.png[/img],[img]https://forum.vivaldi.net/uploads/attachments/71895/ws2.png[/img],[img]https://forum.vivaldi.net/uploads/attachments/71895/ws3.png[/img]



  • I forgot to mention that Vivaldi plays well with other desktop environments that I have tested. KDE is the only desktop environment that has this problem.



  • Plasma 5 is a little bit buggy at the moment. Which distro you use?



  • I'm currently using Kubuntu 15.10 with the 4.2.0-22 kernel.



  • FWIW, it works nicely for me with KDE activities using Kubuntu 14.04, provided that "System window manager" is ticked in the Vivaldi settings. (The setting is called "Systemets fönster" in Swedish, it's under settings/appearance.)



  • That fixed it! Thanks so much.

    Here's the setting that fixed this issue. For those who are struggling with this.

    [attachment=2251]window_manager1.png.png[/attachment]
    Attachments:



  • I've noticed this issue (with activities) with other apps, before I used vivaldi, I circumvented it within KDE itself, using 'window behaviour" settings….

    Since I have kde 4 still on this computer, it even happen(s) on kde4.

    So I used KDE's window behaviour option, and forced the app to only be on activity I wanted.

    Just so as you know there is a way to 'force' it on other apps that also do this (like virtual box seamless puts the window on both activities... )

    systemsettings -> window behaviour -> window rules -> (new) -> size and position -> activity -> FORCE -> "desktop name of your activity"

    in the 'window matching' I used the 'detect window properties' and clicked my browser and/or virtual box window that was already loaded into an OS, so when I save those settings, my vbox, in 'seamless' stayed on my alternate desktop activity.

    addendum:

    the same principle / location / settings for plasma desktop as well... its the same.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.