Why does Vivaldi connect to these IPs on startup?



  • I'm concerned about privacy here, especially since Vivaldi is based on Chrome. That said, why does Vivaldi connects to the follow IPs (two of which are Google's, one of which is a datacenter in Germany) on startup and keeps up the connection seemingly indefinitely? 216.58.209.131 82.221.99.163 173.194.40.238



  • Interesting question. I did some research about it.

    Chrome does the same.
    They have DNS names like *.1e100.net
    The Google FAQ says about it:

    What is 1e100.net?

    1e100.net is a Google-owned domain name used to identify the servers in our network.

    Following standard industry practice, we make sure each IP address has a corresponding hostname. In October 2009, we started using a single domain name to identify our servers across all Google products, rather than use different product domains such as youtube.com, blogger.com, and google.com. We did this for two reasons: first, to keep things simpler, and second, to proactively improve security by protecting against potential threats such as cross-site scripting attacks.

    Most typical Internet users will never see 1e100.net, but we picked a Googley name for it just in case (1e100 is scientific notation for 1 googol).

    Furthermore this question was asked on superuser.com. And the answer was:

    It's Google Safebrowsing feature in Chrome.

    That feature checking sites and tell you if that site is "Attack Site"

    sinni800: @MicTech, Google has all it's search servers under the 1e100 domain. I know this is kind of late but w/e. It does not ONLY relate to google safe browsing.

    So… maybe Google knows where you are surfing with Vivaldi :)



  • In the past ive tried out Chrome as well and blocked this IP addresses in Windows Firewall years ago…



  • It's the Google Phishing and Malware protection feature, aka Safe Browsing. It can be turned off in privacy settings.



  • @steinar:

    It's the Google Phishing and Malware protection feature, aka Safe Browsing. It can be turned off in privacy settings.

    Indeed that fixed it. What about the 82.221.99.163 Germany server address?



  • That last one is our Auto-Update server. It's in Iceland, not Germany.



  • @johnsmith1:

    @steinar:

    It's the Google Phishing and Malware protection feature, aka Safe Browsing. It can be turned off in privacy settings.

    Indeed that fixed it. What about the 82.221.99.163 Germany server address?

    That's the Thor data center in Iceland, not Germany.

    Likely is used for autopdate.

    Edit:

    Oops

    Steinar was faster than me. ;)



  • And a last bit:

    When I enter any webpage, this IP pops up: 68.232.35.121

    I'm not in the US, the websites do not have Google Analytics, they are on different hostings and do not use CDN systems.


  • Moderator

    That is Icelandic; Thor Data Center IP.
    May be it is Vivaldi for anonymous browser statistics.



  • @Gwen-Dragon:

    May be it is Vivaldi for anonymous browser statistics.

    All available privacy settings are cranked up. I do not agree with sending any information to anybody about my browsing, supposedly anonymous or not.


  • Moderator

    The statistic is NOT about your browsing, it may collect used settings, activated JS or plugins, etc.

    Perhaps the IP is the Vivaldi CDN for Vivaldi's autoupdate.



  • @Gwen-Dragon:

    Then it may be the Vivaldi CDN for Vivaldi's autoupdate.

    Why would a connection open up every time I go to any website? That doesn't make sense.


  • Moderator

    With Wireshark/tcpdump i cant find with a connect to 68.232.35.121 with Vivaldi 1.0.321.3 Beta and other snapshots



  • It is funny that for several years everything worked well, just 1 hour after i wrote on this forums that i blocked those 3 IP addresses, i cannot connect from my home IP (from which i wrote that reply) and i get this message when trying to enter forums

    You have been blocked from accessing this site because your IP address (...) appears in a spam blacklist database

    Please see this link for details and instructions on how to remove yourself from this list.

    The link goes to spamrats.com

    Seriously Vivaldi?!? :-O


  • Moderator

    Correlation is not causation.



  • @Gwen-Dragon:

    With Wireshark/tcpdump i cant find with a connect to 68.232.35.121 with Vivaldi 1.0.321.3 Beta and other snapshots

    Weird, I use tcpview and can see it popping up every time I enter sites. Double-checked my settings before testing again to make sure that every tracky-ish thing is turned off.



  • @Aikimaniac:

    It is funny that for several years everything worked well, just 1 hour after i wrote on this forums that i blocked those 3 IP addresses, i cannot connect from my home IP (from which i wrote that reply) and i get this message when trying to enter forums

    You have been blocked from accessing this site because your IP address (...) appears in a spam blacklist database

    Please see this link for details and instructions on how to remove yourself from this list.

    The link goes to spamrats.com

    Seriously Vivaldi?!? :-O

    Google is onto you!! Haha.

    You should look for a cause for that, there must be some. I was going to list possibilities, but I realized that it'd derail the topic. Besides, people who are brace enough to try Vivaldi should be quite techy.



  • Contacted my ISP and it works now. There was probably some mail spam from some IP address from my range….it looked to me like very weird coincidence... it was really just correlation :) i apologize for false accusation :)


  • Moderator

    The IP seems to be contacted for Gravatars
    See the relation graph at https://www.robtex.net/en/advisory/ip/68/232/35/121



  • @Gwen-Dragon:

    The IP seems to be contacted for Gravatars
    See the relation graph at https://www.robtex.net/en/advisory/ip/68/232/35/121

    Strange coincidence, but good to know, now. Great site too, I'm bookmarking it. Thanks for the site.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.