Can't use backspace when entering text



  • When entering text on a forum or similiar, pressing backspace to remove text will make the browser go back to previous page. 1.0.321.3 (Beta)



  • Can confirm that this happens on IP.Board. Very annoying.



  • On Windows 10 with Vivaldi 1.0.321.3 (Beta) (64-bit) I can't confirm this. In the text field of this forum for instance the backspace key is working as expected, even if I enable 'Single Key Shortcuts' in the settings.



  • good word-processing habits begin with attacking it from the other side with the delete and insert keys. ?
    simplicity is nice but sometimes gets in the way of sophistication. always an easy workaround to be found. delete button. for when you find this happening.



  • back with a more sympathetic tone. I just got off a DellVenue8Pro; touchscreen keyboard. there is no insert or delete key evident on that screen keyboard thingie. ! ugh! many times i have encountered web pages that will not abide special keyboard navigation like the backspace key, or mouse click to cut and paste, missing keyboard cut and paste, missing highlighting, and the fundamental basics of insert and delete always work. NOW there is no fundamental keys on the keyboard? what kind of tools are we giving to the world?! ridiculous. guess the software guys really DO need to fix the input box to meet the needs of the depleted hardware. pathetic. Dracoster and Daring and silly touchscreen me will be showing strikethrough and typos until it behaves. I feel silly contemplating the need to search for a keyboard shortcut that will do what the missing keyboard shortcut usually accomplished!



  • Insert doesn't do much on most keyboards - by itself. On some forms, it will toggle overwrite mode … if the page supports it. Shift-Insert is another matter.

    Android keyboards lack arrow keys and the touchscreen may not be very exact, and I can't get some WYSIWYG forums to even display the keyboard. Never used a touchscreen Windows device, but if Android is any example...



  • This has been a bug for a long time which I worked around by disabling backspace as a shortcut, it's back though but I have single key shortcuts disabled and I have no shortcuts set for going back. Despite that it's definitely still using backspace to go back a page, is there somewhere else I need to go to disable it? It's annoying not being able to use backspace to go back a page but much more annoying to have it keep jumping out of pages when pressing backspace.



  • This is such a frustrating bug, I don't understand how it can have existed for so long (still happening in 1.0.344.37) and that there's not more complaints about it as it makes certain forum types completely unusable particularly combined with this newer bug that for some reason setting single key shortcuts to disabled doesn't actually disable them. Unless there's a work around I'm not aware of? I keep having to switch browsers to use forums because in Vivaldi each time I press backspace to correct text, it jumps back a page even though that shortcut is disabled.

    Edit - I guess single key shortcuts doesn't work the way it sounds, after digging through the shortcuts I found backspace was still defined and now with it removed it stops it going back pages.


  • Moderator

    @JohnMcL7:

    This is such a frustrating bug, I don't understand how it can have existed for so long (still happening in 1.0.344.37) and that there's not more complaints about it as it makes certain forum types completely unusable particularly combined with this newer bug that for some reason setting single key shortcuts to disabled doesn't actually disable them. Unless there's a work around I'm not aware of? I keep having to switch browsers to use forums because in Vivaldi each time I press backspace to correct text, it jumps back a page even though that shortcut is disabled.

    Edit - I guess single key shortcuts doesn't work the way it sounds, after digging through the shortcuts I found backspace was still defined and now with it removed it stops it going back pages.

    Try the newest snapshot (1.0.390.3) at https://vivaldi.net/

    I think you will find many fixes and new features.



  • I am also having this issue, in particular that Backspace when in a text box takes you back a page. My work around has been to remove that shortcut. Still not sure what the "disable single key shortcuts" is supposed to do, it doesn't do anything.

    I've tried in Snapshot version 1.0.422.8 and 1.0.425.3 with the same results



  • Yep, backspace strikes back. :P

    Opensuse Tumblweed x86_64
    CPU Intel T4200
    GPU Intel GN 965
    Vivaldi 1.0.425.3

    Cheers, mib



  • Problem is minor given (since a while) you can remove the Backspace key from the back function.

    Anyway, personally I never faced bug's return on windows, but now I'm seeing it happen on (Arch) Linux.



  • Strange issue. I cant reproduce this on Linux Debian 8x64 KDE 4.14
    Because this happens not on normal textfields/areas.

    Is this the Backspace key in regular keyboard or in numeric keyboard?
    Can you give us a page where that happens (and we dont need a login) or a demopage?



  • To add further information. Yes, I'm on Linux, Ubuntu 14.04

    This occurs in Gmail text fields (i.e. Composing an email). I'll keep an eye out for other locations, as it doesn't appear to happen in the Vivaldi forum, which is a normal text field. (Although for now, I've removed the shortcuts that are causing issues)

    I've noticed that Ctrl + Z also causes issues.

    Yes, you can remove these shortcuts, so it's a minor issue. However, the bigger issue is that these shortcuts shouldn't be detected while in a text entry field. There are plenty of people who will get confused as to why when they compose an email, and hit backspace, that they lose everything and it goes back a page. Or press Ctrl + Z and another tab opens up.

    I'm not sure if it's related, but I get a double paste issue as well in text fields, pasting pastes the clipboard twice. Potentially Vivaldi seeing the keyboard shortcut and executing a paste, as well as the textfield executing a paste.



  • I know there was a reported bug for some users with GMail and Backspace. But i cant check if it is fixed now.
    Problems with double paste should have been fixed as i see in bugtracker.

    Please, did you already have updated to latest version 1.0.429.5 and tested the problem?



  • Is there anything new on this topic?

    I have had this problem when editing text in edit fields that backspace was navigating back in history for a while on windows. Now I've switched to linux mint, I run Vivaldi 1.4.589.38, and I again sometimes see this bug. I have so far only seen this happening editing text in our company's Confluence Wiki, so I can't share a link.

    The workaround "no backspace keyboard shortcut" is silly, as I like to use it for navigation.



  • And there I was thinking I was imagining things it has happened to me couple of times, 1.4 release OSX 10.11.6.



  • @RRR13 said in Can't use backspace when entering text:

    @WildEnte @MacUser2525 Are you guys sure you are not losing focus of the edit box temporarily or some crap like this? Maybe the website is doing some magic moves in the background?

    No clue what website was doing I however was typing in box like I am now hit backspace to correct typo page jumps back simple as that. So if page is doing anything foolish while doing that then that is what happened but I fail to see how, no matter I have disabled/changed that shortcut to only the command back arrow that was already there. Which again I fail to see why it does not use the standard back keys for a Mac the Command + [ in that spot for it which works in every application including this one.



  • @RRR13 said in Can't use backspace when entering text:

    @WildEnte @MacUser2525 Are you guys sure you are not losing focus of the edit box temporarily or some crap like this? Maybe the website is doing some magic moves in the background?

    I am absolutely certain that all I'm doing is typing. It only happens in Vivaldi, and it doesn't happen in my Vivaldi installation at work ever since I turned off the keyboard shortcut. Now, the editor of Confluence is a rather sophisticated one, so I can't be certain it's not doing something funky in background. E.g., Confluence has @mention commands (like this forum), and automatically converts links that I type to pages (and such). So maybe maybe editing mode is interrupted every now and then to do some autoconverting, and while it's in this state Vivaldi thinks it's not in edit mode and thus treats my back keystroke as a command.

    Sometimes the back gesture is also triggered when I use ctrl+left cursor (to jump back entire words).

    In my book, this is clearly Vivaldi catching keystrokes as commands even though I am working in an edit field. Maybe all that's required is Vivaldi adding a timeout once I leave the edit field?



  • @WildEnte said in Can't use backspace when entering text:

    In my book, this is clearly Vivaldi catching keystrokes as commands even though I am working in an edit field. Maybe all that's required is Vivaldi adding a timeout once I leave the edit field?

    There is no doubting that is happening I turned on the single key shortcuts so I could have the / for search in page first time I used it in post like I did now instead of it just showing up typed I got search box as well. Then I used a 9 in the same text box a zoom out occurred as that is the shortcut for it. This program does not respect a text box typing taking precedence over the shortcut being executed it does both actions. Be nice if that search box had timeout on it as well so you did not have to kill it off manually. I do like the count of items it finds and the way you can cycle through them, should disappear once no activity is happening though.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.