[SOLVED] Severe full screen flickering



  • [UPD] Solution: https://forum.vivaldi.net/post/397779

    Hi!

    Vivaldi would flicker in full screen. Happens both to videos and pages.

    The flickering is extremely severe, making the browser unusable and painfully uncofortable.

    I've found a couple of threads from 2017 and 2018, but it's 2020 so I've decided to post a fresh one.

    Halp!

    Windows 10 Pro 64-bit build 18363
    AMD Ryzen 2700X
    NVIDIA GeForce 1070 Ti
    64 GB RAM

    PS No other app or activity suffers from this on my computer.



  • I have found the second app that also suffers from the flickering issue: Visual Studio Code, whose GUI is also built with web technologies. Here's the ticket: https://github.com/microsoft/vscode/issues/64383

    Their common solution is to disable GPU acceleration. This is fine for an IDE, but in Vivaldi it causes a severe FPS drop on Netflix, so it's not acceptable.

    Luckily, the VS Code community have identified the culprit: it's V-Sync set to Fast mode.

    My explanation for what is V-Sync and what is Fast mode:

    V-Sync is a technology to prevent screen tearing which happens when GPU FPS does not match monitor FPS: the monitor displays one frame in the top half of the screen and the next frame in the bottom half. V-Sync reduces GPU FPS to be a multiple of monitor FPS (or a multiplier your GPU FPS is higher).
    .
    The true solution to the tearing problem is adjusting the monitor FPS dynamically to match the GPU FPS. Such technology is called FreeSync and G-Sync and requires special hardware inside the monitor.
    .
    "Fast" mode of V-Sync is a know-how of NVIDIA to get rid of tearing with a regular moninor and without sacrificing performance: Fast is only one frame slower than FreeSync/G-Sync. For comparison, regular V-Sync reduces the framerate by 2× or 4× when GPU FPS is lower than monitor FPS (e. g. for a 60 FPS monitor, V-Sync fixes the FPS at 60, 30 or 15, depending on how much your GPU can guarantee). Fast mode is such a simple concept, that I find it ridiculous for it to be novel. V-Sync should've been Fast in the first place, and the 50% FPS drop should've never existed.

    Adding Vivaldi to exceptions and disabling V-Sync has resolved the flickering issue but caused heavy screen tearing when watching Netflix. The solution is to set V-Sync to On (regular mode), which is fine because 99% of video content is at 24 or 30 FPS.

    88f4ac25-45cb-453c-a331-49987e45d510-image.png

    de41ee3e-6903-44b4-8e26-2c7b845ba882-image.png


    PS

    0fb4fe98-efe5-4bec-848d-3876185ba183-image.png


  • Moderator

    @lolmaus said in Severe full screen flickering:

    Windows 10 Pro 64-bit build 18363

    Oh, a older Windows 10 version.

    NVIDIA GeForce 1070 Ti

    Do you have the latest or a beta driver from NVidia downlaod page?


  • Ambassador

    @lolmaus I see this from time to time, usually after waking up the computer from sleep.

    To fix it, I go into Display settings, change the monitor resolution, then click on Revert to cancel the change, and the flickering stops.

    Revert Display Resolution Settings.png



  • @Gwen-Dragon said in Severe full screen flickering:

    Oh, a older Windows 10 version.

    Thanks for pointing this out. I haven't skipped a single update, always installing them eagerly.

    But Windows Update was silent about this particular one. I saw it only now when I openend Windows Update manually. Clicked Download and Install, we'll see.


    @Gwen-Dragon said in Severe full screen flickering:

    Do you have the latest or a beta driver from NVidia downlaod page?

    Using latest stable drivers from GeForce Experience. The flickering issue has survived through a number of video driver updates.



  • @Pesala said in Severe full screen flickering:

    I see this from time to time, usually after waking up the computer from sleep.
    To fix it, I go into Display settings, change the monitor resolution, then click on Revert to cancel the change, and the flickering stops.

    I rarely put my PC to sleep, but I shut down the power on my monitors (using a button on the power cord extender, i. e. not standby).

    Thank you for your workaround suggestion, but I definitely do not want to be doing this every morning.



  • @Gwen-Dragon said in Severe full screen flickering:

    Oh, a older Windows 10 version.

    I have updated to latest version: 10.0.19041 Build 19041.

    The issue persists.


  • Moderator

    @lolmaus What happens if you open Vivaldi Settings > Webpages , disable "Use of Hardware Acceleration" and restart Vivaldi?



  • @Gwen-Dragon said in Severe full screen flickering:

    @lolmaus What happens if you open Vivaldi Settings > Webpages , disable "Use of Hardware Acceleration" and restart Vivaldi?

    This seems to resolve the issue, but causes a drastic FPS drop on Netflix, so I can't keep is off either.

    Another thing I've noticed that it only happens on my primary display which is a 4K TV connected via HDMI. Secondary displays are PC monitors connected with DVI and they are fine.

    This flickering issue does not happen to me in any other app or game.


  • Moderator

    @lolmaus I only wanted to know if disabling HWA would reduce flicker. OK, now we know.

    Please visit the following links and tell which options are set for the flags:

    • vivaldi://flags/#ignore-gpu-blacklist
    • vivaldi://flags/#disable-accelerated-video-decode

    Sometimes enabling the flag ignore-gpu-blacklist could help.


  • Moderator

    @lolmaus If enabling one/both of these flows doeds not help, pleae report a bug to Vivaldi.

    When reporting a media issue, in addition to describing what is happening and where, we need more information to be able to follow up with it.
    Please visit the following pages:

    GPU: vivaldi://gpu
    Media: vivaldi://media-internals
    On both pages, click on Copy to Clipboard and paste the content to the bug report.

    Furthermore, please visit the following links and tell us which options are selected for the selected flags:

    vivaldi://flags/#ignore-gpu-blacklist
    vivaldi://flags/#disable-accelerated-video-decode
    Please copy and paste all this information on vivaldi.com/bugreport



  • @Gwen-Dragon, here are the reports: https://gist.github.com/lolmaus/f3c37082e9978357628e38cbce11da76

    GPU blacklist was disabled, enabling it and restarting didn't help.
    Hardware acceleration for video decoding and encoding is enabled, I would like to keep it enabled.



  • Submitted a bug report.

    @Gwen-Dragon, thx for your help. 🙇♂


  • Moderator

    @lolmaus Thanks. Which bug number got it?



  • VB-71118.



  • @Gwen-Dragon, I no longer experience the issue!

    I don't know why. It was flickering for me yesterday when I tried it after updating Windows.

    And I haven't changed anything since. I haven't even rebooted. So maybe it was the Windows update that did the trick.

    Anyway, thank you for your kind help. 🙏


  • Moderator

    @lolmaus said in Severe full screen flickering:

    I no longer experience the issue!

    What a luck 🙂

    So maybe it was the Windows update that did the trick.

    Could be. Sometimes Windows 10 acts strange after updates.
    Next time ⚠ after you saved all your work and closed all your programs you should run this:

    • Win+R
    • Type in command field this
      shutdown /t 0 /g
    • Hit Return key
    • Now Windows reboots immediately and re-reads all settings

    Anyway, thank you for your kind help.

    You are welcome.


  • Moderator

    @lolmaus said in Severe full screen flickering:

    VB-71118.

    I gonna close the Bug now.



  • @Gwen-Dragon Flickering is back. Not as severe and frequent as reported, but it happens.

    I have not restarted Vivaldi since my previous message.

    Please reopen the bug.


  • Moderator

    @lolmaus Oh, this is a hell for you.
    I will reopen. Done.


  • Moderator

    @lolmaus What happens if you install 3.3 Snapshot as Standalone Installation for a test to check if flicker is on 3.3, too.

    I remember something about trouble with monitors:
    Do the two monitors have same refresh rate?
    Are there special GSync settings in graphics driver or monitor?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.