How to connect Vivaldi through proxy when launched via gui



  • I'm running Vivaldi 3.2.1967.41 (Stable channel) (64-bit) on Ubuntu 20.04.1 LTS. When I start Vivaldi via a gui mode (e.g. Alt-F2, or Activities | vivaldi, or 'List Applications' | vivaldi) when I'm behind a proxy, Vivaldi cannot connect to the Internet, even though the system proxy settings are correct and it's configured to use the system proxy settings. I get a connection timed out. Firefox successfully connects. When I run Vivaldi from the command line from behind the same proxy, it connects through the proxy fine. If I'm not behind a proxy, Vivaldi connects fine when launched from a gui mode and from the command line. This just started happening recently and I have the same problem with Chrome. I've tried disabling all extensions to no avail.
    Any clues as to what's going on and how to fix?



  • I solved this problem in both Vivaldi and Chrome by launching both with the --proxy-auto-detect command-line parameter. With this, it picked up on the system proxy setting and I didn't have to mess with setting http_proxy anywhere.

    BTW, I was able to determine Vivaldi & Chrome had proxy problems by using Chrome and going to chrome://linux-proxy-config on Chrome and vivaldi://linux-proxy-config on Vivaldi. Both reported: "When running <browser> under a supported desktop environment, the system proxy settings will be used. However, either your system is not supported or there was a problem launching your system configuration.". I found the proxy-config link on the Chrome chrome://about page. Vivaldi has no such link on vivaldi://about.



  • Adding more information...it seems that the problem is that Vivaldi isn't picking up the System proxy settings. The reason it works when run from a command line is that the http_proxy environment variable is set there before Vivaldi is started.


  • Moderator

    This post is deleted!

  • Moderator

    This post is deleted!

  • Moderator

    @dmocek I set a Proxy manually in Ubuntu 20 > Network > Proxy settings.
    Works nice.

    How did you configure your proxy settings?



  • @Gwen-Dragon There are two ways I've tried it. One is automatically, where I specify a proxy script and the other is directly where I specify the proxy host and port. Both used to work for me, but something has changed that made it stop working.


  • Moderator

    @dmocek said in Vivaldi not connecting through proxy when launched via gui:

    One is automatically, where I specify a proxy script

    I remember that some time ago there were issues with proxy script.
    Do you use a WPAD or a special local proxy domain?
    How did you tell Vivaldi to use such proxy configuration script?

    and the other is directly where I specify the proxy host and port.

    How? Which command line?


    This works fine with my squid proxy:

    export http_proxy=localhost:3128
    export https_proxy=localhost:3128
    vivaldi -proxy-server="https://$https_proxy,http://$http_proxy"
    


  • Yes, our company uses a WPAD proxy script. However, I have also tried directly by using the 'Manual' method in Ubuntu's proxy settings.

    From the command-line, it works fine. I have http_proxy and https_proxy set on the command-line. The problem is that I used to be able to launch Vivaldi using Ubuntu's GUI (e.g. from the Activities list) and it would work through the proxy. Launching Vivaldi from the Activities list no longer works from behind a proxy even though the proxy is set in Ubuntu's Settings.


  • Moderator

    @dmocek Which proxy software?
    Which authentication to access proxy?
    Any security appliance/firewall used from LAN to internet access point (to router, dsl, fiber)?

    I do not know how your LAN administrator configures all, and i do not know how WPAD is distributed to your PCs, and i do not know the content of autoproxy config data.


  • Moderator

    @dmocek YOu could set the env variables in .profile file
    export https_proxy=.....
    export http_proxy=.....
    # and so on

    So you should have them after login to Linux.



    Other idea.
    Goto /usr/share/applications/ , edit laucher .desktop file for Vivaldi and add command line parameter for proxy[1][2] in value for Exec=....

    [1] https://www.chromium.org/developers/design-documents/network-settings
    [2] https://peter.sh/experiments/chromium-command-line-switches/#proxy-auto-detect and following --proxy.....

    If a paramter fails please tell which one!


  • Moderator

    @dmocek Excuse me, If that all does not help, you need to contact the Vivaldi support for get more information how to fix.


    Please contact the support.

    Open Vivaldi Support page, scroll down until you see "I need help with ...", select type, fill the form and send us message.
    Thanks for your feedback. The Support team will look into your request as soon as possible. Please note that their working hours are Monday to Friday, 08:00 CET - 18:00 CET.



  • I solved this problem in both Vivaldi and Chrome by launching both with the --proxy-auto-detect command-line parameter. With this, it picked up on the system proxy setting and I didn't have to mess with setting http_proxy anywhere.

    BTW, I was able to determine Vivaldi & Chrome had proxy problems by using Chrome and going to chrome://linux-proxy-config on Chrome and vivaldi://linux-proxy-config on Vivaldi. Both reported: "When running <browser> under a supported desktop environment, the system proxy settings will be used. However, either your system is not supported or there was a problem launching your system configuration.". I found the proxy-config link on the Chrome chrome://about page. Vivaldi has no such link on vivaldi://about.


  • Moderator

    @dmocek said in Vivaldi not connecting through proxy when launched via gui:

    I solved this problem in both Vivaldi and Chrome by launching both with the --proxy-auto-detect command-line parameter. With this, it picked up on the system proxy setting and I didn't have to mess with setting http_proxy anywhere.

    Ah, interesting. This is a useful information for others 👍
    I gonna tag your answer as a solution.

    I found the proxy-config link on the Chrome chrome://about page. Vivaldi has no such link on vivaldi://about.

    Some internal links have to be converted to vivaldi://-links. That is in progress.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.